summaryrefslogtreecommitdiff
path: root/net-p2p/monero/monero-0.17.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/monero/monero-0.17.3.0.ebuild')
-rw-r--r--net-p2p/monero/monero-0.17.3.0.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/net-p2p/monero/monero-0.17.3.0.ebuild b/net-p2p/monero/monero-0.17.3.0.ebuild
index 2d7f20d6..1b658a74 100644
--- a/net-p2p/monero/monero-0.17.3.0.ebuild
+++ b/net-p2p/monero/monero-0.17.3.0.ebuild
@@ -6,7 +6,7 @@ MONERO_GUI_PV=0.17.3.0
PYTHON_COMPAT=( python{3_8,3_9} )
CMAKE_MAKEFILE_GENERATOR="emake"
-inherit git-r3 cmake flag-o-matic toolchain-funcs python-any-r1 systemd
+inherit git-r3 cmake flag-o-matic toolchain-funcs python-any-r1 systemd qmake-utils
DESCRIPTION="Secure, private, untraceable cryptocurrency"
HOMEPAGE="https://getmonero.org"
@@ -55,7 +55,7 @@ RDEPEND="net-dns/unbound:=[threads]
acct-user/monero
acct-group/monero"
DEPEND="${RDEPEND}
- nls? ( dev-qt/qtchooser )"
+ nls? ( dev-qt/linguist-tools )"
BDEPEND="${PYTHON_DEPS}
doc? (
media-gfx/graphviz
@@ -96,6 +96,9 @@ src_prepare() {
export CXX=$(tc-getCXX)
tc-export_build_env BUILD_C{C,XX}
+ # Needed for lrelease
+ export PATH="${PATH}:$(qt5_get_bindir)" || die
+
append-cflags -DUSE_EXTRA_EC_CERT
append-cxxflags -DUSE_EXTRA_EC_CERT