summaryrefslogtreecommitdiff
path: root/net-p2p/monero/monero-0.12.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/monero/monero-0.12.2.0.ebuild')
-rw-r--r--net-p2p/monero/monero-0.12.2.0.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/net-p2p/monero/monero-0.12.2.0.ebuild b/net-p2p/monero/monero-0.12.2.0.ebuild
deleted file mode 100644
index 0f547569..00000000
--- a/net-p2p/monero/monero-0.12.2.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit cmake-utils
-
-DESCRIPTION="Secure, private, untraceable cryptocurrency"
-HOMEPAGE="https://getmonero.org"
-SRC_URI="https://github.com/monero-project/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="NEWLIB"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc qt5 readline smartcard +system-libs unwind"
-
-RDEPEND="dev-db/lmdb
- system-libs? (
- net-dns/unbound
- net-libs/miniupnpc
- )
- dev-libs/openssl:0
- dev-libs/boost:=
- net-libs/zeromq:=[sodium]
- net-libs/cppzmq:=
- dev-libs/rapidjson:=
- readline? ( sys-libs/readline:= )
- unwind? ( sys-libs/libunwind[lzma] )
- smartcard? (
- sys-apps/pcsc-lite
- >=app-crypt/ccid-1.4.28[usb]
- )"
-DEPEND=">=dev-util/cmake-3.0.0
- doc? (
- media-gfx/graphviz
- app-doc/doxygen:0
- )
- ${RDEPEND}"
-PDEPEND="qt5? ( =net-p2p/monero-gui-${PV} )"
-
-PATCHES=( "${FILESDIR}/${PV}-Drop-in-tree-miniupnpc.patch" )
-
-src_configure () {
- local mycmakeargs=(
- -DCMAKE_BUILD_TYPE=Release
- -DBUILD_DOCUMENTATION="$(usex doc ON OFF)"
- -DBUILD_TESTS=OFF
- -DCOVERAGE=OFF
- -DUSE_READLINE="$(usex readline ON OFF)"
- -DINSTALL_VENDORED_LIBUNBOUND="$(usex system-libs OFF ON)"
- -DBUILD_GUI_DEPS="$(usex qt5 ON OFF)"
- )
-
- export DATABASE="lmdb"
- export DEVELOPER_LOCAL_TOOLS=0
- export DEVELOPER_LIBUNBOUND_OLD=0
-
- cmake-utils_src_configure
-}