summaryrefslogtreecommitdiff
path: root/net-p2p/monero/files/monero-gui-0.17.1.1-cmake-remove-Werror.patch
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/monero/files/monero-gui-0.17.1.1-cmake-remove-Werror.patch')
-rw-r--r--net-p2p/monero/files/monero-gui-0.17.1.1-cmake-remove-Werror.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-p2p/monero/files/monero-gui-0.17.1.1-cmake-remove-Werror.patch b/net-p2p/monero/files/monero-gui-0.17.1.1-cmake-remove-Werror.patch
new file mode 100644
index 00000000..b7c19692
--- /dev/null
+++ b/net-p2p/monero/files/monero-gui-0.17.1.1-cmake-remove-Werror.patch
@@ -0,0 +1,39 @@
+From fbaf0c4b21fb5390758311ff70644623b6697bf2 Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Sat, 17 Oct 2020 18:27:24 +0100
+Subject: [PATCH] cmake: remove Werror
+
+See: https://bugs.gentoo.org/show_bug.cgi?id=652650
+---
+ CMakeLists.txt | 2 --
+ monero-wallet-gui.pro | 4 ++--
+ 2 files changed, 2 insertions(+), 4 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 197e7c301120..a865ec4fa922 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -422,8 +422,6 @@ if(APPLE)
+ endif()
+
+ # warnings
+-add_c_flag_if_supported(-Werror C_SECURITY_FLAGS)
+-add_cxx_flag_if_supported(-Werror CXX_SECURITY_FLAGS)
+ add_c_flag_if_supported(-Wformat C_SECURITY_FLAGS)
+ add_cxx_flag_if_supported(-Wformat CXX_SECURITY_FLAGS)
+ add_c_flag_if_supported(-Wformat-security C_SECURITY_FLAGS)
+diff --git a/monero-wallet-gui.pro b/monero-wallet-gui.pro
+index 271786236b98..49506e09e9e2 100644
+--- a/monero-wallet-gui.pro
++++ b/monero-wallet-gui.pro
+@@ -187,8 +187,8 @@ android {
+
+
+
+-QMAKE_CXXFLAGS += -Werror -Wformat -Wformat-security
+-QMAKE_CFLAGS += -Werror -Wformat -Wformat-security
++QMAKE_CXXFLAGS += -Wformat -Wformat-security
++QMAKE_CFLAGS += -Wformat -Wformat-security
+ QMAKE_CXXFLAGS_RELEASE += -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1 -O2
+ QMAKE_CFLAGS_RELEASE += -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1 -O2
+