summaryrefslogtreecommitdiff
path: root/net-p2p/monero/files/monero-0.18.3.4-translations-use-host-compiler.patch
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/monero/files/monero-0.18.3.4-translations-use-host-compiler.patch')
-rw-r--r--net-p2p/monero/files/monero-0.18.3.4-translations-use-host-compiler.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-p2p/monero/files/monero-0.18.3.4-translations-use-host-compiler.patch b/net-p2p/monero/files/monero-0.18.3.4-translations-use-host-compiler.patch
new file mode 100644
index 00000000..e51bef2f
--- /dev/null
+++ b/net-p2p/monero/files/monero-0.18.3.4-translations-use-host-compiler.patch
@@ -0,0 +1,43 @@
+From c927623016a946cddf6ba4e255cc9208929fa117 Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Sat, 30 Nov 2019 02:09:14 +0000
+Subject: [PATCH] translations: use host compiler
+
+Do not pass target compiler and compiler flags as
+generate_translations_header need to be created using host compiler and
+compiler flags
+---
+ CMakeLists.txt | 4 +++-
+ translations/CMakeLists.txt | 4 ++++
+ 2 files changed, 7 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index b05c087cf898..ef980115c9e1 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -671,7 +671,9 @@ ExternalProject_Add(generate_translations_header
+ SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/translations"
+ BINARY_DIR "${CMAKE_CURRENT_BINARY_DIR}/translations"
+ STAMP_DIR ${LRELEASE_PATH}
+- CMAKE_ARGS -DLRELEASE_PATH=${LRELEASE_PATH}
++ CMAKE_ARGS
++ -DCMAKE_TOOLCHAIN_FILE=${CMAKE_CURRENT_BINARY_DIR}/translations.cmake
++ -DLRELEASE_PATH=${LRELEASE_PATH}
+ INSTALL_COMMAND ${CMAKE_COMMAND} -E echo "")
+ include_directories("${CMAKE_CURRENT_BINARY_DIR}/translations")
+ add_subdirectory(external)
+diff --git a/translations/CMakeLists.txt b/translations/CMakeLists.txt
+index 3b43360f84c8..35fcae544a42 100644
+--- a/translations/CMakeLists.txt
++++ b/translations/CMakeLists.txt
+@@ -30,6 +30,10 @@ cmake_minimum_required(VERSION 3.5)
+
+ project(translations)
+
++# Ensure LDFLAGS for target are not propagated here since target are
++# meant for host
++UNSET(ENV{LDFLAGS})
++
+ # when crosscompiling import the executable targets from a file
+ IF(CMAKE_CROSSCOMPILING)
+ message(WARNING "CrossCompiling")