summaryrefslogtreecommitdiff
path: root/net-p2p/monero/files/monero-0.17.3.0-translations-use-host-compiler.patch
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/monero/files/monero-0.17.3.0-translations-use-host-compiler.patch')
-rw-r--r--net-p2p/monero/files/monero-0.17.3.0-translations-use-host-compiler.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-p2p/monero/files/monero-0.17.3.0-translations-use-host-compiler.patch b/net-p2p/monero/files/monero-0.17.3.0-translations-use-host-compiler.patch
new file mode 100644
index 00000000..40276b0a
--- /dev/null
+++ b/net-p2p/monero/files/monero-0.17.3.0-translations-use-host-compiler.patch
@@ -0,0 +1,43 @@
+From e10d750a15343998ae1b655947820cdb26e58276 Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Sat, 30 Nov 2019 02:09:14 +0000
+Subject: [PATCH] translations: use host compiler
+
+Do not pass target compiler and compiler flags as
+generate_translations_header need to be created using host compiler and
+compiler flags
+---
+ CMakeLists.txt | 4 +++-
+ translations/CMakeLists.txt | 4 ++++
+ 2 files changed, 7 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index ffb5abb82534..49f18a57cf7e 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -542,7 +542,9 @@ ExternalProject_Add(generate_translations_header
+ SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/translations"
+ BINARY_DIR "${CMAKE_CURRENT_BINARY_DIR}/translations"
+ STAMP_DIR ${LRELEASE_PATH}
+- CMAKE_ARGS -DLRELEASE_PATH=${LRELEASE_PATH}
++ CMAKE_ARGS
++ -DCMAKE_TOOLCHAIN_FILE=${CMAKE_CURRENT_BINARY_DIR}/translations.cmake
++ -DLRELEASE_PATH=${LRELEASE_PATH}
+ INSTALL_COMMAND cmake -E echo "")
+ include_directories("${CMAKE_CURRENT_BINARY_DIR}/translations")
+ add_subdirectory(external)
+diff --git a/translations/CMakeLists.txt b/translations/CMakeLists.txt
+index 7e31ed319e94..64bda84f055e 100644
+--- a/translations/CMakeLists.txt
++++ b/translations/CMakeLists.txt
+@@ -28,6 +28,10 @@
+
+ cmake_minimum_required(VERSION 3.5)
+
++# Ensure LDFLAGS for target are not propagated here since target are
++# meant for host
++UNSET(ENV{LDFLAGS})
++
+ project(translations)
+
+ # when crosscompiling import the executable targets from a file