summaryrefslogtreecommitdiff
path: root/net-p2p/monero/files/0.16.0.1-https-sourceware.org-bugzilla-show_bug.cgi-id-25210.patch
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/monero/files/0.16.0.1-https-sourceware.org-bugzilla-show_bug.cgi-id-25210.patch')
-rw-r--r--net-p2p/monero/files/0.16.0.1-https-sourceware.org-bugzilla-show_bug.cgi-id-25210.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-p2p/monero/files/0.16.0.1-https-sourceware.org-bugzilla-show_bug.cgi-id-25210.patch b/net-p2p/monero/files/0.16.0.1-https-sourceware.org-bugzilla-show_bug.cgi-id-25210.patch
new file mode 100644
index 00000000..941f4745
--- /dev/null
+++ b/net-p2p/monero/files/0.16.0.1-https-sourceware.org-bugzilla-show_bug.cgi-id-25210.patch
@@ -0,0 +1,46 @@
+From c62ddad29e57e5c7c535e860bc58db503bfcd8b7 Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Sat, 30 Nov 2019 03:25:11 +0000
+Subject: [PATCH] https://sourceware.org/bugzilla/show_bug.cgi?id=25210
+
+---
+ CMakeLists.txt | 19 -------------------
+ 1 file changed, 19 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 882bc96c56a2..2cb9c040634d 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -716,11 +716,6 @@ else()
+ CHECK_CXX_ACCEPTS_FLAG(-mfloat-abi=softfp CXX_ACCEPTS_MFLOAT_SOFTFP)
+ endif()
+
+- if(ARM8)
+- CHECK_CXX_ACCEPTS_FLAG(-mfix-cortex-a53-835769 CXX_ACCEPTS_MFIX_CORTEX_A53_835769)
+- CHECK_CXX_ACCEPTS_FLAG(-mfix-cortex-a53-843419 CXX_ACCEPTS_MFIX_CORTEX_A53_843419)
+- endif()
+-
+ if(ARM6)
+ message(STATUS "Selecting VFP for ARMv6")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -mfpu=vfp")
+@@ -757,20 +752,6 @@ else()
+ endif()
+ endif(ARM7)
+
+- if(ARM8)
+- if(CXX_ACCEPTS_MFIX_CORTEX_A53_835769)
+- message(STATUS "Enabling Cortex-A53 workaround 835769")
+- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -mfix-cortex-a53-835769")
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -mfix-cortex-a53-835769")
+- endif()
+-
+- if(CXX_ACCEPTS_MFIX_CORTEX_A53_843419)
+- message(STATUS "Enabling Cortex-A53 workaround 843419")
+- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -mfix-cortex-a53-843419")
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -mfix-cortex-a53-843419")
+- endif()
+- endif(ARM8)
+-
+ endif(ARM)
+
+ if(ANDROID AND NOT BUILD_GUI_DEPS STREQUAL "ON" OR IOS)