summaryrefslogtreecommitdiff
path: root/media-sound/azrael
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/azrael')
-rwxr-xr-xmedia-sound/azrael/azrael-0.3.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-sound/azrael/azrael-0.3.1.ebuild b/media-sound/azrael/azrael-0.3.1.ebuild
new file mode 100755
index 00000000..b43c3bc8
--- /dev/null
+++ b/media-sound/azrael/azrael-0.3.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit toolchain-funcs
+
+DESCRIPTION="GTK+ 2.6 based XMMS2 client"
+HOMEPAGE="https://sourceforge.net/projects/azrael/"
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=media-sound/xmms2-0.2
+ >=x11-libs/gtk+-2.6.0"
+
+RESTRICT="nomirror"
+
+S="${WORKDIR}/${PN}"
+
+src_compile () {
+ sed -i -e 's:\(CFLAGS = \).*:\0 ${MY_CFLAGS}:' Makefile
+ sed -i -e 's:\(LDFLAGS = \).*:\0 ${MY_LDFLAGS}:' Makefile
+ sed -i -e 's:\(CC = \).*:\1 ${MY_CC}:' Makefile
+
+ emake MY_CC="$(tc-getCC)" MY_CFLAGS="${CFLAGS}" MY_LDFLAGS="${LDFLAGS}" || die
+}
+
+src_install () {
+ exeinto /usr/bin
+ doexe azrael
+ dodoc ChangeLog INSTALL LICENSE
+}