summaryrefslogtreecommitdiff
path: root/app-crypt
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/acme/acme-20240728.ebuild24
-rw-r--r--app-crypt/acme/acme-9999.ebuild23
-rw-r--r--app-crypt/acme/metadata.xml8
3 files changed, 55 insertions, 0 deletions
diff --git a/app-crypt/acme/acme-20240728.ebuild b/app-crypt/acme/acme-20240728.ebuild
new file mode 100644
index 00000000..5a26551f
--- /dev/null
+++ b/app-crypt/acme/acme-20240728.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{11..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit git-r3 distutils-r1
+
+DESCRIPTION="ACME protocol implementation"
+HOMEPAGE="https://pants-on.net"
+EGIT_REPO_URI="https://git.pants-on.net/acme.git"
+EGIT_COMMIT="v${PVR}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm64"
+
+DEPEND="${PYTHON_DEPS} ${DISTUTILS_DEPS}
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/boto3[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
diff --git a/app-crypt/acme/acme-9999.ebuild b/app-crypt/acme/acme-9999.ebuild
new file mode 100644
index 00000000..9d80156d
--- /dev/null
+++ b/app-crypt/acme/acme-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{11..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit git-r3 distutils-r1
+
+DESCRIPTION="ACME protocol implementation"
+HOMEPAGE="https://pants-on.net"
+EGIT_REPO_URI="https://git.pants-on.net/acme.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+
+DEPEND="${PYTHON_DEPS} ${DISTUTILS_DEPS}
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/boto3[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
diff --git a/app-crypt/acme/metadata.xml b/app-crypt/acme/metadata.xml
new file mode 100644
index 00000000..82f7232e
--- /dev/null
+++ b/app-crypt/acme/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bertrand@jacquin.bzh</email>
+ <name>Bertrand Jacquin</name>
+ </maintainer>
+</pkgmetadata>