summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/irc/ChangeLog5
-rw-r--r--dev-python/irc/Manifest5
-rw-r--r--dev-python/irc/files/8.5.1-remove-hg-dependencies.diff18
-rw-r--r--dev-python/irc/irc-8.5.1.ebuild42
-rw-r--r--dev-python/irc/metadata.xml12
-rw-r--r--metadata/md5-cache/dev-python/irc-8.5.114
6 files changed, 96 insertions, 0 deletions
diff --git a/dev-python/irc/ChangeLog b/dev-python/irc/ChangeLog
new file mode 100644
index 00000000..615c436e
--- /dev/null
+++ b/dev-python/irc/ChangeLog
@@ -0,0 +1,5 @@
+*irc-8.5.1 (19 Sep 2013)
+
+ 19 Sep 2013; Bertrand Jacquin <beber@meleeweb.net>
+ +files/8.5.1-remove-hg-dependencies.diff, +irc-8.5.1.ebuild, +metadata.xml:
+ dev-python/irc: Remove dependencie on dos2unix and hgtools, bug #485398
diff --git a/dev-python/irc/Manifest b/dev-python/irc/Manifest
new file mode 100644
index 00000000..edb905ae
--- /dev/null
+++ b/dev-python/irc/Manifest
@@ -0,0 +1,5 @@
+AUX 8.5.1-remove-hg-dependencies.diff 583 SHA256 202ee36d788c70dc7a53a5f3907e35c91f54636d293b0a1e68d378318f9993b2 WHIRLPOOL d7c26859a8b25c6ffdc1f6dc49a09b03050023a6046c0c277cff0d48df09d771e0891cf7bd097bc8c6bfc01d6e82a45e63dc4d53662c3377e50c3a4d13296b29
+DIST irc-8.5.1.zip 112916 SHA256 ff29edb5c51bbf6583f60f677e846b3eb651374c2f6b39800e4b4947c989b8db WHIRLPOOL e24d1a8155dd79e840aceb085f0a6d6fd0c0cafb356c64604c01555d4a6189e8e8dbc4824f74d58c45731615d24fe1606987b70dacf40375354134d200373d13
+EBUILD irc-8.5.1.ebuild 1170 SHA256 c4d73c04e56173441e1a4ed88d5f6c6565cef7f0afdb9103001c69f2c598de30 WHIRLPOOL 1a39fd06bb546b67e0448a3b0cffb4df7efeab1cdaedd538dd7b5bf28673e5652311f392f22a25a1b2d606083a108d1bcb1c299257584ac9f204aa3de1c48b7a
+MISC ChangeLog 231 SHA256 0dd285ce002163aad5a68603d8737008f3fd20fde3641a2ad48f2e61ac236504 WHIRLPOOL 83725da9caf65851c125e381ea4248ab9b88c3e8acd6d9913fdb00638f11059e9ee3b28d6882f23dc409b11fa600f2502770428a74c431ba908a6c4debd465d4
+MISC metadata.xml 451 SHA256 f70c308344515f83623dba873f7cb705345bee7975fb4d2d4e2f91fcb54ff78b WHIRLPOOL d0eae6b6587c195d8140dfb271babab330c125ce12c10108a89dd247d6c9241852b8eaee285ead3ece28b982ae6f9e2b349476311255bacf085fafa369608a09
diff --git a/dev-python/irc/files/8.5.1-remove-hg-dependencies.diff b/dev-python/irc/files/8.5.1-remove-hg-dependencies.diff
new file mode 100644
index 00000000..75348799
--- /dev/null
+++ b/dev-python/irc/files/8.5.1-remove-hg-dependencies.diff
@@ -0,0 +1,18 @@
+--- setup.py.ori 2013-09-19 12:48:38.946374470 +0200
++++ setup.py 2013-09-19 12:48:57.766779291 +0200
+@@ -16,7 +16,6 @@
+ name="irc",
+ description="IRC (Internet Relay Chat) protocol client library for Python",
+ long_description=read_long_description(),
+- use_hg_version=True,
+ packages=setuptools.find_packages(),
+ author="Joel Rosdahl",
+ author_email="joel@rosdahl.net",
+@@ -35,7 +34,6 @@
+ 'six',
+ ] + importlib_req + argparse_req,
+ setup_requires=[
+- 'hgtools',
+ 'pytest-runner',
+ ],
+ tests_require=[
diff --git a/dev-python/irc/irc-8.5.1.ebuild b/dev-python/irc/irc-8.5.1.ebuild
new file mode 100644
index 00000000..bf9c5c9a
--- /dev/null
+++ b/dev-python/irc/irc-8.5.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/irc/irc-8.5.1.ebuild,v 1.1 2013/08/26 02:38:37 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="IRC client framework written in Python."
+HOMEPAGE="https://bitbucket.org/jaraco/irc http://pypi.python.org/pypi/irc"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+DEPEND="app-arch/unzip
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+
+RDEPEND="!>=dev-python/python-irclib-3.2.2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # Don't rely on hgtools for version
+ epatch "${FILESDIR}/${PV}-remove-hg-dependencies.diff"
+ sed -e "/^tag_/d" -i setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test irc/tests || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( scripts/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/irc/metadata.xml b/dev-python/irc/metadata.xml
new file mode 100644
index 00000000..2a4530a4
--- /dev/null
+++ b/dev-python/irc/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription>
+ This project includes an event-driven IRC client framework written in Python,
+ as well as an object-oriented wrapper class and some example programs.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">irc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/metadata/md5-cache/dev-python/irc-8.5.1 b/metadata/md5-cache/dev-python/irc-8.5.1
new file mode 100644
index 00000000..269c6fa3
--- /dev/null
+++ b/metadata/md5-cache/dev-python/irc-8.5.1
@@ -0,0 +1,14 @@
+DEFINED_PHASES=compile configure install prepare test
+DEPEND=app-arch/unzip dev-python/pytest-runner[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_pypy2_0(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)] test? ( dev-python/pytest[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_pypy2_0(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)] dev-python/mock[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_pypy2_0(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)] ) userland_GNU? ( >=sys-apps/coreutils-8.5 ) python_targets_python2_6? ( dev-lang/python:2.6 ) python_targets_python2_7? ( dev-lang/python:2.7 ) python_targets_python3_2? ( dev-lang/python:3.2 ) python_targets_python3_3? ( dev-lang/python:3.3 ) python_targets_pypy2_0? ( virtual/pypy:2.0 ) dev-python/python-exec:=[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_pypy2_0(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)]
+DESCRIPTION=IRC client framework written in Python.
+EAPI=5
+HOMEPAGE=https://bitbucket.org/jaraco/irc http://pypi.python.org/pypi/irc
+IUSE=examples test python_targets_python2_6 python_targets_python2_7 python_targets_python3_2 python_targets_python3_3 python_targets_pypy2_0
+KEYWORDS=~amd64 ~x86
+LICENSE=LGPL-2.1
+RDEPEND=!>=dev-python/python-irclib-3.2.2[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_pypy2_0(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)] dev-python/six[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_pypy2_0(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)] python_targets_python2_6? ( dev-lang/python:2.6 ) python_targets_python2_7? ( dev-lang/python:2.7 ) python_targets_python3_2? ( dev-lang/python:3.2 ) python_targets_python3_3? ( dev-lang/python:3.3 ) python_targets_pypy2_0? ( virtual/pypy:2.0 ) dev-python/python-exec:=[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_pypy2_0(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)]
+REQUIRED_USE=|| ( python_targets_python2_6 python_targets_python2_7 python_targets_python3_2 python_targets_python3_3 python_targets_pypy2_0 )
+SLOT=0
+SRC_URI=mirror://pypi/i/irc/irc-8.5.1.zip
+_eclasses_=distutils-r1 0d8cd7220d2bf75b999ed76b525565b0 eutils 4878e7f88afc0ba0866ac112190b0fd4 multibuild 56d4120419072116417e8de1bd1040ff multilib 892e597faee02a5b94eb02ab512e7622 multiprocessing a2130e6fc4aa4c6a24b265ca0cbcc2b6 python-r1 2876e182a9a350a7e0049caf3bf3be12 python-utils-r1 a4940acdd0a5ebdc58aaedd38de4983a toolchain-funcs 7ffd28a8c7eea27218865352bfd3ab2f user d0a4d0735a6c0183d707ca919bd72f28
+_md5_=cfcbe1c9f309c3a2be3f038e162a5a55