summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-dns/host/Manifest3
-rw-r--r--net-dns/host/files/host-20070128-Makefile.patch62
-rw-r--r--net-dns/host/host-20070128-r1.ebuild42
3 files changed, 107 insertions, 0 deletions
diff --git a/net-dns/host/Manifest b/net-dns/host/Manifest
new file mode 100644
index 00000000..bb14647b
--- /dev/null
+++ b/net-dns/host/Manifest
@@ -0,0 +1,3 @@
+AUX host-20070128-Makefile.patch 1444 SHA256 b4f44f54039d4b03f2c866587a7d6d230fe9491e1229afbbf11dd151a66ae1cb SHA512 69398082628b37777498ba359798be745fc0d2d7c8bcd8b9076f57e76d69d9173a7eca4bee3f90da256e551a7d3dd57bc62869f880994f8c1a3a03259b2acb59 WHIRLPOOL 914b5742e61edc73999e3ba071bd3c93222a326b1a83651d00dffe9e4fbe11e5e5bf5a266e18b5f4d48e8f6f8cc9e65a93ae0f119072359e530f08862257f07e
+DIST host-20070128.tar.gz 152347 SHA256 a2a56ab236f9e8549366175a3055e0dc7758dafd46658ed8bea58d87de39bd9f SHA512 80f4d4878af40c93f33cc6c43d19b01415e66b3939b157544b4921b9f0b83ef1baa9ce0e151d951417be92973c4b038df80efae974be4bca2bbce43299db65fc WHIRLPOOL 7072f75f1f39b25375f38387625ced95469f7baeeed069429718a5cb438ee0751a612e3ac0f76e91af9ca653ebe97487476dac2cdaeb1d1fc21a49d67ba62527
+EBUILD host-20070128-r1.ebuild 1279 SHA256 b7c6df796efb45d1db350c307be8cab433e29ec79e038d5e06442c04960c253d SHA512 bcfc7be90a7ac54fe8dcd28af5034d850c36dac6232815326c3d8c7cd2d0f03addfa5198b40f7f452ce8d26046a0790f672ae0fa38b54801a163376062b88a7f WHIRLPOOL 1d91f56ea8b360e3c316237f21c36e7077bf6d641ddd17a524de60fdf656eb40819d1a291775788014ab47f5a31a885cc35b7e462320d28206e01cd9e2bfe449
diff --git a/net-dns/host/files/host-20070128-Makefile.patch b/net-dns/host/files/host-20070128-Makefile.patch
new file mode 100644
index 00000000..931c4389
--- /dev/null
+++ b/net-dns/host/files/host-20070128-Makefile.patch
@@ -0,0 +1,62 @@
+--- Makefile.orig 2003-06-05 03:01:45.000000000 +0200
++++ Makefile 2010-03-12 18:53:17.000000000 +0100
+@@ -117,16 +117,11 @@
+ # Compilation definitions.
+ # ----------------------------------------------------------------------
+
+-DEBUGDEFS = -DDEBUG
+
+ DEFS = $(CONFIGDEFS) $(DEBUGDEFS) $(SYSDEFS) $(INCLUDES)
+
+-COPTS = -pipe
+
+-COPTIM = -O2
+-COPTIM = -O
+
+-CDEBUG = -g
+
+ # GCC lint-like warnings -- any warnings are likely bugs in the
+ # platform headers or in gcc itself....
+@@ -139,7 +134,6 @@
+ -Wswitch \
+ -Wcomment \
+ -Wcast-qual \
+- -Wid-clash-30 \
+ -Wpointer-arith \
+ -Wshadow
+ #endif
+@@ -147,7 +141,6 @@
+ #if $(__GNULD__) >= 1
+ GNULDWARNFLAGS = -W \
+ -Wall \
+- -Wid-clash-30
+ #endif
+
+ #if $(__GNUC__) >= 2
+@@ -169,7 +162,7 @@
+ #endif
+
+ CPPFLAGS = $(DEFS)
+-CFLAGS = $(COPTS) $(CDEBUG) $(COPTIM) $(GCCWARNFLAGS) $(GCC2WARNFLAGS) $(GCC3WARNFLAGS)
++CFLAGS += $(GCCWARNFLAGS) $(GCC2WARNFLAGS) $(GCC3WARNFLAGS)
+
+ # Select your favorite compiler if make doesn't already know it...
+ #if defined(next)
+@@ -250,7 +243,7 @@
+ # Unfortunately SunOS-5.9 has only libresolv.so !!!
+ #
+ #if defined(NEED_LIBRESOLV) && !defined(sunos5.x) && !(BIND-8.4.x)
+-LDFLAGS = -static $(GNULDWARNFLAGS)
++LDFLAGS += $(GNULDWARNFLAGS)
+ #else
+ #LDFLAGS = $(GNULDWARNFLAGS)
+ #endif
+@@ -294,7 +287,7 @@
+ # ----------------------------------------------------------------------
+
+ BINOWN = root
+-BINGRP = staff
++BINGRP = root
+ BINMODE = 755
+ #STRIPFLAG = -s
+
diff --git a/net-dns/host/host-20070128-r1.ebuild b/net-dns/host/host-20070128-r1.ebuild
new file mode 100644
index 00000000..44e019e9
--- /dev/null
+++ b/net-dns/host/host-20070128-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/host/host-20070128-r1.ebuild,v 1.7 2012/09/24 18:57:27 armin76 Exp $
+
+EAPI="2"
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="A powerful command-line DNS query and test tool implementing many additional protocols"
+HOMEPAGE="http://www.weird.com/~woods/projects/host.html"
+SRC_URI="ftp://ftp.weird.com/pub/Planix/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ppc sparc x86"
+IUSE="debug"
+
+# Bug 91515
+RESTRICT="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-Makefile.patch"
+ sed -i -e "s:^\(# if defined(__alpha).*\):\1 || defined(__x86_64__):" \
+ port.h || die "sed failed"
+}
+
+src_compile() {
+ use debug && export DEBUGDEFS="-DDEBUG"
+ emake CC="$(tc-getCC)" RES_LIB="${ROOT}usr/$(get_libdir)/libresolv.a" || die "emake failed"
+}
+
+src_install () {
+ # This tool has slightly different format of output from "standard" host.
+ # Renaming it to host-woods, hopefully this does not conflict with anything.
+
+ newbin host host-woods || die "newbin failed"
+ newman host.1 host-woods.1 || die "newman failed"
+ dodoc RELEASE_NOTES ToDo || die "dodoc failed"
+}