summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/monero/Manifest1
-rw-r--r--net-p2p/monero/files/0.12.3.0-Drop-in-tree-miniupnpc.patch57
-rw-r--r--net-p2p/monero/monero-0.12.3.0.ebuild58
3 files changed, 116 insertions, 0 deletions
diff --git a/net-p2p/monero/Manifest b/net-p2p/monero/Manifest
index dfabbdee..aedd44a7 100644
--- a/net-p2p/monero/Manifest
+++ b/net-p2p/monero/Manifest
@@ -1,2 +1,3 @@
DIST monero-0.11.1.0.tar.gz 55329159 BLAKE2B ca543f6694a9117b12f6a0acf852943387d8c95215c9c70ea5a1e75595119715a255d9717cf76dfce00e88b5d01701949e352c4d1376b583de1e187b82664d1c SHA512 bac3520730164afe2ca992c588bd0b51791d986cd8d5ebcaac5bd48185b963e2391c28ee89399d7dd678a5d1f8b41c3ae5724d194a5f62bbcd3e6ad505986573
DIST monero-0.12.2.0.tar.gz 8431190 BLAKE2B c1314d3a220327851149760763d27594cba1325935d5c0e9cfa205ea3930fb25e27d7785aa99718277b4ccddb1c76924738a2a538b9790d880c4220de766968b SHA512 2d5f151e800c27050d4008a850d4eea2cc59b9d8f7f92f504b7189ec4eb6221fd5d693bf8e815ea9879f3bbee0c9acebc58acdc97fe86c3f11780565373f88bc
+DIST monero-0.12.3.0.tar.gz 8431327 BLAKE2B dfc46780ff26ba9369afc869ee37fbe252a5999246b9fc3732cdd78bf9a8d416fdddcc91b59aebce363021fd9719fd8838e3d99e01ad352b5d345b2003be0e43 SHA512 9e78a66c2f76ebcefd355442f659a9a02298ec34ffca5ee514763b688d999da25cd1b96dd98255bacda7448e783b1c52e8d9effbbf3a75d1f0be1b5788d4b1ca
diff --git a/net-p2p/monero/files/0.12.3.0-Drop-in-tree-miniupnpc.patch b/net-p2p/monero/files/0.12.3.0-Drop-in-tree-miniupnpc.patch
new file mode 100644
index 00000000..c7b9d543
--- /dev/null
+++ b/net-p2p/monero/files/0.12.3.0-Drop-in-tree-miniupnpc.patch
@@ -0,0 +1,57 @@
+From 694352e707574580d4249ead6673ffa2e7fcd0c2 Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Sun, 17 Jun 2018 22:34:11 +0100
+Subject: [PATCH] Drop in-tree miniupnpc
+
+Since 6b8539803184 ("Build: update CMake and p2p for in-tree
+miniupnp"), a hard dependency is made on miniupnpc which is a git
+submodule not part of the archive available upstream.
+---
+ external/CMakeLists.txt | 16 +++-------------
+ src/p2p/net_node.inl | 6 +++---
+ 2 files changed, 6 insertions(+), 16 deletions(-)
+
+diff --git a/external/CMakeLists.txt b/external/CMakeLists.txt
+index 1fc4d64c1cbf..48a6a9a32f08 100644
+--- a/external/CMakeLists.txt
++++ b/external/CMakeLists.txt
+@@ -36,19 +36,9 @@
+ # others.
+
+ find_package(Miniupnpc REQUIRED)
+-
+-message(STATUS "Using in-tree miniupnpc")
+-
+-add_subdirectory(miniupnp/miniupnpc)
+-
+-set_property(TARGET libminiupnpc-static PROPERTY FOLDER "external")
+-if(MSVC)
+- set_property(TARGET libminiupnpc-static APPEND_STRING PROPERTY COMPILE_FLAGS " -wd4244 -wd4267")
+-elseif(NOT MSVC)
+- set_property(TARGET libminiupnpc-static APPEND_STRING PROPERTY COMPILE_FLAGS " -Wno-undef -Wno-unused-result -Wno-unused-value")
+-endif()
+-
+-set(UPNP_LIBRARIES "libminiupnpc-static" PARENT_SCOPE)
++set(UPNP_STATIC false PARENT_SCOPE)
++set(UPNP_INCLUDE ${MINIUPNP_INCLUDE_DIR} PARENT_SCOPE)
++set(UPNP_LIBRARIES ${MINIUPNP_LIBRARY} PARENT_SCOPE)
+
+ find_package(Unbound)
+
+diff --git a/src/p2p/net_node.inl b/src/p2p/net_node.inl
+index 07f369d40544..e10e4cfbc606 100644
+--- a/src/p2p/net_node.inl
++++ b/src/p2p/net_node.inl
+@@ -49,9 +49,9 @@
+ #include "storages/levin_abstract_invoke2.h"
+ #include "cryptonote_core/cryptonote_core.h"
+
+-#include <miniupnp/miniupnpc/miniupnpc.h>
+-#include <miniupnp/miniupnpc/upnpcommands.h>
+-#include <miniupnp/miniupnpc/upnperrors.h>
++#include <miniupnpc/miniupnpc.h>
++#include <miniupnpc/upnpcommands.h>
++#include <miniupnpc/upnperrors.h>
+
+ #undef MONERO_DEFAULT_LOG_CATEGORY
+ #define MONERO_DEFAULT_LOG_CATEGORY "net.p2p"
diff --git a/net-p2p/monero/monero-0.12.3.0.ebuild b/net-p2p/monero/monero-0.12.3.0.ebuild
new file mode 100644
index 00000000..0f547569
--- /dev/null
+++ b/net-p2p/monero/monero-0.12.3.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils
+
+DESCRIPTION="Secure, private, untraceable cryptocurrency"
+HOMEPAGE="https://getmonero.org"
+SRC_URI="https://github.com/monero-project/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="NEWLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc qt5 readline smartcard +system-libs unwind"
+
+RDEPEND="dev-db/lmdb
+ system-libs? (
+ net-dns/unbound
+ net-libs/miniupnpc
+ )
+ dev-libs/openssl:0
+ dev-libs/boost:=
+ net-libs/zeromq:=[sodium]
+ net-libs/cppzmq:=
+ dev-libs/rapidjson:=
+ readline? ( sys-libs/readline:= )
+ unwind? ( sys-libs/libunwind[lzma] )
+ smartcard? (
+ sys-apps/pcsc-lite
+ >=app-crypt/ccid-1.4.28[usb]
+ )"
+DEPEND=">=dev-util/cmake-3.0.0
+ doc? (
+ media-gfx/graphviz
+ app-doc/doxygen:0
+ )
+ ${RDEPEND}"
+PDEPEND="qt5? ( =net-p2p/monero-gui-${PV} )"
+
+PATCHES=( "${FILESDIR}/${PV}-Drop-in-tree-miniupnpc.patch" )
+
+src_configure () {
+ local mycmakeargs=(
+ -DCMAKE_BUILD_TYPE=Release
+ -DBUILD_DOCUMENTATION="$(usex doc ON OFF)"
+ -DBUILD_TESTS=OFF
+ -DCOVERAGE=OFF
+ -DUSE_READLINE="$(usex readline ON OFF)"
+ -DINSTALL_VENDORED_LIBUNBOUND="$(usex system-libs OFF ON)"
+ -DBUILD_GUI_DEPS="$(usex qt5 ON OFF)"
+ )
+
+ export DATABASE="lmdb"
+ export DEVELOPER_LOCAL_TOOLS=0
+ export DEVELOPER_LIBUNBOUND_OLD=0
+
+ cmake-utils_src_configure
+}