summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/cpplint/ChangeLog3
-rw-r--r--dev-util/cpplint/Manifest3
-rw-r--r--dev-util/cpplint/cpplint-9999.ebuild30
-rw-r--r--dev-util/cpplint/metadata.xml8
-rw-r--r--licenses/cpplint25
-rw-r--r--metadata/md5-cache/dev-util/cpplint-999910
6 files changed, 79 insertions, 0 deletions
diff --git a/dev-util/cpplint/ChangeLog b/dev-util/cpplint/ChangeLog
new file mode 100644
index 00000000..30e2daf1
--- /dev/null
+++ b/dev-util/cpplint/ChangeLog
@@ -0,0 +1,3 @@
+ 02 Sep 2013; Bertrand Jacquin <beber@meleeweb.net> +metadata.xml:
+ dev-util/cpplint: Checker to make sure a C++ file follows Google's C++ style
+ guide
diff --git a/dev-util/cpplint/Manifest b/dev-util/cpplint/Manifest
new file mode 100644
index 00000000..3331530a
--- /dev/null
+++ b/dev-util/cpplint/Manifest
@@ -0,0 +1,3 @@
+EBUILD cpplint-9999.ebuild 665 SHA256 69745344849b097ac6f0673f04700cb7bb861e4cee2ba6b101ac866d62b941d3 WHIRLPOOL d59b451a9c40717aa97923f29891cdae3e5e44c6c85038524b0dde08d910de7ccc2b773d1a875bcc39049b8e56c319bc9354bff5b7823898a3240334c41253a8
+MISC ChangeLog 155 SHA256 0a7ac4fc2c938e0fa7eb90b877418179e2ae6f420a08fbb8001400a550c5db1c WHIRLPOOL be34ad2696f22fb74cea299c2e7361c4b6a50be0edcfff5851e9f23e773d570ad4d0431e822c7abcef2894dfe332056960517010dac43844bbfc6f38b1f63168
+MISC metadata.xml 254 SHA256 c56bc3d6780712c960298c70bb86867aeb6661e97a317cc624516b0e16b72fcc WHIRLPOOL 2ebbfaa14ef0c1847284fe64a79f052cd7e73b25a724fba728c084aaaf2dd0692e068eedcf42ccef7e205077f00c35780ded7ec69118dc01ddb988b4802e46ae
diff --git a/dev-util/cpplint/cpplint-9999.ebuild b/dev-util/cpplint/cpplint-9999.ebuild
new file mode 100644
index 00000000..30791355
--- /dev/null
+++ b/dev-util/cpplint/cpplint-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_{6,7} )
+
+inherit python-single-r1 subversion
+
+DESCRIPTION="Checker to make sure a C++ file follows Google's C++ style guide"
+HOMEPAGE="https://code.google.com/p/google-styleguide"
+ESVN_REPO_URI="http://google-styleguide.googlecode.com/svn/trunk/${PN}"
+
+LICENSE="cpplint"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+src_test() {
+ einfo "Running ${EPYTHON} cpplint_unittest.py"
+ ${EPYTHON} cpplint_unittest.py --verbose \
+ || die "cpplint_unittest.py failed"
+}
+
+src_install() {
+ python_doscript cpplint.py
+
+ dodoc README
+}
diff --git a/dev-util/cpplint/metadata.xml b/dev-util/cpplint/metadata.xml
new file mode 100644
index 00000000..933498d8
--- /dev/null
+++ b/dev-util/cpplint/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>beber@meleeweb.net</email>
+ <name>Bertrand Jacquin</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/licenses/cpplint b/licenses/cpplint
new file mode 100644
index 00000000..063941ff
--- /dev/null
+++ b/licenses/cpplint
@@ -0,0 +1,25 @@
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are
+met:
+
+ * Redistributions of source code must retain the above copyright
+notice, this list of conditions and the following disclaimer.
+ * Redistributions in binary form must reproduce the above
+copyright notice, this list of conditions and the following disclaimer
+in the documentation and/or other materials provided with the
+distribution.
+ * Neither the name of Google Inc. nor the names of its
+contributors may be used to endorse or promote products derived from
+this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/metadata/md5-cache/dev-util/cpplint-9999 b/metadata/md5-cache/dev-util/cpplint-9999
new file mode 100644
index 00000000..3fc17143
--- /dev/null
+++ b/metadata/md5-cache/dev-util/cpplint-9999
@@ -0,0 +1,10 @@
+DEFINED_PHASES=install preinst prepare setup test unpack
+DEPEND=|| ( dev-vcs/subversion[webdav-neon] dev-vcs/subversion[webdav-serf] ) net-misc/rsync
+DESCRIPTION=Checker to make sure a C++ file follows Google's C++ style guide
+EAPI=5
+HOMEPAGE=https://code.google.com/p/google-styleguide
+IUSE=test python_targets_python2_6 python_targets_python2_7 python_single_target_python2_6 python_single_target_python2_7
+LICENSE=cpplint
+SLOT=0
+_eclasses_=eutils 63afaaed8aa819fdcb814c7cd39495a2 multilib 892e597faee02a5b94eb02ab512e7622 python-single-r1 b13f5baea5da0da5a5dcc6b8b79706a2 python-utils-r1 3668f5e62c6e2526acef650e8e1e8fc4 subversion e80e84db0fc102c2959858102060bec9 toolchain-funcs 7ffd28a8c7eea27218865352bfd3ab2f user d0a4d0735a6c0183d707ca919bd72f28
+_md5_=e5fdda1e513b28e13d8f2c701f3e18bd