summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-client/arcanist/arcanist-20191119.ebuild14
-rw-r--r--www-client/arcanist/arcanist-9999.ebuild14
2 files changed, 16 insertions, 12 deletions
diff --git a/www-client/arcanist/arcanist-20191119.ebuild b/www-client/arcanist/arcanist-20191119.ebuild
index 7353f9a6..c82eb845 100644
--- a/www-client/arcanist/arcanist-20191119.ebuild
+++ b/www-client/arcanist/arcanist-20191119.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_COMPAT=( python{3_7,3_8} )
PYTHON_REQ_USE="ncurses"
inherit bash-completion-r1 python-single-r1 git-r3
@@ -44,6 +44,12 @@ RDEPEND="dev-lang/php[cli,curl,json,ssl?]
net-libs/nodejs:0[npm]
)"
+PATCHES=(
+ "${FILESDIR}/${PV}-MINOR-Disable-self-upgrade.patch"
+ "${FILESDIR}/${PV}-MEDIUM-Get-VERSION-for-files-in-usr-share-PN-GIT_COM.patch"
+ "${FILESDIR}/${PV}-breakout-migrate-to-python3.patch"
+)
+
src_test() {
einfo "Note that you need to install some Node JS script manually:"
einfo " npm install -g coffeelint"
@@ -82,10 +88,6 @@ src_prepare() {
git remote add origin "${EGIT_REPO_URI}"
git remote -v > "${S}/GIT_REMOTE_INFO"
- eapply "${FILESDIR}/${PV}-MINOR-Disable-self-upgrade.patch"
- eapply "${FILESDIR}/${PV}-MEDIUM-Get-VERSION-for-files-in-usr-share-PN-GIT_COM.patch"
- eapply "${FILESDIR}/${PV}-breakout-migrate-to-python3.patch"
-
find "${S}" -type f -name .gitignore -print0 \
| xargs -0 --no-run-if-empty -- \
rm
diff --git a/www-client/arcanist/arcanist-9999.ebuild b/www-client/arcanist/arcanist-9999.ebuild
index 15a82346..1ce90854 100644
--- a/www-client/arcanist/arcanist-9999.ebuild
+++ b/www-client/arcanist/arcanist-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_COMPAT=( python{3_7,3_8} )
PYTHON_REQ_USE="ncurses"
inherit bash-completion-r1 python-single-r1 git-r3
@@ -42,6 +42,12 @@ RDEPEND="dev-lang/php[cli,curl,json,ssl?]
net-libs/nodejs:0[npm]
)"
+PATCHES=(
+ "${FILESDIR}/${PV}-MINOR-Disable-self-upgrade.patch"
+ "${FILESDIR}/${PV}-MEDIUM-Get-VERSION-for-files-in-usr-share-PN-GIT_COM.patch"
+ "${FILESDIR}/${PV}-breakout-migrate-to-python3.patch"
+)
+
src_test() {
einfo "Note that you need to install some Node JS script manually:"
einfo " npm install -g coffeelint"
@@ -80,10 +86,6 @@ src_prepare() {
git remote add origin "${EGIT_REPO_URI}"
git remote -v > "${S}/GIT_REMOTE_INFO"
- eapply "${FILESDIR}/${PV}-MINOR-Disable-self-upgrade.patch"
- eapply "${FILESDIR}/${PV}-MEDIUM-Get-VERSION-for-files-in-usr-share-PN-GIT_COM.patch"
- eapply "${FILESDIR}/${PV}-breakout-migrate-to-python3.patch"
-
find "${S}" -type f -name .gitignore -print0 \
| xargs -0 --no-run-if-empty -- \
rm