summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/monero/monero-0.17.2.0.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/net-p2p/monero/monero-0.17.2.0.ebuild b/net-p2p/monero/monero-0.17.2.0.ebuild
index b8d0fdb8..92826abe 100644
--- a/net-p2p/monero/monero-0.17.2.0.ebuild
+++ b/net-p2p/monero/monero-0.17.2.0.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+MONERO_GUI_PV=0.17.2.2
PYTHON_COMPAT=( python{3_7,3_8,3_9} )
CMAKE_MAKEFILE_GENERATOR="emake"
@@ -12,6 +13,7 @@ HOMEPAGE="https://getmonero.org"
EGIT_REPO_URI="https://github.com/monero-project/${PN}.git"
EGIT_COMMIT="v${PV}"
+EGIT_COMMIT_GUI="v${MONERO_GUI_PV}"
EGIT_SUBMODULES=( external/trezor-common external/supercop external/quirc )
LICENSE="NEWLIB"
@@ -82,7 +84,7 @@ src_unpack() {
git-r3_src_unpack
if use qt5 ; then
- git-r3_fetch "https://github.com/monero-project/${PN}-gui.git" "${EGIT_COMMIT}"
+ git-r3_fetch "https://github.com/monero-project/${PN}-gui.git" "${EGIT_COMMIT_GUI}"
git-r3_checkout "https://github.com/monero-project/${PN}-gui.git" "${WORKDIR}/monero-gui-${PV}"
rm -rf "${WORKDIR}/monero-gui-${PV}/monero" || die
@@ -109,7 +111,7 @@ src_prepare() {
S="${CMAKE_USE_DIR}" PATCHES="${PATCHES_MONERO_GUI[@]}" cmake_src_prepare
sed -i \
- -e "s/@@PV@@/${PV}/" \
+ -e "s/@@PV@@/${MONERO_GUI_PV}/" \
"${WORKDIR}/monero-gui-${PV}/cmake/VersionGui.cmake" \
|| die
fi