summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/tcptrace/Manifest3
-rw-r--r--net-analyzer/tcptrace/files/tcptrace-6.6.7-BJA-cross.diff50
-rw-r--r--net-analyzer/tcptrace/tcptrace-6.6.7.ebuild43
3 files changed, 96 insertions, 0 deletions
diff --git a/net-analyzer/tcptrace/Manifest b/net-analyzer/tcptrace/Manifest
new file mode 100644
index 00000000..9a23e831
--- /dev/null
+++ b/net-analyzer/tcptrace/Manifest
@@ -0,0 +1,3 @@
+AUX tcptrace-6.6.7-BJA-cross.diff 1436 RMD160 0dc6a9a174c3ce1f57ac0d829ec4372fcb4b85b3 SHA1 2f8b7d65af26418768929cb4e78820e24341ef09 SHA256 1c47654c546b9bdac86f449b3bf1257c44a2cc0acfc840fa16ac98a8d2560b98
+DIST tcptrace-6.6.7.tar.gz 3773308 RMD160 1dd0f373f766322343ffad59d0655eba4c6682e0 SHA1 ae4d10a0829c57f2eda17e63f593e558f52b7f24 SHA256 63380a4051933ca08979476a9dfc6f959308bc9f60d45255202e388eb56910bd
+EBUILD tcptrace-6.6.7.ebuild 1028 RMD160 8a456bd6528dd123ecc68768dd34a6eadd306c1b SHA1 21254e69465ec3e5d3f8b759108c0597bfebeb68 SHA256 298110be60d8866ba40b2463f14947e91009bb9587b8c312e2035fb7c0915b3e
diff --git a/net-analyzer/tcptrace/files/tcptrace-6.6.7-BJA-cross.diff b/net-analyzer/tcptrace/files/tcptrace-6.6.7-BJA-cross.diff
new file mode 100644
index 00000000..1216b5b9
--- /dev/null
+++ b/net-analyzer/tcptrace/files/tcptrace-6.6.7-BJA-cross.diff
@@ -0,0 +1,50 @@
+--- /tmp/tcptrace-6.6.7/configure.in 2002-06-21 11:56:26.000000000 +0200
++++ configure.in 2011-07-05 01:35:05.000000000 +0200
+@@ -3,8 +3,6 @@
+
+ AC_CANONICAL_SYSTEM
+
+-AC_LBL_C_INIT(V_CCOPT, V_INCLS)
+-
+ dnl Checks for programs.
+ AC_PROG_CC
+ AC_PROG_MAKE_SET
+@@ -43,13 +41,12 @@
+ dnl check for the IPv6 routines inet_pton
+ AC_CHECK_FUNCS(inet_pton)
+
+-AC_MSG_CHECKING(how to print unsigned long long)
+-AC_SUBST(FS_ULL)
+ dnl AC_TRY_RUN is a test program that performs a run-time test to find out
+ dnl the correct syntax to print unsigned long long ints in printf stmts.
+ dnl If strcmp returns 0, we are on an enironment that uses %llu, otherwise
+ dnl we are on a MacOSX environment that uses %qu
+-AC_TRY_RUN([
++AC_CACHE_CHECK([how to print unsigned long long], ac_cv_unsigned_long_long_printf_format,
++ [AC_TRY_RUN([
+ #include <stdio.h>
+
+ #define NIX "%llu"
+@@ -63,11 +60,17 @@
+ exit (0);
+ else
+ exit (1);
+-}],
+-AC_DEFINE(USE_LLU)
+-AC_MSG_RESULT(%llu),
+-AC_MSG_RESULT(%qu),
+-AC_MSG_ERROR(can not run test program while cross compiling))
++}
++ ],
++ ac_cv_unsigned_long_long_printf_format=%llu,
++ ac_cv_unsigned_long_long_printf_format=%qu,
++ [AS_ECHO_N(["cross-comiling, assuming "])]
++ ac_cv_unsigned_long_long_printf_format=%llu
++ )]
++)
++AS_IF([test $ac_cv_unsigned_long_long_printf_format = %llu],
++ AC_DEFINE(USE_LLU)
++)
+
+ dnl Grab standard includes under weird Linux versions
+ dnl case "$target_os" in
diff --git a/net-analyzer/tcptrace/tcptrace-6.6.7.ebuild b/net-analyzer/tcptrace/tcptrace-6.6.7.ebuild
new file mode 100644
index 00000000..376d9a72
--- /dev/null
+++ b/net-analyzer/tcptrace/tcptrace-6.6.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcptrace/tcptrace-6.6.7.ebuild,v 1.9 2010/07/26 22:56:17 jer Exp $
+
+EAPI="2"
+
+inherit flag-o-matic autotools
+
+IUSE=""
+
+DESCRIPTION="A Tool for analyzing network packet dumps"
+HOMEPAGE="http://www.tcptrace.org/"
+SRC_URI="http://www.tcptrace.org/download/${P}.tar.gz
+ http://www.tcptrace.org/download/old/6.6/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ppc64 x86"
+
+DEPEND="net-libs/libpcap"
+
+src_prepare() {
+ append-flags -D_BSD_SOURCE
+ epatch "${FILESDIR}/${P}-BJA-cross.diff"
+
+ eautoreconf
+}
+
+src_install() {
+ dobin tcptrace xpl2gpl
+
+ newman tcptrace.man tcptrace.1
+ dodoc CHANGES COPYRIGHT FAQ README* THANKS WWW
+}
+
+pkg_postinst() {
+ elog
+ elog "Note: tcptrace outputs its graphs in the xpl (xplot)"
+ elog "format. Since xplot is unavailable, you will have to"
+ elog "use the included xpl2gpl utility to convert it to"
+ elog "the gnuplot format."
+ elog
+}