summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/kovri/files/0.2.0_rc1-Drop-in-tree-miniupnpc.patch99
-rw-r--r--net-p2p/kovri/kovri-0.2.0_rc1.ebuild71
-rw-r--r--net-p2p/kovri/metadata.xml8
3 files changed, 0 insertions, 178 deletions
diff --git a/net-p2p/kovri/files/0.2.0_rc1-Drop-in-tree-miniupnpc.patch b/net-p2p/kovri/files/0.2.0_rc1-Drop-in-tree-miniupnpc.patch
deleted file mode 100644
index 118f5987..00000000
--- a/net-p2p/kovri/files/0.2.0_rc1-Drop-in-tree-miniupnpc.patch
+++ /dev/null
@@ -1,99 +0,0 @@
-From daf5e950a459194104ca01ee4dd63bbe81ef26b5 Mon Sep 17 00:00:00 2001
-From: Bertrand Jacquin <bertrand@jacquin.bzh>
-Date: Wed, 26 Sep 2018 00:46:42 +0100
-Subject: [PATCH] Drop in-tree miniupnpc
-
----
- deps/CMakeLists.txt | 62 +------------------------------
- src/core/router/transports/upnp.h | 8 ++--
- 2 files changed, 6 insertions(+), 64 deletions(-)
-
-diff --git a/deps/CMakeLists.txt b/deps/CMakeLists.txt
-index 835cafc7763a..fab217288b27 100644
---- a/deps/CMakeLists.txt
-+++ b/deps/CMakeLists.txt
-@@ -31,63 +31,5 @@
- find_package(Miniupnpc REQUIRED)
- add_library(libminiupnpc INTERFACE)
-
--# In addition to allowing optional local building of miniupnpc, the following will require that
--# the build is built locally if a system package only provides a shared library (like on Arch)
--# even though we have chosen to build statically. NOTE: do *not* distribute a local dynamic-build
--# when building in-tree dynamic (must build statically).
--if (NOT MINIUPNP_INCLUDE_DIR OR NOT MINIUPNP_LIBRARY)
-- set(BUILD_MINIUPNPC ON)
--endif()
--
--if (BUILD_MINIUPNPC)
-- if (NOT WITH_STATIC)
-- set(UPNPC_BUILD_STATIC OFF CACHE BOOL "Disable static lib target" FORCE)
-- set(UPNPC_BUILD_SHARED ON CACHE BOOL "Enable shared lib target" FORCE)
-- endif()
--
-- if (MINIUPNP_FOUND)
-- message(WARNING "Ignoring system miniupnpc, forcing a local build")
-- endif()
--
-- message(STATUS "Using " ${CMAKE_CURRENT_SOURCE_DIR}/miniupnp/miniupnpc)
-- add_subdirectory(miniupnp/miniupnpc)
--
-- if (NOT WITH_STATIC)
-- set(MINIUPNPC_TARGET libminiupnpc-shared)
-- else()
-- set(MINIUPNPC_TARGET libminiupnpc-static)
-- endif()
--
-- set(MINIUPNPC_FLAGS "")
-- if(MSVC)
-- list(APPEND MINIUPNPC_FLAGS "-wd4244 -wd4267")
-- elseif(NOT MSVC)
-- list(APPEND MINIUPNPC_FLAGS "-Wno-undef -Wno-unused-result -Wno-unused-value")
-- endif()
-- if(CMAKE_SYSTEM_NAME MATCHES "NetBSD")
-- list(APPEND MINIUPNPC_FLAGS "-D_NETBSD_SOURCE")
-- endif()
--
-- string(REPLACE ";" " " MINIUPNPC_FLAGS "${MINIUPNPC_FLAGS}" )
-- set_property(TARGET ${MINIUPNPC_TARGET} APPEND_STRING PROPERTY COMPILE_FLAGS "${MINIUPNPC_FLAGS}")
-- set_property(TARGET ${MINIUPNPC_TARGET} PROPERTY FOLDER "deps")
--
-- if (WITH_STATIC)
-- set_property(TARGET ${MINIUPNPC_TARGET} APPEND PROPERTY
-- INTERFACE_COMPILE_DEFINITIONS MINIUPNP_STATICLIB)
-- endif()
--
-- # Use #include <miniupnp/miniupnpc/miniupnpc.h>
-- set_property(TARGET ${MINIUPNPC_TARGET} APPEND PROPERTY
-- INTERFACE_INCLUDE_DIRECTORIES $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}>)
--
-- # Suppress warnings from miniupnpc headers
-- set_property(TARGET ${MINIUPNPC_TARGET} APPEND PROPERTY
-- INTERFACE_SYSTEM_INCLUDE_DIRECTORIES $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}>)
--
-- target_link_libraries(libminiupnpc INTERFACE ${MINIUPNPC_TARGET})
-- set(MINIUPNPC_BUILT ON PARENT_SCOPE) # TODO(unassigned): HACK for install
--else()
-- target_include_directories(libminiupnpc INTERFACE ${MINIUPNP_INCLUDE_DIR})
-- target_link_libraries(libminiupnpc INTERFACE ${MINIUPNP_LIBRARY})
--endif()
-+target_include_directories(libminiupnpc INTERFACE ${MINIUPNP_INCLUDE_DIR})
-+target_link_libraries(libminiupnpc INTERFACE ${MINIUPNP_LIBRARY})
-diff --git a/src/core/router/transports/upnp.h b/src/core/router/transports/upnp.h
-index 0390dca93f23..a2430ca3e67b 100644
---- a/src/core/router/transports/upnp.h
-+++ b/src/core/router/transports/upnp.h
-@@ -35,10 +35,10 @@
-
- #include <boost/asio.hpp>
-
--#include <miniupnp/miniupnpc/miniupnpc.h>
--#include <miniupnp/miniupnpc/miniwget.h>
--#include <miniupnp/miniupnpc/upnpcommands.h>
--#include <miniupnp/miniupnpc/upnperrors.h>
-+#include <miniupnpc/miniupnpc.h>
-+#include <miniupnpc/miniwget.h>
-+#include <miniupnpc/upnpcommands.h>
-+#include <miniupnpc/upnperrors.h>
-
- #include <memory>
- #include <string>
diff --git a/net-p2p/kovri/kovri-0.2.0_rc1.ebuild b/net-p2p/kovri/kovri-0.2.0_rc1.ebuild
deleted file mode 100644
index 39d98394..00000000
--- a/net-p2p/kovri/kovri-0.2.0_rc1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{3_8,3_9} )
-inherit git-r3 toolchain-funcs python-r1 bash-completion-r1
-
-DESCRIPTION="Free, decentralized, anonymity technology based on I2P's open specifications"
-HOMEPAGE="https://getkovri.org"
-EGIT_REPO_URI="https://gitlab.com/kovri-project/${PN}"
-EGIT_COMMIT="v${PV/_/-}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc python"
-
-RDEPEND="dev-libs/openssl:0
- dev-libs/boost:=
- dev-libs/crypto++:=
- python? ( dev-libs/boost:=[python,${PYTHON_USEDEP}] )
- net-libs/miniupnpc"
-DEPEND=">=sys-devel/clang-3.5
- >=dev-util/cmake-3.5.1
- doc? (
- media-gfx/graphviz
- app-doc/doxygen:0
- )
- ${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${PV}-Drop-in-tree-miniupnpc.patch"
-)
-
-src_prepare () {
- export AR=$(tc-getAR)
- export RANLIB=$(tc-getRANLIB)
- export CC=$(tc-getCC)
- export CXX=$(tc-getCXX)
-
- sed -i \
- -e "s;bin_path=.*;bin_path=${ED}/usr/bin;" \
- -e "s;kovri_data_dir=.*;kovri_data_dir=${ED}/etc/${PN};" \
- -e "s;mkdir ;mkdir -p ;" \
- pkg/installers/kovri-install.sh \
- || die
-
- default
-}
-
-src_compile () {
- emake release COTIRE=0
-
- if use doc ; then
- emake doxygen
- fi
-
- # Boost.Python package not yet supported for your system
- #if use python ; then
- # emake python
- #fi
-}
-
-src_install () {
- default
-
- rm -f "${ED}/usr/bin/kovri-bash.sh"
- newbashcomp "${S}/contrib/utils/kovri-bash.sh" "${PN}"
-
- dodoc -r docs/i18n/*
-}
diff --git a/net-p2p/kovri/metadata.xml b/net-p2p/kovri/metadata.xml
deleted file mode 100644
index de37e444..00000000
--- a/net-p2p/kovri/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>bertrand@jacquin.bzh</email>
- <name>Bertrand Jacquin</name>
- </maintainer>
-</pkgmetadata>