summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/entrance/Manifest1
-rw-r--r--x11-misc/entrance/entrance-3.0.0_alpha6.ebuild46
-rw-r--r--x11-misc/entrance/entrance-9999.ebuild41
-rw-r--r--x11-misc/entrance/files/3.0.0_alpha6-2c02d1b1d5c7221059f81c5b6c89fe71f23640cc.patch39
-rw-r--r--x11-misc/entrance/files/3.0.0_alpha6-f526bc6874a1c7cec167e569d60a21787a12a2fd.patch35
-rw-r--r--x11-misc/entrance/metadata.xml8
6 files changed, 170 insertions, 0 deletions
diff --git a/x11-misc/entrance/Manifest b/x11-misc/entrance/Manifest
new file mode 100644
index 00000000..558cbd31
--- /dev/null
+++ b/x11-misc/entrance/Manifest
@@ -0,0 +1 @@
+DIST entrance-3.0.0_alpha6.tar.gz 1237940 BLAKE2B e29f53c6e6bb41865342526bc8518881448e79882566a384980d77534d1180837ced99b28f06ff6a20d15309f7b793f980d2836a0ac169270ab9ccbb96f1044b SHA512 51f9fdeb87bef9f347f2deb0f5b09ffdf67393399453b0e160c227142fb39f16d083c37a9eeda41d12232516cd02bf6e402bb49b4bfda1110e3e4a4fad822971
diff --git a/x11-misc/entrance/entrance-3.0.0_alpha6.ebuild b/x11-misc/entrance/entrance-3.0.0_alpha6.ebuild
new file mode 100644
index 00000000..4320488a
--- /dev/null
+++ b/x11-misc/entrance/entrance-3.0.0_alpha6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit meson
+
+DESCRIPTION="An EFL based display manager"
+HOMEPAGE="https://github.com/Obsidian-StudiosInc/entrance"
+SRC_URI="https://github.com/Obsidian-StudiosInc/entrance/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="nls +pam systemd X"
+
+DEPEND=">=dev-libs/efl-1.19.0[X?,systemd?]
+ pam? ( sys-libs/pam )
+ systemd? ( sys-apps/systemd )
+ "
+RDEPEND="${DEPEND}
+ X? (
+ x11-base/xorg-server
+ x11-apps/sessreg
+ x11-apps/xauth
+ )
+ acct-user/nobody"
+
+PATCHES=(
+ "${FILESDIR}/${PV}-f526bc6874a1c7cec167e569d60a21787a12a2fd.patch"
+ "${FILESDIR}/${PV}-2c02d1b1d5c7221059f81c5b6c89fe71f23640cc.patch"
+)
+
+src_configure() {
+ local emesonargs=(
+ -Dconsolekit=false
+ $(meson_use systemd logind)
+ $(meson_use nls)
+ $(meson_use pam)
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+}
diff --git a/x11-misc/entrance/entrance-9999.ebuild b/x11-misc/entrance/entrance-9999.ebuild
new file mode 100644
index 00000000..d378fbdb
--- /dev/null
+++ b/x11-misc/entrance/entrance-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit git-r3 meson
+
+DESCRIPTION="An EFL based display manager"
+HOMEPAGE="https://github.com/Obsidian-StudiosInc/entrance"
+EGIT_REPO_URI="https://github.com/Obsidian-StudiosInc/entrance.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="nls +pam systemd X"
+
+DEPEND=">=dev-libs/efl-1.19.0[X?,systemd?]
+ pam? ( sys-libs/pam )
+ systemd? ( sys-apps/systemd )
+ "
+RDEPEND="${DEPEND}
+ X? (
+ x11-base/xorg-server
+ x11-apps/sessreg
+ x11-apps/xauth
+ )
+ acct-user/nobody"
+
+src_configure() {
+ local emesonargs=(
+ -Dconsolekit=false
+ $(meson_use systemd logind)
+ $(meson_use nls)
+ $(meson_use pam)
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+}
diff --git a/x11-misc/entrance/files/3.0.0_alpha6-2c02d1b1d5c7221059f81c5b6c89fe71f23640cc.patch b/x11-misc/entrance/files/3.0.0_alpha6-2c02d1b1d5c7221059f81c5b6c89fe71f23640cc.patch
new file mode 100644
index 00000000..1919e02c
--- /dev/null
+++ b/x11-misc/entrance/files/3.0.0_alpha6-2c02d1b1d5c7221059f81c5b6c89fe71f23640cc.patch
@@ -0,0 +1,39 @@
+From 2c02d1b1d5c7221059f81c5b6c89fe71f23640cc Mon Sep 17 00:00:00 2001
+From: "William L. Thomson Jr" <wlt@o-sinc.com>
+Date: Wed, 27 May 2020 14:17:31 -0400
+Subject: [PATCH] daemon:Fix build with -fno-common, multiple-definition of
+
+---
+ src/daemon/entrance.c | 3 +++
+ src/daemon/entrance.h | 4 ++--
+ 2 files changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/src/daemon/entrance.c b/src/daemon/entrance.c
+index 053e3b9b2444..85a1a4d2755f 100644
+--- a/src/daemon/entrance.c
++++ b/src/daemon/entrance.c
+@@ -39,6 +39,9 @@ static gid_t entrance_gid = 0;
+ static uid_t entrance_uid = 0;
+ static pid_t entrance_xserver_pid = 0;
+
++int _entrance_log;
++int _entrance_client_log;
++
+ static const Ecore_Getopt options =
+ {
+ PACKAGE,
+diff --git a/src/daemon/entrance.h b/src/daemon/entrance.h
+index 2a7bb1ed8e54..fbe05bdb94da 100644
+--- a/src/daemon/entrance.h
++++ b/src/daemon/entrance.h
+@@ -26,8 +26,8 @@
+ #include "entrance_image.h"
+ #include "entrance_theme.h"
+
+-int _entrance_log;
+-int _entrance_client_log;
++extern int _entrance_log;
++extern int _entrance_client_log;
+
+ #define PT(f, x...) \
+ do \
diff --git a/x11-misc/entrance/files/3.0.0_alpha6-f526bc6874a1c7cec167e569d60a21787a12a2fd.patch b/x11-misc/entrance/files/3.0.0_alpha6-f526bc6874a1c7cec167e569d60a21787a12a2fd.patch
new file mode 100644
index 00000000..7b401e84
--- /dev/null
+++ b/x11-misc/entrance/files/3.0.0_alpha6-f526bc6874a1c7cec167e569d60a21787a12a2fd.patch
@@ -0,0 +1,35 @@
+From f526bc6874a1c7cec167e569d60a21787a12a2fd Mon Sep 17 00:00:00 2001
+From: "William L. Thomson Jr" <wlt@o-sinc.com>
+Date: Wed, 27 May 2020 14:16:23 -0400
+Subject: [PATCH] daemon: Fix build with -fno-common, multiple-definition of
+
+---
+ src/daemon/entrance_config.c | 2 ++
+ src/daemon/entrance_config.h | 2 +-
+ 2 files changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/src/daemon/entrance_config.c b/src/daemon/entrance_config.c
+index 9c458807742c..e20ebd705e93 100644
+--- a/src/daemon/entrance_config.c
++++ b/src/daemon/entrance_config.c
+@@ -10,6 +10,8 @@ static Entrance_Config *_cache_get(void);
+
+ static Eet_Data_Descriptor *_entrance_config_descriptor;
+
++Entrance_Config *entrance_config;
++
+ static void
+ _defaults_set(Entrance_Config *config)
+ {
+diff --git a/src/daemon/entrance_config.h b/src/daemon/entrance_config.h
+index a17e7917b69c..e52a6fc9008d 100644
+--- a/src/daemon/entrance_config.h
++++ b/src/daemon/entrance_config.h
+@@ -49,6 +49,6 @@ void entrance_config_init(void);
+ void entrance_config_shutdown(void);
+ void entrance_config_set(const Entrance_Conf_Gui_Event *conf);
+
+-Entrance_Config *entrance_config;
++extern Entrance_Config *entrance_config;
+
+ #endif /* ENTRANCE_CONFIG_H_ */
diff --git a/x11-misc/entrance/metadata.xml b/x11-misc/entrance/metadata.xml
new file mode 100644
index 00000000..82f7232e
--- /dev/null
+++ b/x11-misc/entrance/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bertrand@jacquin.bzh</email>
+ <name>Bertrand Jacquin</name>
+ </maintainer>
+</pkgmetadata>