summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/cpplint/cpplint-20200102.ebuild48
-rw-r--r--dev-util/cpplint/cpplint-9999.ebuild47
-rw-r--r--dev-util/cpplint/metadata.xml11
3 files changed, 0 insertions, 106 deletions
diff --git a/dev-util/cpplint/cpplint-20200102.ebuild b/dev-util/cpplint/cpplint-20200102.ebuild
deleted file mode 100644
index fffe787e..00000000
--- a/dev-util/cpplint/cpplint-20200102.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit python-single-r1 git-r3
-
-DESCRIPTION="Checker to make sure a C++ file follows Google's C++ style guide"
-HOMEPAGE="https://github.com/google/styleguide"
-EGIT_REPO_URI="https://github.com/google/styleguide.git"
-EGIT_COMMIT="f704c352f4f0597d2bd8b85d089b093946ff75d7"
-
-LICENSE="cpplint"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="${PYTHON_DEPS}"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-HTML_DOCS=(
- include/
- angularjs-google-style.html cppguide.html google-r-style.html javaguide.html jsoncstyleguide.html xmlstyle.html
- javaguide.css styleguide.css
- javaguidelink.png jsoncstyleguide_example_01.png jsoncstyleguide_example_02.png
-)
-
-src_test() {
- cd "${PN}"
-
- einfo "Running ${EPYTHON} cpplint_unittest.py"
- ${EPYTHON} cpplint_unittest.py --verbose \
- || die "cpplint_unittest.py failed"
-}
-
-src_install() {
- default
-
- python_doscript "${PN}/cpplint.py"
-
- dodoc README.md "${PN}/README"
-
- insinto /usr/share/vim/vimfiles/syntax
- doins google_python_style.vim
-}
diff --git a/dev-util/cpplint/cpplint-9999.ebuild b/dev-util/cpplint/cpplint-9999.ebuild
deleted file mode 100644
index 66b297e1..00000000
--- a/dev-util/cpplint/cpplint-9999.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit python-single-r1 git-r3
-
-DESCRIPTION="Checker to make sure a C++ file follows Google's C++ style guide"
-HOMEPAGE="https://github.com/google/styleguide"
-EGIT_REPO_URI="https://github.com/google/styleguide.git"
-
-LICENSE="cpplint"
-SLOT="0"
-KEYWORDS=""
-IUSE="test"
-
-RDEPEND="${PYTHON_DEPS}"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-HTML_DOCS=(
- include/
- angularjs-google-style.html cppguide.html google-r-style.html javaguide.html jsoncstyleguide.html xmlstyle.html
- javaguide.css styleguide.css
- javaguidelink.png jsoncstyleguide_example_01.png jsoncstyleguide_example_02.png
-)
-
-src_test() {
- cd "${PN}"
-
- einfo "Running ${EPYTHON} cpplint_unittest.py"
- ${EPYTHON} cpplint_unittest.py --verbose \
- || die "cpplint_unittest.py failed"
-}
-
-src_install() {
- default
-
- python_doscript "${PN}/cpplint.py"
-
- dodoc README.md "${PN}/README"
-
- insinto /usr/share/vim/vimfiles/syntax
- doins google_python_style.vim
-}
diff --git a/dev-util/cpplint/metadata.xml b/dev-util/cpplint/metadata.xml
deleted file mode 100644
index 0b4f4f8b..00000000
--- a/dev-util/cpplint/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>bertrand@jacquin.bzh</email>
- <name>Bertrand Jacquin</name>
- </maintainer>
- <upstream>
- <remote-id type="github">google/styleguide</remote-id>
- </upstream>
-</pkgmetadata>