summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/hp-health/ChangeLog6
-rw-r--r--app-admin/hp-health/Manifest7
-rw-r--r--app-admin/hp-health/hp-health-9.1.0.42.ebuild77
-rw-r--r--app-admin/hp-health/hp-health-9.50.ebuild88
-rw-r--r--metadata/md5-cache/app-admin/hp-health-9.1.0.4212
-rw-r--r--metadata/md5-cache/app-admin/hp-health-9.5012
6 files changed, 202 insertions, 0 deletions
diff --git a/app-admin/hp-health/ChangeLog b/app-admin/hp-health/ChangeLog
new file mode 100644
index 00000000..dc720f88
--- /dev/null
+++ b/app-admin/hp-health/ChangeLog
@@ -0,0 +1,6 @@
+*hp-health-9.1.0.42 (02 Apr 2014)
+*hp-health-9.50 (02 Apr 2014)
+
+ 02 Apr 2014; Bertrand Jacquin <beber@meleeweb.net> +hp-health-9.1.0.42.ebuild,
+ +hp-health-9.50.ebuild:
+ app-admin/hp-health: Sync from barzog overlay
diff --git a/app-admin/hp-health/Manifest b/app-admin/hp-health/Manifest
new file mode 100644
index 00000000..6bfd33bb
--- /dev/null
+++ b/app-admin/hp-health/Manifest
@@ -0,0 +1,7 @@
+DIST hp-health-9.1.0.42-54.rhel6.x86_64.rpm 831802 SHA256 8fba9204681896d696a3d6bbc1497d8d359080598cbe4ebc9351f113a99c234f
+DIST hp-health-9.1.0.42-58.rhel6.i386.rpm 950070 SHA256 a3ad4d1b7bbc6336fa0978f82ccce5b38fa98f9127f0d24adbc46ab6ef52e040
+DIST hp-health-9.50-1628.32.rhel6.x86_64.rpm 328532 SHA256 8dc1247dded64d620d72b02384997d3e6bf582233fa766ee9bd35c7ef17ecaed SHA512 e78c389ebc727c94d4952a82e8c70d4726c93dc9bb6e8bd73bc5b5a2c2ed4987742c610c800ae89e63f21df08712e01c52593842f7518944f33248a88d9f7995 WHIRLPOOL a14ab562e22fbbdb3415ec595151001559e8ddf43f90d93bfd90eda40ace80a299b56622226199120192036db9d506174fa1bc2ede544e28f1cdf79b18e73de8
+DIST hp-health-9.50-1628.33.rhel6.i686.rpm 408816 SHA256 7ee31c9843e5e8b06d42143c5b5f167fef5c62e5f22b759bd2da7caf84ce48ca SHA512 8b5feb178a4e0a65c156eadd94cd12e5a2d9d606a72e3b3267b43e9c006fa7f84f1e539b39fb8cee95c23a1248f9703e07e2b9e1c15a9481f17988d0b6777525 WHIRLPOOL 7207ba5af89b211b06e505f5334607c20792d8fac844c33e018bbf12054096612f9c60232a7629acf951b780fa2c19e457e5e6a410b1bf277c1b7d0449439ef3
+EBUILD hp-health-9.1.0.42.ebuild 2200 SHA256 4e512af34d5863f08444efe80396b2d705aef03fe97bf3d3e51b7dcd8b3df383 WHIRLPOOL ef63ddb7be68533880b4b0ccd3d1c1963ecb913e73bdd8b09b5f7983711e8922b707f421ce271467ed937c254a417c428e2ffaf53c2d10cc556c08cd47bfc557
+EBUILD hp-health-9.50.ebuild 2561 SHA256 8c9b48d44fce96ec6db38bae8bf9d19c314289d107d99c1b0899002e8718602d WHIRLPOOL 7c7e47f3fef694f49402afd14c81c7ebece45f763d514d3a89d1b61a84b4e7885bb4f847e905890ce2c5a3ee42cbf3e36ffaeb80f21aaf60c28460eae4d6a76b
+MISC ChangeLog 220 SHA256 65a924e9f52b061c683b9493860fe0d0dc4c0c0123115dbfa5eacbbcbbed1ba6 WHIRLPOOL e1e63136e65b5a20e3792a41d4d77cbf8587b4e889e85e964ae1bf8309c70c6f31d8d736b2089aafb0cbaaaec6466fae5649f330ba5bf78a262af1d7b0829ae3
diff --git a/app-admin/hp-health/hp-health-9.1.0.42.ebuild b/app-admin/hp-health/hp-health-9.1.0.42.ebuild
new file mode 100644
index 00000000..df5c560d
--- /dev/null
+++ b/app-admin/hp-health/hp-health-9.1.0.42.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils toolchain-funcs rpm
+
+DESCRIPTION="HP System Health Application and Insight Management Agents Package (Formerly HPASM)"
+HOMEPAGE="http://h18000.www1.hp.com/products/servers/linux/documentation.html"
+LICENSE="hp-value"
+KEYWORDS="amd64 x86"
+IUSE="ssl snmp X"
+DEPEND="${RDEPEND}
+ mail-client/mailx
+ app-arch/rpm2targz
+ sys-apps/pciutils
+ sys-libs/ncurses
+ dev-lang/python
+ sys-apps/ethtool
+ sys-apps/lm_sensors
+ snmp? ( net-analyzer/net-snmp )
+ ssl? ( dev-libs/openssl )"
+
+RDEPEND="${DEPEND}
+ app-arch/tar
+ sys-apps/sed"
+
+SRC_URI_BASE="http://downloads.linux.hp.com/SDR/psp/RedHatEnterpriseServer/6.2/"
+SRC_URI="x86? ( ${SRC_URI_BASE}/i686/current/${P}-58.rhel6.i386.rpm )
+ amd64? ( ${SRC_URI_BASE}/x86_64/current/${P}-54.rhel6.x86_64.rpm )"
+
+HP_HOME="/opt/hp"
+
+SLOT="0"
+S="${WORKDIR}"
+
+QA_EXECSTACK="${HP_HOME:1}/hp-health/bin/hpasmpld
+ ${HP_HOME:1}/hp-health/bin/IrqRouteTbl
+ ${HP_HOME:1}/hp-health/bin/hpasmlited
+ ${HP_HOME:1}/hp-health/bin/hpasmxld
+ usr/$(get_libdir)/libhpev64.so.1.0
+ usr/sbin/hplog"
+
+src_unpack() {
+ rpm_src_unpack
+ cd ${S}
+# find ./ -type l -exec rm -f {} \;
+}
+
+src_install() {
+ cd "${S}"
+ dodir ${HP_HOME}
+ cp -Rdp "${S}"${HP_HOME}/* "${D}${HP_HOME}"
+ dolib.so ./usr/$(get_libdir)/*.so*
+ dodir /var/log/hp-health
+ dodir /var/spool/compaq
+ dodir /var/spool/hp-health
+ doman usr/share/man/man?/*
+ dosbin sbin/*
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" == "/" ] ; then
+ /sbin/ldconfig
+ fi
+ einfo
+ if ! use snmp ; then
+ einfo "If you want to use the web agent and other features"
+ einfo "then configure your /usr/share/snmp/snmpd.conf"
+ einfo
+ einfo "It is not required to have net-snmp"
+ einfo "running for basic hpasm functionality."
+ einfo
+ fi
+ einfo "You now need to execute /etc/init.d/hpasm configure"
+ einfo "in order to configure the installed package."
+ einfo
+} \ No newline at end of file
diff --git a/app-admin/hp-health/hp-health-9.50.ebuild b/app-admin/hp-health/hp-health-9.50.ebuild
new file mode 100644
index 00000000..2c4ec295
--- /dev/null
+++ b/app-admin/hp-health/hp-health-9.50.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils toolchain-funcs rpm
+
+DESCRIPTION="HP System Health Application and Insight Management Agents Package (Formerly HPASM)"
+HOMEPAGE="http://h18000.www1.hp.com/products/servers/linux/documentation.html"
+LICENSE="hp-value"
+KEYWORDS="amd64 x86"
+IUSE="ssl snmp X"
+DEPEND="${RDEPEND}
+ mail-client/mailx
+ app-arch/rpm2targz
+ sys-apps/pciutils
+ sys-libs/ncurses
+ dev-lang/python
+ sys-apps/ethtool
+ sys-apps/lm_sensors
+ snmp? ( net-analyzer/net-snmp )
+ ssl? ( dev-libs/openssl )"
+
+RDEPEND="${DEPEND}
+ app-arch/tar
+ sys-apps/sed"
+
+SRC_URI_BASE="http://downloads.linux.hp.com/downloads/SPP/RedHatEnterpriseServer/6.5"
+SRC_URI="x86? ( ${SRC_URI_BASE}/i686/current/${P}-1628.33.rhel6.i686.rpm )
+ amd64? ( ${SRC_URI_BASE}/x86_64/current/${P}-1628.32.rhel6.x86_64.rpm )"
+
+HP_HOME="/opt/hp"
+
+SLOT="0"
+S="${WORKDIR}"
+
+QA_EXECSTACK="${HP_HOME:1}/hp-health/bin/hpasmpld
+ ${HP_HOME:1}/hp-health/bin/IrqRouteTbl
+ ${HP_HOME:1}/hp-health/bin/hpasmlited
+ ${HP_HOME:1}/hp-health/bin/hpasmxld
+ usr/$(get_libdir)/libhpev64.so.1.0
+ usr/sbin/hplog"
+QA_PRESTRIPPED="/opt/hp/hp-health/bin/hpasmlited
+ /opt/hp/hp-health/bin/hpasmpld
+ /opt/hp/hp-health/bin/hpasmxld
+ /opt/hp/hp-health/bin/hp-asrd
+ /usr/lib64/libcpqci64.so.3.0
+ /usr/lib64/libhpev64.so.1.0
+ /usr/lib64/libhpasmintrfc64.so.3.0
+ /usr/sbin/hpasmcli
+ /usr/sbin/hpbootcfg
+ /usr/sbin/hplog
+ /usr/sbin/hpuid"
+
+src_unpack() {
+ rpm_src_unpack
+ cd ${S}
+# find ./ -type l -exec rm -f {} \;
+}
+
+src_install() {
+ cd "${S}"
+ dodir ${HP_HOME}
+ cp -Rdp "${S}"${HP_HOME}/* "${D}${HP_HOME}"
+ dolib.so ./usr/$(get_libdir)/*.so*
+ dodir /var/log/hp-health
+ dodir /var/spool/compaq
+ dodir /var/spool/hp-health
+ doman usr/share/man/man?/*
+ dosbin sbin/*
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" == "/" ] ; then
+ /sbin/ldconfig
+ fi
+ einfo
+ if ! use snmp ; then
+ einfo "If you want to use the web agent and other features"
+ einfo "then configure your /usr/share/snmp/snmpd.conf"
+ einfo
+ einfo "It is not required to have net-snmp"
+ einfo "running for basic hpasm functionality."
+ einfo
+ fi
+ einfo "You now need to execute /etc/init.d/hpasm configure"
+ einfo "in order to configure the installed package."
+ einfo
+}
diff --git a/metadata/md5-cache/app-admin/hp-health-9.1.0.42 b/metadata/md5-cache/app-admin/hp-health-9.1.0.42
new file mode 100644
index 00000000..21e6a2e0
--- /dev/null
+++ b/metadata/md5-cache/app-admin/hp-health-9.1.0.42
@@ -0,0 +1,12 @@
+DEFINED_PHASES=install postinst unpack
+DEPEND=mail-client/mailx app-arch/rpm2targz sys-apps/pciutils sys-libs/ncurses dev-lang/python sys-apps/ethtool sys-apps/lm_sensors snmp? ( net-analyzer/net-snmp ) ssl? ( dev-libs/openssl ) >=app-arch/rpm2targz-9.0.0.3g
+DESCRIPTION=HP System Health Application and Insight Management Agents Package (Formerly HPASM)
+HOMEPAGE=http://h18000.www1.hp.com/products/servers/linux/documentation.html
+IUSE=ssl snmp X
+KEYWORDS=amd64 x86
+LICENSE=hp-value
+RDEPEND=mail-client/mailx app-arch/rpm2targz sys-apps/pciutils sys-libs/ncurses dev-lang/python sys-apps/ethtool sys-apps/lm_sensors snmp? ( net-analyzer/net-snmp ) ssl? ( dev-libs/openssl ) app-arch/tar sys-apps/sed
+SLOT=0
+SRC_URI=x86? ( http://downloads.linux.hp.com/SDR/psp/RedHatEnterpriseServer/6.2//i686/current/hp-health-9.1.0.42-58.rhel6.i386.rpm ) amd64? ( http://downloads.linux.hp.com/SDR/psp/RedHatEnterpriseServer/6.2//x86_64/current/hp-health-9.1.0.42-54.rhel6.x86_64.rpm )
+_eclasses_=eutils af81d52c25ec93fbdff71e0efb0de7b7 multilib fac675dcccf94392371a6abee62d909f rpm b94b54b44f14d6bee3e966c8f5c86fba toolchain-funcs 48b38a216afb92db6314d6c3187abea3
+_md5_=f79fd23e94d54a1be47da88b0d848a97
diff --git a/metadata/md5-cache/app-admin/hp-health-9.50 b/metadata/md5-cache/app-admin/hp-health-9.50
new file mode 100644
index 00000000..45b59541
--- /dev/null
+++ b/metadata/md5-cache/app-admin/hp-health-9.50
@@ -0,0 +1,12 @@
+DEFINED_PHASES=install postinst unpack
+DEPEND=mail-client/mailx app-arch/rpm2targz sys-apps/pciutils sys-libs/ncurses dev-lang/python sys-apps/ethtool sys-apps/lm_sensors snmp? ( net-analyzer/net-snmp ) ssl? ( dev-libs/openssl ) >=app-arch/rpm2targz-9.0.0.3g
+DESCRIPTION=HP System Health Application and Insight Management Agents Package (Formerly HPASM)
+HOMEPAGE=http://h18000.www1.hp.com/products/servers/linux/documentation.html
+IUSE=ssl snmp X
+KEYWORDS=amd64 x86
+LICENSE=hp-value
+RDEPEND=mail-client/mailx app-arch/rpm2targz sys-apps/pciutils sys-libs/ncurses dev-lang/python sys-apps/ethtool sys-apps/lm_sensors snmp? ( net-analyzer/net-snmp ) ssl? ( dev-libs/openssl ) app-arch/tar sys-apps/sed
+SLOT=0
+SRC_URI=x86? ( http://downloads.linux.hp.com/downloads/SPP/RedHatEnterpriseServer/6.5/i686/current/hp-health-9.50-1628.33.rhel6.i686.rpm ) amd64? ( http://downloads.linux.hp.com/downloads/SPP/RedHatEnterpriseServer/6.5/x86_64/current/hp-health-9.50-1628.32.rhel6.x86_64.rpm )
+_eclasses_=eutils af81d52c25ec93fbdff71e0efb0de7b7 multilib fac675dcccf94392371a6abee62d909f rpm b94b54b44f14d6bee3e966c8f5c86fba toolchain-funcs 48b38a216afb92db6314d6c3187abea3
+_md5_=755dc7b02f8fe378df6f62209d3581e3