summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/randomx/Manifest1
-rw-r--r--dev-libs/randomx/randomx-1.1.10.ebuild10
-rw-r--r--dev-libs/randomx/randomx-1.1.9.ebuild37
3 files changed, 5 insertions, 43 deletions
diff --git a/dev-libs/randomx/Manifest b/dev-libs/randomx/Manifest
index 37038548..12c64ed2 100644
--- a/dev-libs/randomx/Manifest
+++ b/dev-libs/randomx/Manifest
@@ -1,2 +1 @@
DIST randomx-1.1.10.tar.gz 163987 BLAKE2B cbb4757648d54fc8d3d75aaaf668e365900dc9bcd8b53e9afe975e1d288ce36207327608f69eaae16f31d79547355876e86b647f3cd3444cdfa08a1846862932 SHA512 b35210dab4e45165d3a83b1fd873a29872358ae2076f960c41f652a57e5576f872e4b4ebc4cec1937f2a9f31cfa9fd936b30eb2d1e382349097797812d6b5a5c
-DIST randomx-1.1.9.tar.gz 163669 BLAKE2B 41a665061c438c335825abfdf8fbde7f0c8a910fcca22e47babd015120b675378ad04afdc602f2b8e41cc6030ea6caa6298a27bce634034e95b5657d4ea06492 SHA512 89e0541bc849db270672acd7210a6c7109e4ca07765e6e656229ff8867792bfae933ee85b0aa4545dc3cf0c6515140ab782c8e231af17a82610718a80458c420
diff --git a/dev-libs/randomx/randomx-1.1.10.ebuild b/dev-libs/randomx/randomx-1.1.10.ebuild
index a63dae32..495b5dec 100644
--- a/dev-libs/randomx/randomx-1.1.10.ebuild
+++ b/dev-libs/randomx/randomx-1.1.10.ebuild
@@ -1,8 +1,8 @@
-# Copyright 2019-2021 Gentoo Authors
+# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-inherit cmake-multilib
+EAPI=8
+inherit cmake
DESCRIPTION="Proof-of-work algorithm that is optimized for general-purpose CPUs"
HOMEPAGE="https://github.com/tevador/RandomX"
@@ -26,11 +26,11 @@ src_configure() {
-DARCH=native
)
- cmake-multilib_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-multilib_src_install
+ cmake_src_install
insinto /usr/lib/sysctl.d
doins "${FILESDIR}/60-${PN}.conf"
diff --git a/dev-libs/randomx/randomx-1.1.9.ebuild b/dev-libs/randomx/randomx-1.1.9.ebuild
deleted file mode 100644
index fa7d7189..00000000
--- a/dev-libs/randomx/randomx-1.1.9.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 2019-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit cmake-multilib
-
-DESCRIPTION="Proof-of-work algorithm that is optimized for general-purpose CPUs"
-HOMEPAGE="https://github.com/tevador/RandomX"
-SRC_URI="https://github.com/tevador/RandomX/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-BDEPEND=">=dev-util/cmake-2.8.7"
-
-S="${WORKDIR}/RandomX-${PV}"
-
-CMAKE_BUILD_TYPE=Release
-
-src_configure() {
- local mycmakeargs=(
- -DARCH=native
- )
-
- cmake-multilib_src_configure
-}
-
-src_install() {
- cmake-multilib_src_install
-
- insinto /usr/lib/sysctl.d
- doins "${FILESDIR}/60-${PN}.conf"
-}