summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/vanitygen/Manifest1
-rw-r--r--app-crypt/vanitygen/vanitygen-0.21.ebuild36
-rw-r--r--app-crypt/vanitysearch/Manifest1
-rw-r--r--app-crypt/vanitysearch/metadata.xml (renamed from app-crypt/vanitygen/metadata.xml)0
-rw-r--r--app-crypt/vanitysearch/vanitysearch-1.15.ebuild36
5 files changed, 37 insertions, 37 deletions
diff --git a/app-crypt/vanitygen/Manifest b/app-crypt/vanitygen/Manifest
deleted file mode 100644
index 8f73de71..00000000
--- a/app-crypt/vanitygen/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST vanitygen-0.21.tar.gz 77441 BLAKE2B c3daa69ec70109cb891a536469947949734da8581c7ac9d127e9dbd64db277c1d1b0e5ef91cd874b5d03598de5009179232cb15c26cfb00e15c863d3c121b792 SHA512 339fd0ddb7e78d55f95c7e4797d3e2e92dce407a8221f42f3e9971d07210fcea0d681e32247d2d1d46a0946a7e735597eb32dc981ac4f1796abe2ec0a141e88f
diff --git a/app-crypt/vanitygen/vanitygen-0.21.ebuild b/app-crypt/vanitygen/vanitygen-0.21.ebuild
deleted file mode 100644
index 29e6229e..00000000
--- a/app-crypt/vanitygen/vanitygen-0.21.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit toolchain-funcs flag-o-matic
-
-DESCRIPTION="Vanity bitcoin address generator"
-HOMEPAGE="https://github.com/samr7/vanitygen"
-SRC_URI="https://github.com/samr7/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="AGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="dev-libs/openssl:0
- dev-libs/libpcre:="
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- default
-
- tc-export CC
-
- filter-flags -O?
- append-cflags -O3
-}
-
-src_compile() {
- emake CFLAGS="${CFLAGS}"
-}
-
-src_install () {
- dobin vanitygen keyconv
- dodoc CHANGELOG README
-}
diff --git a/app-crypt/vanitysearch/Manifest b/app-crypt/vanitysearch/Manifest
new file mode 100644
index 00000000..1438f170
--- /dev/null
+++ b/app-crypt/vanitysearch/Manifest
@@ -0,0 +1 @@
+DIST vanitysearch-1.15.tar.gz 143113 BLAKE2B 848e6347ad5f2a07b7c0760b48f918702daf538411b621fe748db440a622eb43f99b43af34d438bf2375fb3686eda1a23a3bf733790dbe36069d41f7677ae826 SHA512 21b42ad6759571fdc5421d731279d7a7b83a9716c05a68c2f3607c84788d5e6e2940e7a6e7e7ebb8e211f2032ab1becb5a455a3a81c083daf52a326b61fbc32c
diff --git a/app-crypt/vanitygen/metadata.xml b/app-crypt/vanitysearch/metadata.xml
index 82f7232e..82f7232e 100644
--- a/app-crypt/vanitygen/metadata.xml
+++ b/app-crypt/vanitysearch/metadata.xml
diff --git a/app-crypt/vanitysearch/vanitysearch-1.15.ebuild b/app-crypt/vanitysearch/vanitysearch-1.15.ebuild
new file mode 100644
index 00000000..7e28c466
--- /dev/null
+++ b/app-crypt/vanitysearch/vanitysearch-1.15.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="Bitcoin address prefix finder"
+HOMEPAGE="https://github.com/JeanLucPons/VanitySearch"
+SRC_URI="https://github.com/JeanLucPons/VanitySearch/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/VanitySearch-${PV}"
+
+src_prepare() {
+ default
+
+ tc-export CXX
+}
+
+src_compile() {
+ emake \
+ CXX="${CXX}" \
+ CUDA="${EPREFIX}/usr"
+}
+
+src_install () {
+ dobin VanitySearch
+ dodoc README.md
+}