summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/qbittorrent/Manifest2
-rw-r--r--net-p2p/qbittorrent/qbittorrent-2.1.0_rc7.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/Manifest b/net-p2p/qbittorrent/Manifest
new file mode 100644
index 00000000..d0bda3c7
--- /dev/null
+++ b/net-p2p/qbittorrent/Manifest
@@ -0,0 +1,2 @@
+DIST qbittorrent-2.1.0rc7.tar.gz 2296117 RMD160 669fe563e91b909d8d47dfdc34327b1e9cb69f2d SHA1 f558e2ce0fe9058cb526ecf5e0e13ef80da8580a SHA256 688699ef96abe76426b7bd1e9cb78d8ebab639fa1366841764750143e4825be8
+EBUILD qbittorrent-2.1.0_rc7.ebuild 1399 RMD160 5e61ba95d281087a5246e78c2de0de2715842b94 SHA1 9b2a9f616563469bdeea836d27979cdb477d0245 SHA256 aae9964a2a9c900274a401d9b2ff263228b8223c5bbbc467524831c937f1903a
diff --git a/net-p2p/qbittorrent/qbittorrent-2.1.0_rc7.ebuild b/net-p2p/qbittorrent/qbittorrent-2.1.0_rc7.ebuild
new file mode 100644
index 00000000..4242bfff
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-2.1.0_rc7.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.0.6.ebuild,v 1.1 2010/01/09 17:19:58 armin76 Exp $
+
+EAPI="2"
+inherit eutils qt4 multilib
+
+MY_P="${P/_/}"
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="geoip libnotify X"
+
+# boost version so that we always have thread support
+DEPEND=" X? ( x11-libs/qt-gui:4 )
+ >=net-libs/rb_libtorrent-0.14.7
+ >=dev-libs/boost-1.34.1"
+RDEPEND="${DEPEND}
+ >=dev-lang/python-2.3
+ geoip? ( dev-libs/geoip )
+ libnotify? ( x11-libs/libnotify )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Respect LDFLAGS
+ sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
+ qt4_src_prepare
+}
+
+src_configure() {
+ local myconf=
+
+ if ! use X ; then
+ myconf="${myconf} --disable-gui"
+ fi
+
+ if ! use geoip ; then
+ myconf="${myconf} --disable-geoip-database"
+ fi
+
+ if ! use libnotify ; then
+ myconf="${myconf} --disable-geoip-database"
+ fi
+
+ # econf fails, since this uses qconf
+ ./configure --prefix=${ROOT}/usr --qtdir=${ROOT}/usr \
+ ${myconf} \
+ || die "configure failed"
+ eqmake4
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ dodoc AUTHORS Changelog NEWS README TODO
+}