summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/irc/ChangeLog10
-rw-r--r--dev-python/irc/Manifest5
-rw-r--r--dev-python/irc/files/8.5.1-cleanup-requires.diff13
-rw-r--r--dev-python/irc/irc-8.5.1.ebuild43
-rw-r--r--dev-python/irc/metadata.xml12
-rw-r--r--metadata/md5-cache/dev-python/irc-8.5.114
6 files changed, 0 insertions, 97 deletions
diff --git a/dev-python/irc/ChangeLog b/dev-python/irc/ChangeLog
deleted file mode 100644
index b91ae210..00000000
--- a/dev-python/irc/ChangeLog
+++ /dev/null
@@ -1,10 +0,0 @@
- 19 Sep 2013; Bertrand Jacquin <beber@meleeweb.net>
- +files/8.5.1-cleanup-requires.diff, -files/8.5.1-remove-hg-dependencies.diff,
- irc-8.5.1.ebuild:
- dev-python/irc: remove DEPEND on pytest-runner
-
-*irc-8.5.1 (19 Sep 2013)
-
- 19 Sep 2013; Bertrand Jacquin <beber@meleeweb.net>
- +files/8.5.1-remove-hg-dependencies.diff, +irc-8.5.1.ebuild, +metadata.xml:
- dev-python/irc: Remove dependencie on dos2unix and hgtools, bug #485398
diff --git a/dev-python/irc/Manifest b/dev-python/irc/Manifest
deleted file mode 100644
index 253f299e..00000000
--- a/dev-python/irc/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-AUX 8.5.1-cleanup-requires.diff 339 SHA256 c71c48db2c2a0679a5b10cc88419d9d4ab4fe66098dad055d61c5d98531e3a80 WHIRLPOOL e5de4a0dd8ca1e7f728ce2ea6720bd76cbededbc1266f8ead59f59eead765399328fa376b8e6679dec563559db56410d0a3555b52d68ad433665a18211bab036
-DIST irc-8.5.1.zip 112916 SHA256 ff29edb5c51bbf6583f60f677e846b3eb651374c2f6b39800e4b4947c989b8db WHIRLPOOL e24d1a8155dd79e840aceb085f0a6d6fd0c0cafb356c64604c01555d4a6189e8e8dbc4824f74d58c45731615d24fe1606987b70dacf40375354134d200373d13
-EBUILD irc-8.5.1.ebuild 1191 SHA256 4281cb13ffc7df3704bc68ed81cedcee55d29d6183e4da0e75bc8598f0150cc6 WHIRLPOOL eafe49179f3e183b01fbdffe6b9f15f2ef63d964c14f6d63fe297c705df46c55e8ca0cd200875c9d1e5b45a9e7586051e885a945c1ea9ab189f4ab09390d8a35
-MISC ChangeLog 434 SHA256 75860d54c0ef047ca52f322367d147e04f52c0870b88dc43089857689d1cc188 WHIRLPOOL 30a4be0282a620e5335547f2f75f22a771365f3acb2e016b8fa43c35bba1759788320e55a33e9c27f45491ad94b83eb6ff7c580811642a2bc6cad3c4774c1c62
-MISC metadata.xml 451 SHA256 f70c308344515f83623dba873f7cb705345bee7975fb4d2d4e2f91fcb54ff78b WHIRLPOOL d0eae6b6587c195d8140dfb271babab330c125ce12c10108a89dd247d6c9241852b8eaee285ead3ece28b982ae6f9e2b349476311255bacf085fafa369608a09
diff --git a/dev-python/irc/files/8.5.1-cleanup-requires.diff b/dev-python/irc/files/8.5.1-cleanup-requires.diff
deleted file mode 100644
index 29740806..00000000
--- a/dev-python/irc/files/8.5.1-cleanup-requires.diff
+++ /dev/null
@@ -1,13 +0,0 @@
---- setup.py 2013-09-19 12:48:38.946374470 +0200
-+++ setup.py 2013-09-19 13:59:33.837894164 +0200
-@@ -34,10 +33,6 @@
- install_requires=[
- 'six',
- ] + importlib_req + argparse_req,
-- setup_requires=[
-- 'hgtools',
-- 'pytest-runner',
-- ],
- tests_require=[
- 'pytest',
- 'mock',
diff --git a/dev-python/irc/irc-8.5.1.ebuild b/dev-python/irc/irc-8.5.1.ebuild
deleted file mode 100644
index b08affc7..00000000
--- a/dev-python/irc/irc-8.5.1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/irc/irc-8.5.1.ebuild,v 1.1 2013/08/26 02:38:37 patrick Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
-
-inherit distutils-r1
-
-DESCRIPTION="IRC client framework written in Python."
-HOMEPAGE="https://bitbucket.org/jaraco/irc http://pypi.python.org/pypi/irc"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples test"
-
-DEPEND="app-arch/unzip
- test? ( dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}] )"
-
-RDEPEND="!>=dev-python/python-irclib-3.2.2[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
- epatch "${FILESDIR}/${PV}-cleanup-requires.diff"
-
- # Don't rely on hgtools for version
- sed -e "s/use_hg_version=True/version=\"${PV}\"/" -i setup.py || die
- sed -e "/^tag_/d" -i setup.cfg || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- py.test irc/tests || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( scripts/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/irc/metadata.xml b/dev-python/irc/metadata.xml
deleted file mode 100644
index 2a4530a4..00000000
--- a/dev-python/irc/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <herd>python</herd>
- <longdescription>
- This project includes an event-driven IRC client framework written in Python,
- as well as an object-oriented wrapper class and some example programs.
- </longdescription>
- <upstream>
- <remote-id type="pypi">irc</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/metadata/md5-cache/dev-python/irc-8.5.1 b/metadata/md5-cache/dev-python/irc-8.5.1
deleted file mode 100644
index d7c53beb..00000000
--- a/metadata/md5-cache/dev-python/irc-8.5.1
+++ /dev/null
@@ -1,14 +0,0 @@
-DEFINED_PHASES=compile configure install prepare test
-DEPEND=app-arch/unzip test? ( dev-python/pytest[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_pypy2_0(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)] dev-python/mock[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_pypy2_0(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)] ) userland_GNU? ( >=sys-apps/coreutils-8.5 ) python_targets_python2_6? ( dev-lang/python:2.6 ) python_targets_python2_7? ( dev-lang/python:2.7 ) python_targets_python3_2? ( dev-lang/python:3.2 ) python_targets_python3_3? ( dev-lang/python:3.3 ) python_targets_pypy2_0? ( virtual/pypy:2.0 ) dev-python/python-exec:=[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_pypy2_0(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)]
-DESCRIPTION=IRC client framework written in Python.
-EAPI=5
-HOMEPAGE=https://bitbucket.org/jaraco/irc http://pypi.python.org/pypi/irc
-IUSE=examples test python_targets_python2_6 python_targets_python2_7 python_targets_python3_2 python_targets_python3_3 python_targets_pypy2_0
-KEYWORDS=~amd64 ~x86
-LICENSE=LGPL-2.1
-RDEPEND=!>=dev-python/python-irclib-3.2.2[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_pypy2_0(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)] dev-python/six[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_pypy2_0(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)] python_targets_python2_6? ( dev-lang/python:2.6 ) python_targets_python2_7? ( dev-lang/python:2.7 ) python_targets_python3_2? ( dev-lang/python:3.2 ) python_targets_python3_3? ( dev-lang/python:3.3 ) python_targets_pypy2_0? ( virtual/pypy:2.0 ) dev-python/python-exec:=[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_pypy2_0(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)]
-REQUIRED_USE=|| ( python_targets_python2_6 python_targets_python2_7 python_targets_python3_2 python_targets_python3_3 python_targets_pypy2_0 )
-SLOT=0
-SRC_URI=mirror://pypi/i/irc/irc-8.5.1.zip
-_eclasses_=distutils-r1 9f10a6b45de097bcad5a9cd394652643 eutils 4878e7f88afc0ba0866ac112190b0fd4 multibuild 56d4120419072116417e8de1bd1040ff multilib 892e597faee02a5b94eb02ab512e7622 multiprocessing a2130e6fc4aa4c6a24b265ca0cbcc2b6 python-r1 2876e182a9a350a7e0049caf3bf3be12 python-utils-r1 a4940acdd0a5ebdc58aaedd38de4983a toolchain-funcs 7ffd28a8c7eea27218865352bfd3ab2f user d0a4d0735a6c0183d707ca919bd72f28
-_md5_=254f1e45992e7232376330b2773fba12