summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-www/apache/Manifest8
-rw-r--r--net-www/apache/files/melee-index.diff44
2 files changed, 40 insertions, 12 deletions
diff --git a/net-www/apache/Manifest b/net-www/apache/Manifest
index b14dd1f2..04401180 100644
--- a/net-www/apache/Manifest
+++ b/net-www/apache/Manifest
@@ -1,7 +1,7 @@
-AUX melee-index.diff 733 RMD160 624749dde03a8ab5ebca131f898373c59b6e9cea SHA1 df15caba4cb611174e53a9760cfb32f7b0c28a1d SHA256 37b14c030a8d3aadc2a971f4b2f09bff53edbd1d8297493a678bae7c60a8a90d
-MD5 f44760062bce5e9603c520e3bcec41a0 files/melee-index.diff 733
-RMD160 624749dde03a8ab5ebca131f898373c59b6e9cea files/melee-index.diff 733
-SHA256 37b14c030a8d3aadc2a971f4b2f09bff53edbd1d8297493a678bae7c60a8a90d files/melee-index.diff 733
+AUX melee-index.diff 1760 RMD160 dd4bbcf7df8ae8b7e8c18fd3001e4713cd46c78e SHA1 f7f71b6973f7620172e67a75d2fde59c05ec2a4a SHA256 c984bb5e237ade14f82877931607c51b4a8cbf72f8a112d5e01fa17fb275e628
+MD5 8f8f4191d21bc50cfb272166be03d0d6 files/melee-index.diff 1760
+RMD160 dd4bbcf7df8ae8b7e8c18fd3001e4713cd46c78e files/melee-index.diff 1760
+SHA256 c984bb5e237ade14f82877931607c51b4a8cbf72f8a112d5e01fa17fb275e628 files/melee-index.diff 1760
DIST gentoo-apache-2.0.58-r2-20060726.tar.bz2 58758 RMD160 46c6da577db444a6553b60d3ae30c61ae3b741fa SHA1 5399c6076fbccc36b1d8a5ed783f77918c3398eb SHA256 b8e0356e87fdd7b55fcecbee804c9a41525b3e6fe8309f87f2509abd161c8e6b
DIST httpd-2.0.58.tar.bz2 4704318 RMD160 2ff44b2254552db908f1defd09e3142527f9bf83 SHA1 697e1674f8efbbe05b9f6c1ba00cd28a37293229 SHA256 4f746715c408f4cac48099ea72560c50ef190568dfcfa8e0762bae66c0398029
EBUILD apache-2.0.58-r2.ebuild 13861 RMD160 ba9818f212be7e4473c3cccb2ca2e928e50b0872 SHA1 bcce17ee3ed0244d59c74409a6a00d9c943e6567 SHA256 33c80e5e1d83debb7db9d20f34b1653de9f85b06ce60bbdb4e903bd4197c3ca0
diff --git a/net-www/apache/files/melee-index.diff b/net-www/apache/files/melee-index.diff
index 7817f4c6..08a73112 100644
--- a/net-www/apache/files/melee-index.diff
+++ b/net-www/apache/files/melee-index.diff
@@ -1,19 +1,47 @@
---- modules/generators/mod_autoindex.c 2006-04-24 19:12:21.000000000 +0200
-+++ modules/generators/mod_autoindex.c 2006-09-23 02:08:45.000000000 +0200
-@@ -153,6 +153,7 @@
+--- modules/generators/mod_autoindex.c.old 2006-09-23 04:11:13.000000000 +0200
++++ modules/generators/mod_autoindex.c 2006-09-23 04:23:19.000000000 +0200
+@@ -151,9 +151,12 @@
+ */
+ static void emit_preamble(request_rec *r, int xhtml, const char *title)
{
++ /* Melee-Hack: Alway add the css for AutoIndexing */
ap_rvputs(r, xhtml ? DOCTYPE_XHTML_1_0T : DOCTYPE_HTML_3_2,
- "<html>\n <head>\n <title>Index of ", title,
-+ "<link rel=\"stylesheet\" type=\"text/css\" href=\"/error/style.css\"/>",
- "</title>\n </head>\n <body>\n", NULL);
+- "<html>\n <head>\n <title>Index of ", title,
+- "</title>\n </head>\n <body>\n", NULL);
++ "<html>\n <head>\n",
++ " <title>Index of ", title, "</title>\n",
++ " <link rel=\"stylesheet\" type=\"text/css\" href=\"/error/style.css\"/>\n",
++ " </head>\n <body>\n", NULL);
}
-@@ -1129,7 +1130,7 @@
+ static void push_item(apr_array_header_t *arr, char *type, const char *to,
+@@ -961,6 +964,9 @@
+ const char *r_accept;
+ const char *r_accept_enc;
+
++ /* Melee-Hack: Alway add the html preamble */
++ suppress_amble = 0;
++
+ /*
+ * If there's a header file, send a subrequest to look for it. If it's
+ * found and html do the subrequest, otherwise handle it
+@@ -1081,6 +1087,9 @@
+ int suppress_post = 0;
+ int suppress_sig = 0;
+
++ /* Melee-Hack: Always add the postamble */
++ suppress_amble = 0;
++
+ /*
+ * If there's a readme file, send a subrequest to look for it. If it's
+ * found and a text file, handle it -- otherwise fall through and
+@@ -1129,7 +1138,8 @@
ap_rputs(ap_psignature("", r), r);
}
if (!suppress_post) {
- ap_rputs("</body></html>\n", r);
-+ ap_rputs("<center><img src="/icons/linux.png"></center></body></html>\n", r);
++ /* Melee-Hack: Alway add the icons for AutoIndexing */
++ ap_rputs("<center><img src=\"/icons/linux.png\"></center></body></html>\n", r);
}
if (rr != NULL) {
ap_destroy_sub_req(rr);