summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/pesetacoin/Manifest1
-rw-r--r--net-p2p/pesetacoin/metadata.xml12
-rw-r--r--net-p2p/pesetacoin/pesetacoin-0.9.1.ebuild71
-rw-r--r--profiles/use.local.desc2
4 files changed, 86 insertions, 0 deletions
diff --git a/net-p2p/pesetacoin/Manifest b/net-p2p/pesetacoin/Manifest
new file mode 100644
index 00000000..b4072b95
--- /dev/null
+++ b/net-p2p/pesetacoin/Manifest
@@ -0,0 +1 @@
+DIST pesetacoin-0.9.1.tar.gz 5110821 BLAKE2B 7a37977bbcc2190f95f4905ef7527a0fc25372cd78854590b5f133e3a71ce9ea045477ba249456463ecc0e4cc5c01a76a0d62ce7f2890bbfdc54e732070eb7e9 SHA512 333ef31d9dc0a9ce93c8e1bf4023c3006f6a7d145ebd8a9b68e2c4868c91328f1fc34fff60f4509ab65745644f668d8c24b465dcaf167ce28fbb35cdf26afae4
diff --git a/net-p2p/pesetacoin/metadata.xml b/net-p2p/pesetacoin/metadata.xml
new file mode 100644
index 00000000..97709f02
--- /dev/null
+++ b/net-p2p/pesetacoin/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bertrand@jacquin.bzh</email>
+ <name>Bertrand Jacquin</name>
+ </maintainer>
+ <use>
+ <flag name="qrcode">Enable generation of QR Codes for receiving payments</flag>
+ <flag name="wallet">Enable wallet support</flag>
+ </use>
+</pkgmetadata>
diff --git a/net-p2p/pesetacoin/pesetacoin-0.9.1.ebuild b/net-p2p/pesetacoin/pesetacoin-0.9.1.ebuild
new file mode 100644
index 00000000..3aab5227
--- /dev/null
+++ b/net-p2p/pesetacoin/pesetacoin-0.9.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+DB_VER="5.1"
+
+inherit db-use flag-o-matic autotools
+
+MY_PN="Pesetacoin-${PV}-Oficial"
+
+DESCRIPTION="Pesetacoin is a crypto-currency focused in the Spanish Country"
+HOMEPAGE="http://pesetacoin.info"
+SRC_URI="https://github.com/FundacionPesetacoin/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="dbus +qrcode +qt4 qt5 +upnp +wallet"
+REQUIRED_USE="?? ( qt4 qt5 )"
+
+RDEPEND="
+ dev-libs/openssl:0[-bindist]
+ >=dev-libs/boost-1.20.0[threads(+)]
+ qrcode? ( media-gfx/qrencode )
+ qt4? (
+ dev-qt/qtgui:4
+ dbus? ( dev-qt/qtdbus:4 )
+ )
+ qt5? (
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtprintsupport:5
+ dbus? ( dev-qt/qtdbus:5 )
+ )
+ upnp? ( net-libs/miniupnpc:0 )
+ wallet? ( sys-libs/db:$(db_ver_to_slot ${DB_VER})[cxx] )
+ dev-libs/protobuf:0"
+DEPEND="${RDEPEND}
+ qt5? ( dev-qt/linguist-tools:5 )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ default
+
+ append-cppflags "-I$(db_includedir ${DB_VER})"
+ eautoreconf
+}
+
+src_configure () {
+ local my_econf=(
+ --with-cli
+ --with-daemon
+ $(use_enable wallet)
+ $(use_with upnp miniupnpc)
+ $(use_with dbus qtdbus)
+ $(use_with qrcode qrencode)
+ )
+
+ if use qt5 ; then
+ my_econf+=( --with-gui=qt5 )
+ elif use qt4 ; then
+ my_econf+=( --with-gui=qt4 )
+ else
+ my_econf+=( --with-gui=no )
+ fi
+
+ econf \
+ "${my_econf[@]}"
+}
diff --git a/profiles/use.local.desc b/profiles/use.local.desc
index 89e9354c..e5f648f9 100644
--- a/profiles/use.local.desc
+++ b/profiles/use.local.desc
@@ -69,6 +69,8 @@ net-p2p/dogecoin:qrcode - Enable generation of QR Codes for receiving payments
net-p2p/dogecoin:utils - Build the utils
net-p2p/dogecoin:wallet - Enable wallet support
net-p2p/monero:system-libs - Use system libraries instead of the ones included in the upstream distribution
+net-p2p/pesetacoin:qrcode - Enable generation of QR Codes for receiving payments
+net-p2p/pesetacoin:wallet - Enable wallet support
sys-firmware/gnuk:tools - Install aditional tools
virtual/linux-sources:firmware - Install linux kernel firmware
www-apps/phabricator:extension-sprint - Enable extension sprint via www-apps/phabricator-extensions-Sprint