summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--eclass/linux-build.eclass30
-rw-r--r--net-p2p/c-lightning/c-lightning-24.08.2.ebuild (renamed from net-p2p/c-lightning/c-lightning-24.08.ebuild)0
-rw-r--r--net-p2p/c-lightning/files/24.08.2-build-do-not-Werror.patch (renamed from net-p2p/c-lightning/files/24.08-build-do-not-Werror.patch)0
-rw-r--r--net-p2p/c-lightning/files/24.08.2-build-do-not-cargo-quiet.patch (renamed from net-p2p/c-lightning/files/24.08-build-do-not-cargo-quiet.patch)0
-rw-r--r--net-p2p/c-lightning/files/24.08.2-build-do-not-refresh-external-modules.patch (renamed from net-p2p/c-lightning/files/24.08-build-do-not-refresh-external-modules.patch)0
-rw-r--r--net-p2p/c-lightning/files/24.08.2-build-remove-deprecated-AM_ENABLE_MULTILIB.patch (renamed from net-p2p/c-lightning/files/24.08-build-remove-deprecated-AM_ENABLE_MULTILIB.patch)0
-rw-r--r--net-p2p/c-lightning/files/24.08.2-build-use-FHS-docdir.patch (renamed from net-p2p/c-lightning/files/24.08-build-use-FHS-docdir.patch)0
-rw-r--r--profiles/common/make.defaults5
-rw-r--r--profiles/common/package.use2
-rw-r--r--profiles/common/packages1
-rw-r--r--profiles/common/profile.bashrc3
-rw-r--r--profiles/container/package.use2
-rw-r--r--profiles/container/packages2
-rw-r--r--profiles/desktop/packages2
-rw-r--r--profiles/generic/package.use1
-rw-r--r--profiles/generic/packages2
-rw-r--r--profiles/raspberry-pi/packages1
-rw-r--r--profiles/server/aws/packages1
-rw-r--r--sys-kernel/longterm-sources/Manifest12
-rw-r--r--sys-kernel/longterm-sources/longterm-sources-4.19.323.ebuild (renamed from sys-kernel/longterm-sources/longterm-sources-4.19.322.ebuild)0
-rw-r--r--sys-kernel/longterm-sources/longterm-sources-5.10.229.ebuild (renamed from sys-kernel/longterm-sources/longterm-sources-5.10.226.ebuild)0
-rw-r--r--sys-kernel/longterm-sources/longterm-sources-5.15.171.ebuild (renamed from sys-kernel/longterm-sources/longterm-sources-5.15.167.ebuild)0
-rw-r--r--sys-kernel/longterm-sources/longterm-sources-5.4.285.ebuild (renamed from sys-kernel/longterm-sources/longterm-sources-5.4.284.ebuild)0
-rw-r--r--sys-kernel/longterm-sources/longterm-sources-6.1.116.ebuild (renamed from sys-kernel/longterm-sources/longterm-sources-6.1.111.ebuild)0
-rw-r--r--sys-kernel/longterm-sources/longterm-sources-6.6.60.ebuild (renamed from sys-kernel/longterm-sources/longterm-sources-6.6.52.ebuild)0
-rw-r--r--sys-kernel/stable-sources/Manifest4
-rw-r--r--sys-kernel/stable-sources/stable-sources-6.10.14.ebuild (renamed from sys-kernel/stable-sources/stable-sources-6.10.11.ebuild)0
-rw-r--r--sys-kernel/stable-sources/stable-sources-6.11.7.ebuild7
28 files changed, 55 insertions, 20 deletions
diff --git a/eclass/linux-build.eclass b/eclass/linux-build.eclass
index 487fc8b0..247d7e64 100644
--- a/eclass/linux-build.eclass
+++ b/eclass/linux-build.eclass
@@ -58,7 +58,7 @@ BDEPEND="${BDEPEND}
sys-devel/lld:=
)
rust? ( !arm? ( !x86? (
- dev-lang/rust:=[rust-src]
+ dev-lang/rust:=[rust-src,rustfmt]
dev-util/bindgen
) ) )"
DEPEND="${DEPEND}
@@ -546,6 +546,7 @@ _linux-build_src_prepare_build() {
# Various
--ignore-matching-lines '^CONFIG_PAHOLE_VERSION='
+ --ignore-matching-lines '^CONFIG_HAVE_CTF_TOOLCHAIN='
)
if ! diff -q "${_diff_opts[@]}" "${BUILDDIR}/.config.old" "${BUILDDIR}/.config" ; then
@@ -555,6 +556,18 @@ _linux-build_src_prepare_build() {
fi
emake prepare "${myopt[@]}"
+
+ if _linux-build_configval MODULES ; then
+ emake modules_prepare "${myopt[@]}"
+ fi
+
+ cp -R "${BUILDDIR}" "${WORKDIR}/prepare" || die
+
+ rm -r "${WORKDIR}/prepare/Makefile"
+ rm -r "${WORKDIR}/prepare/certs"
+ rm -r "${WORKDIR}/prepare/source"
+ find "${WORKDIR}/prepare" -type f -name '.*' -delete
+ find "${WORKDIR}/prepare" -type f -name '*.o' -delete
}
linux-build_src_prepare() {
@@ -647,6 +660,16 @@ _linux-build_src_install_sources() {
insinto "/usr/src/linux-${KV_FULL}"
doins "${BUILDDIR}/.config"
+
+ if use build ; then
+ cp -R -T "${WORKDIR}/prepare" "${ED}/usr/src/linux-${KV_FULL}" || die
+
+ insinto "/usr/src/linux-${KV_FULL}"
+ doins "${BUILDDIR}/Module.symvers"
+ doins "${BUILDDIR}/System.map"
+
+ dosym "/usr/src/linux-${KV_FULL}" "/lib/modules/${KV_FULL}/build"
+ fi
}
_linux-build_src_install_build() {
@@ -697,10 +720,9 @@ _linux-build_src_install_build() {
|| die "depmod failed"
rm "${WORKDIR}/lib/modules/${KV_FULL}/build"
- rm "${WORKDIR}/lib/modules/${KV_FULL}/source"
- insinto /lib
- doins -r "${WORKDIR}/lib/modules"
+ insinto /lib/modules
+ doins -r "${WORKDIR}/lib/modules/${KV_FULL}"
fi
if [[ -e "${WORKDIR}/lib/firmware" ]] ; then
diff --git a/net-p2p/c-lightning/c-lightning-24.08.ebuild b/net-p2p/c-lightning/c-lightning-24.08.2.ebuild
index 3cb1a929..3cb1a929 100644
--- a/net-p2p/c-lightning/c-lightning-24.08.ebuild
+++ b/net-p2p/c-lightning/c-lightning-24.08.2.ebuild
diff --git a/net-p2p/c-lightning/files/24.08-build-do-not-Werror.patch b/net-p2p/c-lightning/files/24.08.2-build-do-not-Werror.patch
index a7ad96d3..a7ad96d3 100644
--- a/net-p2p/c-lightning/files/24.08-build-do-not-Werror.patch
+++ b/net-p2p/c-lightning/files/24.08.2-build-do-not-Werror.patch
diff --git a/net-p2p/c-lightning/files/24.08-build-do-not-cargo-quiet.patch b/net-p2p/c-lightning/files/24.08.2-build-do-not-cargo-quiet.patch
index 6eecb030..6eecb030 100644
--- a/net-p2p/c-lightning/files/24.08-build-do-not-cargo-quiet.patch
+++ b/net-p2p/c-lightning/files/24.08.2-build-do-not-cargo-quiet.patch
diff --git a/net-p2p/c-lightning/files/24.08-build-do-not-refresh-external-modules.patch b/net-p2p/c-lightning/files/24.08.2-build-do-not-refresh-external-modules.patch
index 45496c71..45496c71 100644
--- a/net-p2p/c-lightning/files/24.08-build-do-not-refresh-external-modules.patch
+++ b/net-p2p/c-lightning/files/24.08.2-build-do-not-refresh-external-modules.patch
diff --git a/net-p2p/c-lightning/files/24.08-build-remove-deprecated-AM_ENABLE_MULTILIB.patch b/net-p2p/c-lightning/files/24.08.2-build-remove-deprecated-AM_ENABLE_MULTILIB.patch
index 415a71cf..415a71cf 100644
--- a/net-p2p/c-lightning/files/24.08-build-remove-deprecated-AM_ENABLE_MULTILIB.patch
+++ b/net-p2p/c-lightning/files/24.08.2-build-remove-deprecated-AM_ENABLE_MULTILIB.patch
diff --git a/net-p2p/c-lightning/files/24.08-build-use-FHS-docdir.patch b/net-p2p/c-lightning/files/24.08.2-build-use-FHS-docdir.patch
index 6c861a7d..6c861a7d 100644
--- a/net-p2p/c-lightning/files/24.08-build-use-FHS-docdir.patch
+++ b/net-p2p/c-lightning/files/24.08.2-build-use-FHS-docdir.patch
diff --git a/profiles/common/make.defaults b/profiles/common/make.defaults
index f29ca4af..8e6ba0d1 100644
--- a/profiles/common/make.defaults
+++ b/profiles/common/make.defaults
@@ -51,7 +51,7 @@ USE="${USE} -nls"
USE="${USE} logrotate syslog"
# Network
-USE="${USE} -bluetooth -ftp idn libidn2 ipv6 http2 netlink ntp -tcpd -modemmanager -upnp -libproxy"
+USE="${USE} -bluetooth -ftp idn libidn2 ipv6 http2 http3 netlink ntp -tcpd -modemmanager -upnp -libproxy"
# Performance
USE="${USE} jit mmap threads"
@@ -85,6 +85,9 @@ RESUMECOMMAND="${FETCHCOMMAND} -C -"
PORTAGE_NICENESS=19
EMERGE_DEFAULT_OPTS="-v --quiet-build=n --misspell-suggestions=n"
+PORTAGE_COMPRESS=zstd
+BINPKG_COMPRESS=zstd
+
PORTAGE_STRIP_FLAGS="--strip-unneeded -R .comment -R .GCC.command.line -R .note.gnu.gold-version"
# Duplicate from base/make.defaults while removing /lib/modules
diff --git a/profiles/common/package.use b/profiles/common/package.use
index ed20f298..46a54f4e 100644
--- a/profiles/common/package.use
+++ b/profiles/common/package.use
@@ -154,3 +154,5 @@ net-analyzer/tcpdump suid
sys-process/procps modern-top
app-arch/xz-utils -extra-filters
net-analyzer/tcpdump -samba
+
+net-print/cups-meta -browsed
diff --git a/profiles/common/packages b/profiles/common/packages
index e4d0b64c..6c1b3ddd 100644
--- a/profiles/common/packages
+++ b/profiles/common/packages
@@ -31,7 +31,6 @@
*sys-kernel/longterm-sources:6.6
*sys-kernel/linux-firmware
-*sys-process/cronie
*sys-process/lsof
*pants-on/base
diff --git a/profiles/common/profile.bashrc b/profiles/common/profile.bashrc
index 6823ea42..d37062b9 100644
--- a/profiles/common/profile.bashrc
+++ b/profiles/common/profile.bashrc
@@ -196,6 +196,8 @@ function __drop-doc () {
function __drop-unneeded () {
local -a _FILES=(
/etc/*.sample
+ /etc/apache2/vhosts.d/00_default_*.conf
+ /etc/apache2/vhosts.d/default_vhost.include
/etc/avahi/avahi-dnsconfd.action
/etc/avahi/services/sftp-ssh.service
/etc/avahi/services/ssh.service
@@ -214,6 +216,7 @@ function __drop-unneeded () {
/etc/init.d/*-supervise
/etc/init.d/pydoc*
/etc/pkcs11/*.example
+ /etc/powerdns/recursor.yml-dist
/etc/rmt
/etc/snmp/*.example
/etc/squid/*.default
diff --git a/profiles/container/package.use b/profiles/container/package.use
index 86e4bfdc..e177fa76 100644
--- a/profiles/container/package.use
+++ b/profiles/container/package.use
@@ -1,3 +1,3 @@
net-proxy/haproxy slz -zlib tools pcre-jit
-sys-apps/systemd -kernel-install
+sys-apps/systemd -kernel-install -kmod
www-servers/nginx -ssl -http-cache pcre-jit threads
diff --git a/profiles/container/packages b/profiles/container/packages
index 0e09dd92..ab42bf49 100644
--- a/profiles/container/packages
+++ b/profiles/container/packages
@@ -4,12 +4,12 @@
-*net-firewall/iptables
-*net-misc/socat
-*net-misc/wget
+-*sys-apps/kmod
-*sys-apps/man-pages
-*sys-apps/pv
-*sys-boot/grub
-*sys-kernel/linux-firmware
-*sys-kernel/longterm-sources:6.6
--*sys-process/cronie
-*sys-process/lsof
-*virtual/logger
-*virtual/man
diff --git a/profiles/desktop/packages b/profiles/desktop/packages
index 171fa454..0c761eab 100644
--- a/profiles/desktop/packages
+++ b/profiles/desktop/packages
@@ -17,5 +17,3 @@
*media-fonts/open-sans
-*sys-boot/grub
--*sys-process/cronie
--*virtual/cron
diff --git a/profiles/generic/package.use b/profiles/generic/package.use
index a2048ef1..d1e07708 100644
--- a/profiles/generic/package.use
+++ b/profiles/generic/package.use
@@ -1,5 +1,6 @@
app-admin/sudo -sendmail
app-crypt/gnupg smartcard tpm usb
+dev-python/pillow -jpeg
net-analyzer/tcpdump -smi
net-libs/gnutls -dane
sys-apps/iproute2 -iptables
diff --git a/profiles/generic/packages b/profiles/generic/packages
index a2e4f23b..bb72aa8c 100644
--- a/profiles/generic/packages
+++ b/profiles/generic/packages
@@ -1,5 +1,6 @@
*app-misc/resolve-march-native
*app-portage/cpuid2cpuflags
+*sys-apps/kexec-tools
*sys-apps/lshw
*sys-apps/pciutils
*sys-apps/usbutils
@@ -18,6 +19,5 @@
-*sys-apps/man-pages
-*sys-apps/pv
-*sys-boot/grub
--*sys-process/cronie
-*sys-process/lsof
-*virtual/man
diff --git a/profiles/raspberry-pi/packages b/profiles/raspberry-pi/packages
index 86f132de..11ff8369 100644
--- a/profiles/raspberry-pi/packages
+++ b/profiles/raspberry-pi/packages
@@ -10,5 +10,4 @@
-*sys-apps/man-pages
-*sys-apps/pv
-*sys-boot/grub
--*sys-process/cronie
-*virtual/man
diff --git a/profiles/server/aws/packages b/profiles/server/aws/packages
index ca6c0894..873ef39e 100644
--- a/profiles/server/aws/packages
+++ b/profiles/server/aws/packages
@@ -1,3 +1,2 @@
-*sys-boot/grub
-*sys-kernel/linux-firmware
--*sys-process/cronie
diff --git a/sys-kernel/longterm-sources/Manifest b/sys-kernel/longterm-sources/Manifest
index cc3aa9a6..f36af0e8 100644
--- a/sys-kernel/longterm-sources/Manifest
+++ b/sys-kernel/longterm-sources/Manifest
@@ -4,9 +4,9 @@ DIST linux-5.15.tar.xz 121913744 BLAKE2B 3921274b23f7938abdf3ed9334534b4581e13d7
DIST linux-5.4.tar.xz 109441440 BLAKE2B 193bc4a3147e147d5529956164ec4912fad5d5c6fb07f909ff1056e57235834173194afc686993ccd785c1ff15804de0961b625f3008cca0e27493efc8f27b13 SHA512 9f60f77e8ab972b9438ac648bed17551c8491d6585a5e85f694b2eaa4c623fbc61eb18419b2656b6795eac5deec0edaa04547fc6723fbda52256bd7f3486898f
DIST linux-6.1.tar.xz 134728520 BLAKE2B ae60257860b2bd1bd708d183f0443afc60ebbd2b3d535c45e44c2e541bd0928530a3b62de6385dd4e4726ebbedcc0a871d4f3ffb4105b9f1f6d8ed7467f5688e SHA512 6ed2a73c2699d0810e54753715635736fc370288ad5ce95c594f2379959b0e418665cd71bc512a0273fe226fe90074d8b10d14c209080a6466498417a4fdda68
DIST linux-6.6.tar.xz 140064536 BLAKE2B 5f02fd8696d42f7ec8c5fbadec8e7270bdcfcb1f9844a6c4db3e1fd461c93ce1ccda650ca72dceb4890ebcbbf768ba8fba0bce91efc49fbd2c307b04e95665f2 SHA512 458b2c34d46206f9b4ccbac54cc57aeca1eaecaf831bc441e59701bac6eadffc17f6ce24af6eadd0454964e843186539ac0d63295ad2cc32d112b60360c39a35
-DIST patch-4.19.322.xz 6167468 BLAKE2B c98f69d3b4507d457c38ae4c36ee0ca61b889e5782310775829f9adef4dffde16dc843a96ae3e9dd3af788d2a38a552970ea7e91cf1bfc221a08c95205f2090d SHA512 32c32074c6a673e03187063534b69d5f354f940f2f9f0a666e6b070c16b3853cc50564849f6cc6a0d79ee730c963b282c895f136c28e0bc5b2f54993cea49902
-DIST patch-5.10.226.xz 6236088 BLAKE2B c6e0ab4fbf820749154d78b1a107d3d19140cfd8a23a5b04fe2cef23778e02f379a16936651511cf9cad556d95ec56f39e752430e36f88ed389cf9ff21c23bc2 SHA512 9b1d7f4e36aa2d98d92bb80fc1230a68cbd7679cf1e2dcdc7eae759e45854f838a7a70f6be6ffa3b6c8b24289bb24e6b1df26f1a55f1dbbc7f30879b69fc0981
-DIST patch-5.15.167.xz 6199840 BLAKE2B f1b1ff1d9259e9b9f4de2709f0bf683d16d86f05245c6534d8e7987ecfd591a52c028bbf04d143852ee0863081ee91a5f8f19e5c167747e8745523fb91721430 SHA512 99c94dc03d1e05d2693e84a0c71d447c59cbb013f815a252e3fafec8358e46c470a59ba7216bd98c6cf20d92e13d48fc5f6341499c353f1960d3c57808000005
-DIST patch-5.4.284.xz 5726484 BLAKE2B dc05f67c379a8c99179da2a62b5d6bef186393d791ccd2a26c99c50bcec5ae211fe3b6a14be38d80ea431b93fecc8d55bafc9492ea1e6f9dd64829671c80e5f9 SHA512 54131a007e78382dd093ca3bdb65ac7b5681f8340b29ce09e93ab802392bccaf65e1b774abc24af364ab3ce28c5ac28bac329593f40e5feb4272b557479a06aa
-DIST patch-6.1.111.xz 5192116 BLAKE2B e2c78000967a0b5de761dff1bc9f8dfc7c66967a27b2bc2c8650781d7e20c2643a0212e6465d97ff5afbfecccf78b4ea5a541ddda6d5c5d87449cf812c0aaf5c SHA512 4dc8f9b68a344a0ad5baef0f28e8a6a23065664fa9a57e184485077f4735ae04016fa032dc3a05b93af0d745b3f57f2c9d56d997501701f09d63f0fd57812733
-DIST patch-6.6.52.xz 2901836 BLAKE2B 94c94b666692d7456feae3ec1491feb41663a18a4e05d971f6c2d27049e105a4ebb53134c716e4d05917fa4b772843208dc18879855edbf458021f92413fc356 SHA512 f5fe39550d9cf02dbdc4483b544688260d69a67332168b5039fa7ca28eddbec4383daadd755857ed6c3b84b5e30094ec29f73e8b0c9095cb064d605bf932d65c
+DIST patch-4.19.323.xz 6238532 BLAKE2B 14458334438f09e709b6f1141d28a47053cc19656a960d43eeddb869548d013cf58ac45f412563246c70d02fc7436114ce703fd01026ec4de3b059dfec2cb51d SHA512 7c3a0309b20f752a0612ba9ecd8ebf8fbcac4de4227f9ebfd493cb46a0b2c7dd58b7d390d12951ad25c8a8c92b02a76fae0664f575a6dfb8d7c042aaa227aa6f
+DIST patch-5.10.229.xz 6385284 BLAKE2B 5cb15eb3547cfcf8cc5132a76f77c5facfdf941baa1b1efe820c88065701f215a9f31e7213f402d4e72e12fa9b1e053fe06c9699b8859d9744ff3609d2be623f SHA512 489f738b0c457afc5908f8f1c0281e8b0082fabe3ab434f511f4ab6b3e181ca45eb5e30b41f2613c52afe68805c8e5aa6027898f12b91d06b540f6780e97f2ed
+DIST patch-5.15.171.xz 6418684 BLAKE2B 0990861a25cbbeea22deeec461fa81270ea7a650ce69cb924f5d1f4488bfb372f825f3ec787cc39bc584077e0081081a05aabfa45542e964d8dcd85f424a5c5b SHA512 827fad5ce006612e27cca90e95cf6099dec4ac484ae04947d4af365432478f62217153a7144b66bbcded37f7ac47af91c9e0914d8211fae34caba215e0e2d979
+DIST patch-5.4.285.xz 5848868 BLAKE2B f48953649a0cd30a58591f761c41a0f7ce4c1d06c303485dca43496c032454d0b17694c16a0aa9517e0d5fcbb10a236defc043901d761cdfe90c152f0927d16e SHA512 7b1eee5220e1320137ea19e3448b8be0ce885b03432199f08469e35c6b73ab911257f68ee623caf09a839275a080986a2afe4cb2dd6580b601984991b9f34bde
+DIST patch-6.1.116.xz 5484296 BLAKE2B 000781d23556fb645c74afe57b1360c2a4ce7a53f9cb704d90772ac3b6080698e875387a11e708a93f8fe19a318d4c8c03abdcbe4f20ba521449aeb8b651a959 SHA512 ece5aaf12f834f773b213397ed8958b82765979cfe1019605384e8b11ad36233a749b78eaba42a08c659477c7de2bf0ad362f38c76f454e4c5c345f834583f36
+DIST patch-6.6.60.xz 3314136 BLAKE2B 9dd89075db3fd228ecaa343885f7556283388255cd8eebee50884d651ab9c50f7a54c7eb1429a5925038e66d78e8911140767ea289dffd3d32eb22c8e0dba0d2 SHA512 cc4a9f9d0e698978bc08da6e358310a7cb939100113370787b4ca485b35a2dee3d71f4473ac76a5432fa27d057492902969a246b356ee1bce0ea7acd0ceaec0e
diff --git a/sys-kernel/longterm-sources/longterm-sources-4.19.322.ebuild b/sys-kernel/longterm-sources/longterm-sources-4.19.323.ebuild
index 888495b1..888495b1 100644
--- a/sys-kernel/longterm-sources/longterm-sources-4.19.322.ebuild
+++ b/sys-kernel/longterm-sources/longterm-sources-4.19.323.ebuild
diff --git a/sys-kernel/longterm-sources/longterm-sources-5.10.226.ebuild b/sys-kernel/longterm-sources/longterm-sources-5.10.229.ebuild
index 02e7861b..02e7861b 100644
--- a/sys-kernel/longterm-sources/longterm-sources-5.10.226.ebuild
+++ b/sys-kernel/longterm-sources/longterm-sources-5.10.229.ebuild
diff --git a/sys-kernel/longterm-sources/longterm-sources-5.15.167.ebuild b/sys-kernel/longterm-sources/longterm-sources-5.15.171.ebuild
index 02e7861b..02e7861b 100644
--- a/sys-kernel/longterm-sources/longterm-sources-5.15.167.ebuild
+++ b/sys-kernel/longterm-sources/longterm-sources-5.15.171.ebuild
diff --git a/sys-kernel/longterm-sources/longterm-sources-5.4.284.ebuild b/sys-kernel/longterm-sources/longterm-sources-5.4.285.ebuild
index 888495b1..888495b1 100644
--- a/sys-kernel/longterm-sources/longterm-sources-5.4.284.ebuild
+++ b/sys-kernel/longterm-sources/longterm-sources-5.4.285.ebuild
diff --git a/sys-kernel/longterm-sources/longterm-sources-6.1.111.ebuild b/sys-kernel/longterm-sources/longterm-sources-6.1.116.ebuild
index 02e7861b..02e7861b 100644
--- a/sys-kernel/longterm-sources/longterm-sources-6.1.111.ebuild
+++ b/sys-kernel/longterm-sources/longterm-sources-6.1.116.ebuild
diff --git a/sys-kernel/longterm-sources/longterm-sources-6.6.52.ebuild b/sys-kernel/longterm-sources/longterm-sources-6.6.60.ebuild
index 02e7861b..02e7861b 100644
--- a/sys-kernel/longterm-sources/longterm-sources-6.6.52.ebuild
+++ b/sys-kernel/longterm-sources/longterm-sources-6.6.60.ebuild
diff --git a/sys-kernel/stable-sources/Manifest b/sys-kernel/stable-sources/Manifest
index cedcf5cf..09fbdd86 100644
--- a/sys-kernel/stable-sources/Manifest
+++ b/sys-kernel/stable-sources/Manifest
@@ -1,2 +1,4 @@
DIST linux-6.10.tar.xz 145142812 BLAKE2B bb243ea7493b9d63aa2df2050a3f1ae2b89ee84a20015239cf157e3f4f51c7ac5efedc8a51132b2d7482f9276ac418de6624831c8a3b806130d9c2d2124c539b SHA512 baa2487954044f991d2ae254d77d14a1f0185dd62c9f0fcaff69f586c9f906823017b8db1c4588f27b076dfa3ebb606929fec859f60ea419e7974330b9289cc2
-DIST patch-6.10.11.xz 714624 BLAKE2B ad380f02d5f18669538f14d0596014cfe72b224b9c71678ccd17fda22606252d2d109b988555d6f8bb842dba9feb8d9a723316fa6ea68b561fe82754ab2215f0 SHA512 647939f3750fb5205556f2bc33d20c4fbec478e5ba13bc957312cdc2687a4e8216391527deca532026b2a8879cc4840a61b328feddfb57778fb947baf1d42276
+DIST linux-6.11.tar.xz 146900704 BLAKE2B e7750c0878d71a56a0ce52d4c4c912199dad5bf5e2e8f872585a6494afbb37cbd852e612a6858936d2dc9b7776a3933818f540db408d57e90d18ea5249bba7ab SHA512 329c1f94008742e3f0c2ce7e591a16316d1b2cb9ea4596d4f45604097e07b7aa2f64afa40630a07f321a858455c77aa32ba57b271932ddcf4dc27863f9081cea
+DIST patch-6.10.14.xz 1050528 BLAKE2B bb16fc578c1e6dae17c2c4b98020c1932a7bab52678117b86a03b4adb60eb2bd6b5cc25792beafe9d7caa5a97f99f86cc3cd5faa4f06fb99b8eda516dd6195c2 SHA512 fff5b671017cada8a8a7702a89d3a1b26de9ce226b802c04bf61f9b8580e698b47c4a58ce6573aba1fb3868d1dcbe53980476d8adaa21636ab69b3b1192f6730
+DIST patch-6.11.7.xz 669756 BLAKE2B f2ec79bd337eaa61c7203c00ce61b3e5afa9eee38a3e38e63a7fc9270af86674e5c369ca7ddfe4fa5f79601b1c874af1ce732bd8987529c7db2f2f9ca54ba85b SHA512 031c22e2fa7e1c7808f50dc2120a35d10a0b81d30636c5d19146fe12558999517f132213b72c39a32d8cc2c0e14e16ff64cac63ef97f8be0ebe8e709a3de8156
diff --git a/sys-kernel/stable-sources/stable-sources-6.10.11.ebuild b/sys-kernel/stable-sources/stable-sources-6.10.14.ebuild
index 8c331148..8c331148 100644
--- a/sys-kernel/stable-sources/stable-sources-6.10.11.ebuild
+++ b/sys-kernel/stable-sources/stable-sources-6.10.14.ebuild
diff --git a/sys-kernel/stable-sources/stable-sources-6.11.7.ebuild b/sys-kernel/stable-sources/stable-sources-6.11.7.ebuild
new file mode 100644
index 00000000..8c331148
--- /dev/null
+++ b/sys-kernel/stable-sources/stable-sources-6.11.7.ebuild
@@ -0,0 +1,7 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit linux-build
+
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"