summaryrefslogtreecommitdiff
path: root/x11-misc
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2006-02-08 20:47:35 +0100
committerBertrand Jacquin <beber@meleeweb.net>2006-02-08 20:47:35 +0100
commit790151c2bd8997fed9fe63cd7dc1784d9d55cc04 (patch)
tree8cd75f226a1014fdcc51368f88003cb91e18d5d9 /x11-misc
parentUpdate dependencies in azrael (diff)
downloadportage-790151c2bd8997fed9fe63cd7dc1784d9d55cc04.tar.xz
Add xgl stuff
From http://dev.gentoo.org/~hanno/
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/glitzinfo/Manifest2
-rw-r--r--x11-misc/glitzinfo/files/digest-glitzinfo-200601070
-rw-r--r--x11-misc/glitzinfo/glitzinfo-20060107.ebuild26
-rw-r--r--x11-misc/glxcompmgr/Manifest2
-rw-r--r--x11-misc/glxcompmgr/files/digest-glxcompmgr-200601190
-rw-r--r--x11-misc/glxcompmgr/glxcompmgr-20060119.ebuild29
6 files changed, 59 insertions, 0 deletions
diff --git a/x11-misc/glitzinfo/Manifest b/x11-misc/glitzinfo/Manifest
new file mode 100644
index 00000000..3bbea325
--- /dev/null
+++ b/x11-misc/glitzinfo/Manifest
@@ -0,0 +1,2 @@
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-glitzinfo-20060107 0
+MD5 773d1ba51d7b523079c15bacce64d966 glitzinfo-20060107.ebuild 586
diff --git a/x11-misc/glitzinfo/files/digest-glitzinfo-20060107 b/x11-misc/glitzinfo/files/digest-glitzinfo-20060107
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/x11-misc/glitzinfo/files/digest-glitzinfo-20060107
diff --git a/x11-misc/glitzinfo/glitzinfo-20060107.ebuild b/x11-misc/glitzinfo/glitzinfo-20060107.ebuild
new file mode 100644
index 00000000..daa4f46f
--- /dev/null
+++ b/x11-misc/glitzinfo/glitzinfo-20060107.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/glitz/glitz-0.4.4.ebuild,v 1.6 2006/01/04 23:23:46 halcy0n Exp $
+
+inherit eutils cvs
+
+ECVS_SERVER="cvs.freedesktop.org:/cvs/cairo"
+ECVS_MODULE="glitzinfo"
+S=${WORKDIR}/${ECVS_MODULE}
+
+DESCRIPTION="Glitz info tool"
+HOMEPAGE="http://www.freedesktop.org/Software/glitz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="media-libs/glitz"
+
+src_compile() {
+ emake -f Makefile.glx || die
+}
+
+src_install() {
+ dobin glitzinfo
+}
diff --git a/x11-misc/glxcompmgr/Manifest b/x11-misc/glxcompmgr/Manifest
new file mode 100644
index 00000000..78af9912
--- /dev/null
+++ b/x11-misc/glxcompmgr/Manifest
@@ -0,0 +1,2 @@
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-glxcompmgr-20060119 0
+MD5 240dae1026af936e4488e25482753fb7 glxcompmgr-20060119.ebuild 620
diff --git a/x11-misc/glxcompmgr/files/digest-glxcompmgr-20060119 b/x11-misc/glxcompmgr/files/digest-glxcompmgr-20060119
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/x11-misc/glxcompmgr/files/digest-glxcompmgr-20060119
diff --git a/x11-misc/glxcompmgr/glxcompmgr-20060119.ebuild b/x11-misc/glxcompmgr/glxcompmgr-20060119.ebuild
new file mode 100644
index 00000000..54e3a497
--- /dev/null
+++ b/x11-misc/glxcompmgr/glxcompmgr-20060119.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/glitz/glitz-0.4.4.ebuild,v 1.6 2006/01/04 23:23:46 halcy0n Exp $
+
+inherit eutils cvs
+
+ECVS_SERVER="cvs.freedesktop.org:/cvs/xorg"
+ECVS_MODULE="app/glxcompmgr"
+S=${WORKDIR}/${ECVS_MODULE}
+
+
+DESCRIPTION="Glxcompmgr composite manager"
+HOMEPAGE="http://xorg.freedesktop.org"
+LICENSE="X11"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="media-libs/mesa"
+
+src_compile() {
+ ./autogen.sh
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+}