summaryrefslogtreecommitdiff
path: root/x11-misc/entrance
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2021-04-25 02:19:39 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2021-04-25 17:42:21 +0100
commitc4868ef156cd26531e8f65219b83a60f708e47d6 (patch)
tree7524c57146934082c89e6733904bebc671eb215c /x11-misc/entrance
parenteclass/linux-build: relax CONFIG_CMDLINE requirements (diff)
downloadportage-c4868ef156cd26531e8f65219b83a60f708e47d6.tar.xz
x11-misc/entrance: add user, fix config
Package-Manager: Portage-3.0.17, Repoman-3.0.2
Diffstat (limited to 'x11-misc/entrance')
-rw-r--r--x11-misc/entrance/entrance-3.0.0_alpha6.ebuild43
-rw-r--r--x11-misc/entrance/entrance-9999.ebuild43
2 files changed, 76 insertions, 10 deletions
diff --git a/x11-misc/entrance/entrance-3.0.0_alpha6.ebuild b/x11-misc/entrance/entrance-3.0.0_alpha6.ebuild
index 4320488a..af7026d4 100644
--- a/x11-misc/entrance/entrance-3.0.0_alpha6.ebuild
+++ b/x11-misc/entrance/entrance-3.0.0_alpha6.ebuild
@@ -11,31 +11,64 @@ SRC_URI="https://github.com/Obsidian-StudiosInc/entrance/archive/v${PV}.tar.gz -
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="nls +pam systemd X"
+IUSE="nls +pam systemd xcb X"
-DEPEND=">=dev-libs/efl-1.19.0[X?,systemd?]
+DEPEND=">=dev-libs/efl-1.19.0[systemd?,X?]
pam? ( sys-libs/pam )
systemd? ( sys-apps/systemd )
+ xcb? ( x11-libs/libxcb )
"
RDEPEND="${DEPEND}
X? (
- x11-base/xorg-server
x11-apps/sessreg
x11-apps/xauth
+ x11-base/xorg-server
)
- acct-user/nobody"
+ acct-user/entrance"
PATCHES=(
"${FILESDIR}/${PV}-f526bc6874a1c7cec167e569d60a21787a12a2fd.patch"
"${FILESDIR}/${PV}-2c02d1b1d5c7221059f81c5b6c89fe71f23640cc.patch"
)
+src_prepare() {
+ # LFS
+ sed -i \
+ -e '/lockfile/ s|string: .*|string: "/run/entrance.pid";|' \
+ -e '/xauth_file/ s|string: .*|string: "/run/entrance.auth";|' \
+ data/entrance.conf.in \
+ || die
+
+ # Default user
+ sed -i \
+ -e '/start_user/ s|string: .*|string: "entrance";|' \
+ data/entrance.conf.in \
+ || die
+
+ # Ensure first VT is used
+ sed -i \
+ -e '/vtnr/ s|ushort: .*|ushort: 1;|' \
+ data/entrance.conf.in \
+ || die
+
+ if use systemd ; then
+ sed -i \
+ -e '/reboot/ s|string: .*|string: "/usr/bin/systemctl reboot";|' \
+ -e '/shutdown/ s|string: .*|string: "/usr/bin/systemctl poweroff";|' \
+ -e '/suspend/ s|string: .*|string: "/usr/bin/systemctl suspend";|' \
+ data/entrance.conf.in \
+ || die
+ fi
+
+ default
+}
+
src_configure() {
local emesonargs=(
-Dconsolekit=false
- $(meson_use systemd logind)
$(meson_use nls)
$(meson_use pam)
+ $(meson_use systemd logind)
)
meson_src_configure
diff --git a/x11-misc/entrance/entrance-9999.ebuild b/x11-misc/entrance/entrance-9999.ebuild
index d378fbdb..2790b033 100644
--- a/x11-misc/entrance/entrance-9999.ebuild
+++ b/x11-misc/entrance/entrance-9999.ebuild
@@ -11,26 +11,59 @@ EGIT_REPO_URI="https://github.com/Obsidian-StudiosInc/entrance.git"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
-IUSE="nls +pam systemd X"
+IUSE="nls +pam systemd xcb X"
-DEPEND=">=dev-libs/efl-1.19.0[X?,systemd?]
+DEPEND=">=dev-libs/efl-1.19.0[systemd?,X?]
pam? ( sys-libs/pam )
systemd? ( sys-apps/systemd )
+ xcb? ( x11-libs/libxcb )
"
RDEPEND="${DEPEND}
X? (
- x11-base/xorg-server
x11-apps/sessreg
x11-apps/xauth
+ x11-base/xorg-server
)
- acct-user/nobody"
+ acct-user/entrance"
+
+src_prepare() {
+ # LFS
+ sed -i \
+ -e '/lockfile/ s|string: .*|string: "/run/entrance.pid";|' \
+ -e '/xauth_file/ s|string: .*|string: "/run/entrance.auth";|' \
+ data/entrance.conf.in \
+ || die
+
+ # Default user
+ sed -i \
+ -e '/start_user/ s|string: .*|string: "entrance";|' \
+ data/entrance.conf.in \
+ || die
+
+ # Ensure first VT is used
+ sed -i \
+ -e '/vtnr/ s|ushort: .*|ushort: 1;|' \
+ data/entrance.conf.in \
+ || die
+
+ if use systemd ; then
+ sed -i \
+ -e '/reboot/ s|string: .*|string: "/usr/bin/systemctl reboot";|' \
+ -e '/shutdown/ s|string: .*|string: "/usr/bin/systemctl poweroff";|' \
+ -e '/suspend/ s|string: .*|string: "/usr/bin/systemctl suspend";|' \
+ data/entrance.conf.in \
+ || die
+ fi
+
+ default
+}
src_configure() {
local emesonargs=(
-Dconsolekit=false
- $(meson_use systemd logind)
$(meson_use nls)
$(meson_use pam)
+ $(meson_use systemd logind)
)
meson_src_configure