summaryrefslogtreecommitdiff
path: root/x11-libs/xcb-util
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2005-07-30 21:48:23 +0000
committerBertrand Jacquin <beber@meleeweb.net>2005-07-30 21:48:23 +0000
commit8ba9011dae5fb85e1e53bb6adb122a5615fb32e3 (patch)
tree9923c0730cd78b86ec8c924d3cd55f25e147649e /x11-libs/xcb-util
parentDel old ebuilds (diff)
downloadportage-8ba9011dae5fb85e1e53bb6adb122a5615fb32e3.tar.xz
move gentoofr overlay to ..
Diffstat (limited to 'x11-libs/xcb-util')
-rw-r--r--x11-libs/xcb-util/Manifest2
-rw-r--r--x11-libs/xcb-util/files/digest-xcb-util-99990
-rw-r--r--x11-libs/xcb-util/xcb-util-9999.ebuild63
3 files changed, 65 insertions, 0 deletions
diff --git a/x11-libs/xcb-util/Manifest b/x11-libs/xcb-util/Manifest
new file mode 100644
index 00000000..308cda1a
--- /dev/null
+++ b/x11-libs/xcb-util/Manifest
@@ -0,0 +1,2 @@
+MD5 bbde456f8d6c5aed5b106ec9edbda322 xcb-util-9999.ebuild 1684
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-xcb-util-9999 0
diff --git a/x11-libs/xcb-util/files/digest-xcb-util-9999 b/x11-libs/xcb-util/files/digest-xcb-util-9999
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/x11-libs/xcb-util/files/digest-xcb-util-9999
diff --git a/x11-libs/xcb-util/xcb-util-9999.ebuild b/x11-libs/xcb-util/xcb-util-9999.ebuild
new file mode 100644
index 00000000..e120c90c
--- /dev/null
+++ b/x11-libs/xcb-util/xcb-util-9999.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit cvs
+
+ECVS_SERVER="cvs.freedesktop.org:/cvs/xcb"
+ECVS_MODULE="${PN}"
+
+DESCRIPTION="XCB-util"
+HOMEPAGE="http://freedesktop.org/Software/xcb"
+
+LICENSE="AS-IS"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-util/gperf
+ x11-libs/xcb"
+RDEPEND=""
+
+S=${WORKDIR}/${PN}
+
+src_compile()
+{
+ ./autogen.sh || die "autogen.sh failed"
+ econf || die "econf failed"
+
+ # emake failed because of atom which is broken so made one per one
+ # Resolved with DEPEND gperf (Thanks to caro)
+
+ # Must be done before all (need by icccm)
+ #emake -C atom xcb_atom.h || die "emake -C atom xcb_atom.h failed"
+ #emake -C atom xcb-atom.pc || die "emake -C atom xcb-atom.pc failed"
+
+ #emake -C icccm || die "emake -C icccm failed"
+ #emake -C event || die "emake -C event failed"
+ #emake -C property || die "emake -C property failed"
+ #emake -C image || die "emake -C image failed"
+
+ emake || die "emake failed"
+}
+
+src_install()
+{
+ einstall || die "einstall failed"
+
+ #einstall -C icccm || die "einstall -C icccm failed"
+ #einstall -C event || die "einstall -C event failed"
+ #einstall -C property || die "einstall -C property failed"
+ #einstall -C image || die "einstall -C image failed"
+
+ # Need FEATURES="-sandbox" or a patch (didn't find the way to avoid ACCESS
+ # VIOLATION)
+ # Now ok
+ ##emake -C atom install-pkgconfigDATA || die "emake -C atom install-pkgconfigDATA failed"
+ ##emake -C atom install-xcbincludeHEADERS || die "emake -C atom install-xcbincludeHEADERS failed"
+
+ #insinto /usr/include/X11/XCB/
+ #doins ${S}/atom/xcb_atom.h
+
+ #insinto /usr/lib/pkgconfig
+ #doins ${S}/atom/xcb-atom.pc
+}