summaryrefslogtreecommitdiff
path: root/www-servers
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2019-05-14 00:15:43 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2019-05-20 18:43:52 +0100
commit9cc85b87e7b2dfa9b5bff1884fe5e485c8439e5d (patch)
tree729f44b2ea91c9a60efc9676e1dcc845da5a2a50 /www-servers
parentprofiles/common: drop distfiles after install (diff)
downloadportage-9cc85b87e7b2dfa9b5bff1884fe5e485c8439e5d.tar.xz
www-servers: fix variable assignment
Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/httpterm/httpterm-1.7.2.ebuild14
-rw-r--r--www-servers/httpterm/httpterm-9999.ebuild14
2 files changed, 16 insertions, 12 deletions
diff --git a/www-servers/httpterm/httpterm-1.7.2.ebuild b/www-servers/httpterm/httpterm-1.7.2.ebuild
index 846dca20..ce7988a7 100644
--- a/www-servers/httpterm/httpterm-1.7.2.ebuild
+++ b/www-servers/httpterm/httpterm-1.7.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -17,18 +17,20 @@ DEPEND=""
RDEPEND="${DEPEND}"
src_compile() {
- # This is for recent Linux 2.6 with splice and accept4()
- local args="TARGET=linux26s"
+ local -a args=(
+ # This is for recent Linux 2.6 with splice and accept4()
+ "TARGET=linux26s"
- # Disable debug
- local args="DEBUG="
+ # Disable debug
+ "DEBUG="
+ )
emake "${PN}" \
CC="$(tc-getCC)" \
LD="$(tc-getCC)" \
CPU_OPTS="${CFLAGS}" \
LDFLAGS="${LDFLAGS}" \
- ${args}
+ "${args[@]}"
}
src_install() {
diff --git a/www-servers/httpterm/httpterm-9999.ebuild b/www-servers/httpterm/httpterm-9999.ebuild
index 7ebd9828..40bc1792 100644
--- a/www-servers/httpterm/httpterm-9999.ebuild
+++ b/www-servers/httpterm/httpterm-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -23,18 +23,20 @@ src_prepare() {
}
src_compile() {
- # This is for recent Linux 2.6 with splice and accept4()
- local args="TARGET=linux26s"
+ local -a args=(
+ # This is for recent Linux 2.6 with splice and accept4()
+ "TARGET=linux26s"
- # Disable debug
- local args="DEBUG="
+ # Disable debug
+ "DEBUG="
+ )
emake "${PN}" \
CC="$(tc-getCC)" \
LD="$(tc-getCC)" \
CPU_OPTS="${CFLAGS}" \
LDFLAGS="${LDFLAGS}" \
- ${args}
+ "${args[@]}"
}
src_install() {