summaryrefslogtreecommitdiff
path: root/www-client
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2020-09-26 17:41:19 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2020-10-18 01:19:03 +0100
commitb3354b3d78bad94e2798816a82fa2a2ee7b4925d (patch)
tree864f0840e72557cc26877f4350a1694776671ee4 /www-client
parentapp-antivirus/clamd-stream-client: move to EAPI 7 (diff)
downloadportage-b3354b3d78bad94e2798816a82fa2a2ee7b4925d.tar.xz
www-client/inject: move to EAPI 7
Package-Manager: Portage-3.0.4, Repoman-3.0.1
Diffstat (limited to 'www-client')
-rw-r--r--www-client/inject/inject-36.ebuild17
-rw-r--r--www-client/inject/inject-9999.ebuild15
2 files changed, 11 insertions, 21 deletions
diff --git a/www-client/inject/inject-36.ebuild b/www-client/inject/inject-36.ebuild
index d8237e56..fe3043ce 100644
--- a/www-client/inject/inject-36.ebuild
+++ b/www-client/inject/inject-36.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit eutils toolchain-funcs
DESCRIPTION="Simple HTTP injector"
@@ -13,17 +13,12 @@ SLOT="0"
KEYWORDS="amd64 ~arm ~x86"
IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}"
-
S="${WORKDIR}/${PN}${PV}"
-src_prepare() {
- default
-
- eapply "${FILESDIR}/${PV}-BUILD-INT_MAX-requires-limits.h.patch"
- eapply "${FILESDIR}/${PV}-MEDIUM-Remove-hardcoded-march-i686-and-mpreferred-st.patch"
-}
+PATCHES=(
+ "${FILESDIR}/${PV}-BUILD-INT_MAX-requires-limits.h.patch"
+ "${FILESDIR}/${PV}-MEDIUM-Remove-hardcoded-march-i686-and-mpreferred-st.patch"
+)
src_compile() {
emake "${PN}" \
diff --git a/www-client/inject/inject-9999.ebuild b/www-client/inject/inject-9999.ebuild
index 776a5536..46a0e139 100644
--- a/www-client/inject/inject-9999.ebuild
+++ b/www-client/inject/inject-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit eutils toolchain-funcs git-r3
DESCRIPTION="Simple HTTP injector"
@@ -13,14 +13,9 @@ SLOT="0"
KEYWORDS=""
IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- default
-
- eapply "${FILESDIR}/${PV}-MEDIUM-Remove-hardcoded-march-i686-and-mpreferred-st.patch"
-}
+PATCHES=(
+ "${FILESDIR}/${PV}-MEDIUM-Remove-hardcoded-march-i686-and-mpreferred-st.patch"
+)
src_compile() {
emake "${PN}" \