summaryrefslogtreecommitdiff
path: root/www-client
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2015-08-15 21:29:16 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2015-08-18 21:48:40 +0100
commitb2b77f726afd75fad06b61448fa4b36af5cd3508 (patch)
tree39c375969038faee9e41860eab45a1332017d042 /www-client
parentdev-php/libphutil: Version bump (diff)
downloadportage-b2b77f726afd75fad06b61448fa4b36af5cd3508.tar.xz
www-client/arcanist: Version bump
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'www-client')
-rw-r--r--www-client/arcanist/ChangeLog6
-rw-r--r--www-client/arcanist/Manifest3
-rw-r--r--www-client/arcanist/arcanist-20150815.ebuild141
3 files changed, 149 insertions, 1 deletions
diff --git a/www-client/arcanist/ChangeLog b/www-client/arcanist/ChangeLog
index d6cfbc61..8857bbf9 100644
--- a/www-client/arcanist/ChangeLog
+++ b/www-client/arcanist/ChangeLog
@@ -1,3 +1,9 @@
+*arcanist-20150815 (15 Aug 2015)
+
+ 15 Aug 2015; Bertrand Jacquin <bertrand@jacquin.bzh>
+ +arcanist-20150815.ebuild:
+ www-client/arcanist: Version bump
+
*arcanist-20150724 (08 Aug 2015)
08 Aug 2015; Bertrand Jacquin <bertrand@jacquin.bzh>
diff --git a/www-client/arcanist/Manifest b/www-client/arcanist/Manifest
index 0c65f837..fca4cb77 100644
--- a/www-client/arcanist/Manifest
+++ b/www-client/arcanist/Manifest
@@ -1,5 +1,6 @@
EBUILD arcanist-20150414.ebuild 3831 SHA256 ed19f949968280f161059fbfbb3fec716060d08ca8825b832fb92f1add3f5c6a WHIRLPOOL 41827b62a7948d7dcbaa7e22533c9a62d498ab93746b168aa78c88a11675b747105335f6fcac1746bc4fafc5559b4ea97428989ee7bd73f3c49ae2ad5e2aeba2
EBUILD arcanist-20150724.ebuild 3777 SHA256 443b8e5697d4becd237466d0a2b70a03ea2c31cb1e803db86c39ec968fdb8757 WHIRLPOOL 308b88c24b0ca0c19e1aba9fc9254ee4deb6dffa85528627669862546ad08380172ab7985fb950f3ae19b927c27982a6e4b14302d4337c7892311c63c3d946ab
+EBUILD arcanist-20150815.ebuild 3777 SHA256 06394c85583d115f7fc4153b389884d2c00c6abc8e28c2d1edad472fb538f0fd WHIRLPOOL fcfb0602c3498d3c832676fbfe049aa7982ac5a10da58f3941b11ddcec2c70a57d9409d500cc2958e6f032fc518af0344da729bb3e1f17930479e467e343be10
EBUILD arcanist-9999.ebuild 3659 SHA256 a17d930ce6b176e127b04394d6a9b8cd0d302f27fe0284880b411f367edae2b4 WHIRLPOOL aab3132eba8a31e36bbc5ccbd6718de403becdd83bac205eb83bd9fcd0e072e3343297902f64841709c0f870b9d50a9f60a8480a471b4bdd919fe35d7c8ef90f
-MISC ChangeLog 2810 SHA256 2a899b2ddd51e7dcc24233c903cd2cebdd1ab1fc5d937f2f3d3a183f05d3aa6b WHIRLPOOL 8c206491999ad85d0bc7a12c6bfb5cbdad4b2dcf3f1a0aeeb13cd8ee910b372254a8710d1e2b01136bd425e87b556a8764a7266dc69c8ff78d5274bcd9db9975
+MISC ChangeLog 2965 SHA256 c3a2cb7c15787d8858d32bea8198aef28b30bd694c920d4fec6281e4542a7f5c WHIRLPOOL fcfc688863deb37d47ffc03b608d3600ee013547189c28d073013606aeb200c62a30017e55927d1aa2543740fa263071cd19e70c99d29efdd02534de365af7fc
MISC metadata.xml 452 SHA256 2e925bb81450c955ffb47c6af0cfccff61d103c2622101ee5fc225eac0407d59 WHIRLPOOL 757211efd5b90e2c231b585b3b06e5399fa5407bddcf80cd457796a09239c88a48313a5d75ea98ad538ed3aa73bfa080676570f42ea92817c2a4183526006045
diff --git a/www-client/arcanist/arcanist-20150815.ebuild b/www-client/arcanist/arcanist-20150815.ebuild
new file mode 100644
index 00000000..3c5bbc59
--- /dev/null
+++ b/www-client/arcanist/arcanist-20150815.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="ncurses"
+
+inherit bash-completion-r1 python-single-r1 git-r3
+
+DESCRIPTION="Command-line tool for Phabricator"
+HOMEPAGE="http://www.phabricator.org"
+EGIT_REPO_URI="git://github.com/phacility/arcanist.git"
+EGIT_BRANCH="stable"
+EGIT_COMMIT="25be30ae3b47db8d180f772f0d7bff3c11939806"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="git lint mercurial subversion ssl test abi_x86_x32"
+REQUIRED_USE="test? ( lint )"
+
+DEPEND="virtual/awk:0
+ test? (
+ >=dev-lang/php-5.2.3[xmlwriter]
+ =dev-php/libphutil-20150815:0[test]
+ )"
+RDEPEND=">=dev-lang/php-5.2.3[cli,curl,json,ssl?]
+ =dev-php/libphutil-20150815:0[ssl?]
+ git? ( dev-vcs/git:0 )
+ mercurial? ( dev-vcs/mercurial:0 )
+ subversion? ( dev-vcs/subversion:0 )
+ lint? (
+ app-admin/puppet-lint:0
+ dev-haskell/hlint:0
+ dev-php/PEAR-PHP_CodeSniffer:0
+ dev-python/pylint:0[${PYTHON_USEDEP}]
+ dev-python/flake8:0[${PYTHON_USEDEP}]
+ dev-util/cppcheck:0
+ dev-util/cpplint:0
+ !abi_x86_x32? ( net-libs/nodejs:0[npm] )
+ )"
+
+src_test() {
+ einfo "Note that you need to install some Node JS script manually:"
+ einfo " npm install -g coffeelint"
+ einfo " npm install -g csslint"
+ einfo " npm install -g jscs"
+ einfo " npm install -g jshint"
+ einfo " npm install -g jsonlint"
+ einfo " npm install -g less"
+
+ local GIT_NAME="${FUNCNAME} for ${CATEGORY}/${PF}"
+ local GIT_EMAIL="portage@localhost"
+
+ export GIT_AUTHOR_NAME="${GIT_NAME}"
+ export GIT_AUTHOR_EMAIL="${GIT_EMAIL}"
+
+ export GIT_COMMITTER_NAME="${GIT_NAME}"
+ export GIT_COMMITTER_EMAIL="${GIT_EMAIL}"
+
+ # Unable to locate binary "golint" to run linter ArcanistGoLintLinter. You may need to install the binary, or adjust your linter configuration.
+ # TO INSTALL: Install Golint using `go get github.com/golang/lint/golint`.
+
+ # Set config in .git/arc/config for ArcanistPyLintLinter
+ bin/arc set-config --local lint.pylint.codes.advice '^(C|R).*' > /dev/null
+ bin/arc set-config --local lint.pylint.codes.error '^(E|F).*' > /dev/null
+ bin/arc set-config --local lint.pylint.codes.warning '^W.*' > /dev/null
+
+ # + https://secure.phabricator.com/T7170
+
+ bin/arc unit --everything --no-coverage || die "arc unit failed"
+}
+
+src_prepare() {
+ echo "${EGIT_VERSION}" > "${S}/VERSION"
+
+ find "${S}" -type f -name .gitignore -print0 \
+ | xargs -0 --no-run-if-empty -- \
+ rm
+
+ rm bin/*.bat
+
+ # Replace 'env' shebang to files it point to
+ find "${S}" -type f \
+ | sort \
+ | xargs -n 1 --no-run-if-empty -- \
+ awk 'NR == 1 && /^#!\/usr\/bin\/env/ {print FILENAME}' \
+ | while read ; do
+ set -- $(sed -ne '1 s:^#!\([^ ]*\) ::p;q' ${REPLY})
+ cmd="$1" ; shift ; args="$@"
+
+ case "${cmd}" in
+ bash|php) ;;
+ *) continue ;;
+ esac
+
+ path="$(type -p ${cmd})" || continue
+ [[ -z "${path}" ]] && continue
+
+ einfo "Replace ${REPLY/#${S}\/} shebang to #!${path} ${args}"
+ sed -i \
+ -e "1 s:^#!.*:#!${path} ${args}:" \
+ "${REPLY}"
+ eend $?
+ done
+}
+
+src_install() {
+ newbashcomp resources/shell/bash-completion "arc"
+
+ insinto "/usr/share/${PN}"
+ doins VERSION
+
+ insinto "/usr/share/php/${PN}"
+ doins -r bin externals resources scripts src
+
+ python_scriptinto "/usr/share/php/${PN}/scripts"
+ python_doscript scripts/breakout.py
+
+ # Make executable all shebanged files
+ find "${ED}" -type f \
+ | xargs -n 1 --no-run-if-empty -- \
+ awk 'NR == 1 && /^#!/ {print FILENAME}' \
+ | sed -e "s:${ED}:/:" \
+ | xargs --no-run-if-empty -- \
+ fperms 755
+
+ dosym "/usr/share/php/${PN}/bin/arc" /usr/bin/arc
+
+ dodoc NOTICE README.md
+}
+
+pkg_postinst() {
+ if use lint; then
+ elog
+ elog "Some linter need external NodeJS script. To install them, use:"
+ elog " npm install -g csslint"
+ fi
+}