summaryrefslogtreecommitdiff
path: root/www-client
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2005-07-30 21:48:23 +0000
committerBertrand Jacquin <beber@meleeweb.net>2005-07-30 21:48:23 +0000
commit8ba9011dae5fb85e1e53bb6adb122a5615fb32e3 (patch)
tree9923c0730cd78b86ec8c924d3cd55f25e147649e /www-client
parentDel old ebuilds (diff)
downloadportage-8ba9011dae5fb85e1e53bb6adb122a5615fb32e3.tar.xz
move gentoofr overlay to ..
Diffstat (limited to 'www-client')
-rw-r--r--www-client/amaya/Manifest2
-rw-r--r--www-client/amaya/amaya-9.2.1.ebuild54
-rw-r--r--www-client/amaya/files/digest-amaya-9.2.11
3 files changed, 57 insertions, 0 deletions
diff --git a/www-client/amaya/Manifest b/www-client/amaya/Manifest
new file mode 100644
index 00000000..58b3355c
--- /dev/null
+++ b/www-client/amaya/Manifest
@@ -0,0 +1,2 @@
+MD5 c8fb77cb976545dfefdb812c0d52500d amaya-9.2.1.ebuild 1131
+MD5 e508278e7fa6d3648f169666fcbc6585 files/digest-amaya-9.2.1 70
diff --git a/www-client/amaya/amaya-9.2.1.ebuild b/www-client/amaya/amaya-9.2.1.ebuild
new file mode 100644
index 00000000..1aaa352a
--- /dev/null
+++ b/www-client/amaya/amaya-9.2.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/amaya/amaya-9.1.ebuild,v 1.3 2005/06/02 10:43:24 platinumviper Exp $
+
+inherit libtool
+
+S=${WORKDIR}/Amaya/LINUX-ELF
+
+DESCRIPTION="The W3C Web-Editor/Browser"
+SRC_URI="http://www.w3.org/Amaya/Distribution/${PN}-fullsrc-${PV}.tgz"
+HOMEPAGE="http://www.w3.org/Amaya/"
+
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="gl debug"
+
+RDEPEND="!media-libs/raptor
+ virtual/opengl
+ virtual/x11
+ media-libs/imlib
+ >=x11-libs/gtk+-2.0
+ gl? ( >=media-libs/freetype-2 )"
+
+DEPEND="dev-lang/perl
+ dev-libs/openssl
+ ${RDEPEND}"
+
+RESTRICT="nomirror"
+
+src_compile() {
+ local myconf=""
+ mkdir ${S}
+ cd ${S}
+ if use gl ;then
+ myconf="${myconf} --with-gl --without-mesa"
+ else
+ myconf="${myconf} --without-gl --with-mesa"
+ fi
+ if use debug ;then
+ myconf="${myconf} --with-debug --with-wxdebug"
+ fi
+ myconf="${myconf} --with-wx --enable-bookmarks"
+ ../configure \
+ ${myconf} \
+ --prefix=/usr \
+ --host=${CHOST}
+ make || die
+}
+
+src_install () {
+ dodir /usr
+ make prefix=${D}/usr install || die
+}
diff --git a/www-client/amaya/files/digest-amaya-9.2.1 b/www-client/amaya/files/digest-amaya-9.2.1
new file mode 100644
index 00000000..b39c10e5
--- /dev/null
+++ b/www-client/amaya/files/digest-amaya-9.2.1
@@ -0,0 +1 @@
+MD5 7941bbbae65619f16b41f431210b7e39 amaya-fullsrc-9.2.1.tgz 23112083