summaryrefslogtreecommitdiff
path: root/www-client
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2013-09-02 18:57:57 +0200
committerBertrand Jacquin <beber@meleeweb.net>2013-09-02 19:11:05 +0200
commit6f7a8a69038876bb52db95ec91bc9e875e4b66ac (patch)
tree71c0e9f4be87009b1a911b994de09f810141a557 /www-client
parentdev-util/cpplint: Checker to make sure a C++ file follows Google's C++ (diff)
downloadportage-6f7a8a69038876bb52db95ec91bc9e875e4b66ac.tar.xz
www-client/arcanist: Implement FEATURES=test
Package-Manager: portage-2.2.1
Diffstat (limited to 'www-client')
-rw-r--r--www-client/arcanist/ChangeLog3
-rw-r--r--www-client/arcanist/Manifest4
-rw-r--r--www-client/arcanist/arcanist-9999.ebuild43
3 files changed, 30 insertions, 20 deletions
diff --git a/www-client/arcanist/ChangeLog b/www-client/arcanist/ChangeLog
index 7c25a5e4..6cd21f11 100644
--- a/www-client/arcanist/ChangeLog
+++ b/www-client/arcanist/ChangeLog
@@ -1,3 +1,6 @@
+ 02 Sep 2013; Bertrand Jacquin <beber@meleeweb.net> arcanist-9999.ebuild:
+ www-client/arcanist: Implement FEATURES=test
+
22 Aug 2013; Bertrand Jacquin <beber@meleeweb.net> arcanist-9999.ebuild:
www-client/arcanist: Add missing DEPEND on awk for build
diff --git a/www-client/arcanist/Manifest b/www-client/arcanist/Manifest
index 87bfc295..2a2f4913 100644
--- a/www-client/arcanist/Manifest
+++ b/www-client/arcanist/Manifest
@@ -1,3 +1,3 @@
-EBUILD arcanist-9999.ebuild 2093 SHA256 d5a0013e3b497b14f96517ee8c44db758c19610b89a77642323610ba61dbd536 WHIRLPOOL 2ab57e6c608bb436eebfe64a0984471c6e833286fd62d5b2644cba8b5291d90e51cb837a4d1cf48737c9a11bac96d4b2632333b0ef17cda9a8840f3c82d3e06a
-MISC ChangeLog 1197 SHA256 8f6a9540620a62da39516735c5d95a6455d6cf10b25de5790de090c4b82fd4c8 WHIRLPOOL f616bd38e31ed428f2840b2bea946747153f2969b069075960c90150eed0b90300a1dce2d9d63e7fe5181c78a2d811f08bf9ec566c49425a20ef91e96cdd9049
+EBUILD arcanist-9999.ebuild 2270 SHA256 f979ed329e999c7ce711da8f13aef077a50b9368be10f66c0c46328af07e3c6c WHIRLPOOL d94b9354549f81ffc2dc3d20427df25e48d12b1b3758ff91030999cc40087aceabbe57b72f94ef2392deb9d7f4f5af2bb8399ead9d0f187f1f35fb8d15a12500
+MISC ChangeLog 1320 SHA256 575a62d57e91f4dd04eb2d49eb09f262b2c0c5d4f912ca6140611f192bc50b14 WHIRLPOOL 9d8f7cbf9aa3b43780f76793ada6f942c695723dde49d3a3fe10d2a40299040a4de0903dc579c7f46fd02cf41832890cfa75f428b6aaf8245b515299832d9401
MISC metadata.xml 376 SHA256 214868e07f83e61d21087c9867be82c69039947d2f6e29d5d0facf23e7690a4d WHIRLPOOL 34de8852dfdb73e442aba0c8b52cb6bc7877ca7d9b922245d25861935d69882cebeb9a3220dadd2b0f8548f6b16d10bb2c95017eda5d5f7b96cc6af7eadb484d
diff --git a/www-client/arcanist/arcanist-9999.ebuild b/www-client/arcanist/arcanist-9999.ebuild
index 6b953bc3..c08c6147 100644
--- a/www-client/arcanist/arcanist-9999.ebuild
+++ b/www-client/arcanist/arcanist-9999.ebuild
@@ -16,35 +16,45 @@ EGIT_REPO_URI="git://github.com/facebook/arcanist.git"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS=""
-IUSE="css git javascript mercurial php python subversion ssl"
-
-DEPEND="virtual/awk:0"
+IUSE="css git javascript mercurial php python ruby subversion ssl test"
+REQUIRED_USE="test? ( css git javascript php python ruby )"
+
+DEPEND="virtual/awk:0
+ test? (
+ >=dev-lang/php-5.2.3[xmlwriter]
+ =dev-php/libphutil-${PV}:0[test]
+ dev-util/cpplint:0
+ )"
RDEPEND=">=dev-lang/php-5.2.3[cli,curl,json,ssl?]
=dev-php/libphutil-${PV}:0[ssl?]
- dev-python/configparser:0[${PYTHON_USEDEP}]
git? ( dev-vcs/git:0 )
mercurial? ( dev-vcs/mercurial:0 )
subversion? ( dev-vcs/subversion:0 )
css? ( net-libs/nodejs:0[npm] )
javascript? ( net-libs/nodejs:0[npm] )
php? ( dev-php/PEAR-PHP_CodeSniffer:0 )
- python? ( dev-python/pylint:0 )"
+ python? (
+ dev-python/pylint:0[${PYTHON_USEDEP}]
+ dev-python/flake8:0[${PYTHON_USEDEP}]
+ )
+ ruby? ( dev-lang/ruby )"
+
+src_test() {
+ # TODO s/ewarn/die until https://github.com/facebook/arcanist/issues/99
+ bin/arc unit --everything --no-coverage || ewarn "arc unit failed"
+}
src_install() {
- newbashcomp resources/shell/bash-completion "${PN}"
-
- if ! use mercurial ; then
- rm -r scripts/hgdaemon src/hgdaemon
- fi
+ # Provided by dev-python/pep8
+ rm -r externals/pep8
rm bin/*.bat
rm scripts/*.txt
- insinto "/usr/share/php/${PN}"
- doins -r bin externals scripts src
+ newbashcomp resources/shell/bash-completion "${PN}"
- python_scriptinto "/usr/share/php/${PN}/externals/pep8"
- python_doscript externals/pep8/pep8.py
+ insinto "/usr/share/php/${PN}"
+ doins -r bin scripts src
python_scriptinto "/usr/share/php/${PN}/scripts"
python_doscript scripts/breakout.py
@@ -65,10 +75,7 @@ src_install() {
pkg_postinst () {
elog
elog "Linter for different languages are available thrue USE flags"
- elog " css USE=css"
- elog " js USE=javascript"
- elog " php USE=php"
- elog " python USE=python"
+ elog " css javascript php python ruby"
if use css ; then
elog