summaryrefslogtreecommitdiff
path: root/www-client
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2016-02-14 00:03:29 +0000
committerBertrand Jacquin <bertrand@jacquin.bzh>2016-02-14 00:35:46 +0000
commit5ccc96568ba3c9a341367b5126185063e094fd3d (patch)
tree7008671f4957cc3cc4a733ff6e6256497928197f /www-client
parentdev-php/libphutil: Version bump (diff)
downloadportage-5ccc96568ba3c9a341367b5126185063e094fd3d.tar.xz
www-client/arcanist: Version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'www-client')
-rw-r--r--www-client/arcanist/Manifest3
-rw-r--r--www-client/arcanist/arcanist-20160212.ebuild141
-rw-r--r--www-client/arcanist/arcanist-9999.ebuild4
3 files changed, 145 insertions, 3 deletions
diff --git a/www-client/arcanist/Manifest b/www-client/arcanist/Manifest
index a0f27289..a7fdfc39 100644
--- a/www-client/arcanist/Manifest
+++ b/www-client/arcanist/Manifest
@@ -3,5 +3,6 @@ EBUILD arcanist-20150724.ebuild 3771 SHA256 8937b161d65f574c7c6824e9315a64a39456
EBUILD arcanist-20150815.ebuild 3771 SHA256 39a44fe09a70b887642726416fd5ae14569307d6e38e75d2b4ac9f64b230044e WHIRLPOOL db968e34868bb10a7fdc026eaa31f1fc4913fadb58e24e8c053977f8550ceaaf256255a3ae957a0ba425a294cb57df1f888658b87b10afc54947a347aabd3fcd
EBUILD arcanist-20151003.ebuild 3771 SHA256 ee9c1d7cd56ab3fc23f7107f28351817bd468e59e57463c0029a900202b2cea7 WHIRLPOOL ec0d262abecc16398a928e15e35ec1b40b8f4c02fc93632d43a8d7909ab0412e9915dcfb155047cd45d22353ed16a6b04b61b28b5242b939f14448a29e4fefd7
EBUILD arcanist-20151024.ebuild 3771 SHA256 7b882937ddac91f8eea867a9f72e844bdb0785f6bff73fcbb2cd3405d0249e05 WHIRLPOOL b23c2909d2ac1c89f59c9ca4b9c1b7f38834e30396245786e5304f87ac113f1371d5c1077176b19494f81354010f51189c6bdd7ac58f1fa4020fbcee59136c17
-EBUILD arcanist-9999.ebuild 3653 SHA256 13cf626d43c03f547a1d5ae6bc7e899687389641f1402ccd53a358e19362339d WHIRLPOOL e7a341e928800f9379b7eb7eb3e59fa635adccf46da9c26120e3652f3f82b050cccdbe6d6f8da96fc27d5fa04185f55ae621b1cb3de2c9c75dc4e917b3b4851c
+EBUILD arcanist-20160212.ebuild 3795 SHA256 4621d8a9da5fd3809203218b2f0876add2f14a2f8442df37c5758bd86e711728 WHIRLPOOL f2c3e79d5790eb483fce329037cb9bfe83b4e98f38469781ef39a9777fa5d935c58024015c61100ce893de09685ae4e2949a382b229a8a5d4c9641acd0c23720
+EBUILD arcanist-9999.ebuild 3677 SHA256 6a73ee3683e7a90c8e027445730c0afa562cc6d06e8baa2d8f02874e64139fb3 WHIRLPOOL 99c92f647ccc4de6ece4fc8167f74aaf575515572d1ec8c75da2357993017613de4e5fb850deb8f0b53b25fc39e94d0d3a2a66fe940af04df48ec6ac53b80ef4
MISC metadata.xml 452 SHA256 2e925bb81450c955ffb47c6af0cfccff61d103c2622101ee5fc225eac0407d59 WHIRLPOOL 757211efd5b90e2c231b585b3b06e5399fa5407bddcf80cd457796a09239c88a48313a5d75ea98ad538ed3aa73bfa080676570f42ea92817c2a4183526006045
diff --git a/www-client/arcanist/arcanist-20160212.ebuild b/www-client/arcanist/arcanist-20160212.ebuild
new file mode 100644
index 00000000..1caa35cd
--- /dev/null
+++ b/www-client/arcanist/arcanist-20160212.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="ncurses"
+
+inherit bash-completion-r1 python-single-r1 git-r3
+
+DESCRIPTION="Command-line tool for Phabricator"
+HOMEPAGE="http://www.phabricator.org"
+EGIT_REPO_URI="git://github.com/phacility/arcanist.git"
+EGIT_BRANCH="stable"
+EGIT_COMMIT="ed476cf8489c4bf41b7a0075f15d40820d640fe4"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="git lint mercurial subversion ssl test abi_x86_x32"
+REQUIRED_USE="test? ( lint )"
+
+DEPEND="virtual/awk:0
+ test? (
+ >=dev-lang/php-5.2.3[xmlwriter]
+ =dev-php/libphutil-20160123:0[test]
+ )"
+RDEPEND=">=dev-lang/php-5.2.3[cli,curl,json,ssl?]
+ =dev-php/libphutil-20160123:0[ssl?]
+ git? ( dev-vcs/git:0 )
+ mercurial? ( dev-vcs/mercurial:0 )
+ subversion? ( dev-vcs/subversion:0 )
+ lint? (
+ app-admin/puppet-lint:0
+ dev-haskell/hlint:0
+ dev-php/PEAR-PHP_CodeSniffer:0
+ dev-python/pylint:0[${PYTHON_USEDEP}]
+ dev-python/flake8:0[${PYTHON_USEDEP}]
+ dev-util/cppcheck:0
+ dev-util/cpplint:0
+ !abi_x86_x32? ( net-libs/nodejs:0[npm] )
+ )"
+
+src_test() {
+ einfo "Note that you need to install some Node JS script manually:"
+ einfo " npm install -g coffeelint"
+ einfo " npm install -g csslint"
+ einfo " npm install -g jscs"
+ einfo " npm install -g jshint"
+ einfo " npm install -g jsonlint"
+ einfo " npm install -g less"
+
+ local GIT_NAME="${FUNCNAME} for ${CATEGORY}/${PF}"
+ local GIT_EMAIL="portage@localhost"
+
+ export GIT_AUTHOR_NAME="${GIT_NAME}"
+ export GIT_AUTHOR_EMAIL="${GIT_EMAIL}"
+
+ export GIT_COMMITTER_NAME="${GIT_NAME}"
+ export GIT_COMMITTER_EMAIL="${GIT_EMAIL}"
+
+ # Unable to locate binary "golint" to run linter ArcanistGoLintLinter. You may need to install the binary, or adjust your linter configuration.
+ # TO INSTALL: Install Golint using `go get github.com/golang/lint/golint`.
+
+ # Set config in .git/arc/config for ArcanistPyLintLinter
+ bin/arc set-config --local lint.pylint.codes.advice '^(C|R).*' > /dev/null
+ bin/arc set-config --local lint.pylint.codes.error '^(E|F).*' > /dev/null
+ bin/arc set-config --local lint.pylint.codes.warning '^W.*' > /dev/null
+
+ # + https://secure.phabricator.com/T7170
+
+ bin/arc unit --everything --no-coverage || die "arc unit failed"
+}
+
+src_prepare() {
+ git log --format='%H %ct' -n 1 > "${S}/GIT_COMMIT_INFO"
+
+ find "${S}" -type f -name .gitignore -print0 \
+ | xargs -0 --no-run-if-empty -- \
+ rm
+
+ rm bin/*.bat
+
+ # Replace 'env' shebang to files it point to
+ find "${S}" -type f \
+ | sort \
+ | xargs -n 1 --no-run-if-empty -- \
+ awk 'NR == 1 && /^#!\/usr\/bin\/env/ {print FILENAME}' \
+ | while read ; do
+ set -- $(sed -ne '1 s:^#!\([^ ]*\) ::p;q' ${REPLY})
+ cmd="$1" ; shift ; args="$@"
+
+ case "${cmd}" in
+ bash|php) ;;
+ *) continue ;;
+ esac
+
+ path="$(type -p ${cmd})" || continue
+ [[ -z "${path}" ]] && continue
+
+ einfo "Replace ${REPLY/#${S}\/} shebang to #!${path} ${args}"
+ sed -i \
+ -e "1 s:^#!.*:#!${path} ${args}:" \
+ "${REPLY}"
+ eend $?
+ done
+}
+
+src_install() {
+ newbashcomp resources/shell/bash-completion "arc"
+
+ insinto "/usr/share/${PN}"
+ doins GIT_COMMIT_INFO
+
+ insinto "/usr/share/php/${PN}"
+ doins -r bin externals resources scripts src
+
+ python_scriptinto "/usr/share/php/${PN}/scripts"
+ python_doscript scripts/breakout.py
+
+ # Make executable all shebanged files
+ find "${ED}" -type f \
+ | xargs -n 1 --no-run-if-empty -- \
+ awk 'NR == 1 && /^#!/ {print FILENAME}' \
+ | sed -e "s:${ED}:/:" \
+ | xargs --no-run-if-empty -- \
+ fperms 755
+
+ dosym "/usr/share/php/${PN}/bin/arc" /usr/bin/arc
+
+ dodoc NOTICE README.md
+}
+
+pkg_postinst() {
+ if use lint; then
+ elog
+ elog "Some linter need external NodeJS script. To install them, use:"
+ elog " npm install -g csslint"
+ fi
+}
diff --git a/www-client/arcanist/arcanist-9999.ebuild b/www-client/arcanist/arcanist-9999.ebuild
index 7a7f2c92..5a65ed69 100644
--- a/www-client/arcanist/arcanist-9999.ebuild
+++ b/www-client/arcanist/arcanist-9999.ebuild
@@ -72,7 +72,7 @@ src_test() {
}
src_prepare() {
- echo "${EGIT_VERSION}" > "${S}/VERSION"
+ git log --format='%H %ct' -n 1 > "${S}/GIT_COMMIT_INFO"
find "${S}" -type f -name .gitignore -print0 \
| xargs -0 --no-run-if-empty -- \
@@ -109,7 +109,7 @@ src_install() {
newbashcomp resources/shell/bash-completion "arc"
insinto "/usr/share/${PN}"
- doins VERSION
+ doins GIT_COMMIT_INFO
insinto "/usr/share/php/${PN}"
doins -r bin externals resources scripts src