summaryrefslogtreecommitdiff
path: root/www-client
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2013-08-23 01:11:26 +0200
committerBertrand Jacquin <beber@meleeweb.net>2013-08-23 01:11:26 +0200
commit59979ee38361657a9970a609edd41f247f98d6c7 (patch)
treeca321ca08e882fcfccc19884ca670c8e8d803b58 /www-client
parentwww-client/arcanist: Add missing DEPEND slots (diff)
downloadportage-59979ee38361657a9970a609edd41f247f98d6c7.tar.xz
www-client/arcanist: Migrate to python-single-r1, Add some missing python DEPEND
Package-Manager: portage-2.2.1
Diffstat (limited to 'www-client')
-rw-r--r--www-client/arcanist/ChangeLog4
-rw-r--r--www-client/arcanist/Manifest4
-rw-r--r--www-client/arcanist/arcanist-9999.ebuild21
3 files changed, 18 insertions, 11 deletions
diff --git a/www-client/arcanist/ChangeLog b/www-client/arcanist/ChangeLog
index 930a23b7..d840fff6 100644
--- a/www-client/arcanist/ChangeLog
+++ b/www-client/arcanist/ChangeLog
@@ -1,4 +1,8 @@
22 Aug 2013; Bertrand Jacquin <beber@meleeweb.net> arcanist-9999.ebuild:
+ www-client/arcanist: Migrate to python-single-r1, Add some missing python
+ DEPEND
+
+ 22 Aug 2013; Bertrand Jacquin <beber@meleeweb.net> arcanist-9999.ebuild:
www-client/arcanist: Add missing DEPEND slots
22 Aug 2013; Bertrand Jacquin <beber@meleeweb.net> arcanist-9999.ebuild:
diff --git a/www-client/arcanist/Manifest b/www-client/arcanist/Manifest
index be888a8e..05116041 100644
--- a/www-client/arcanist/Manifest
+++ b/www-client/arcanist/Manifest
@@ -1,3 +1,3 @@
-EBUILD arcanist-9999.ebuild 1950 SHA256 c350dbbc217f43265ca70b51e9feecf9fdb9cebd7b4ce1599df1a215ac49f447 WHIRLPOOL 4166df440666a23032df5a4a55e60fc095dd93fcb843a01a9962d060b90ea45591b0cde942da6f5d31682c1136dcaf14c858e5453adcea60667849ec71055831
-MISC ChangeLog 901 SHA256 ce6d483d40b54023a9e3ba4fa2f150d8cd81c720976c9063465eb9418bdcffcc WHIRLPOOL 26360b5b90c9fca219cafedcf65ef78af264456b07d236b1003716ac2b471f2310431d95eb6e02ce6865df6eb12f74aa9bf9f76166e07f143c060c0fa1b9b8f0
+EBUILD arcanist-9999.ebuild 2070 SHA256 bc00ef291b83d80d83ae8779e20b2e88c6d1524e364203b257e4eb88f4fa0c4b WHIRLPOOL d338a6c2070ae7e86d54bd109ca7576d130dc3862471a247da4a6c3c41f35cc4f6579d9a4e6ca550181fca44453f04fb266555d3563adbebc4c550b8b98f241d
+MISC ChangeLog 1062 SHA256 2e6a428c308a034364bea2069e5ab35b6e846ce360f2b40e20ee28f26153cd68 WHIRLPOOL a121051dace7ea113b0d7296fa50be04cdf1ea52648e3a232c9ffc1c11eb5ee784f12af1590c2dc0fc52dfd78735b7bc62fdb422da80056fb5393eba13a35d14
MISC metadata.xml 376 SHA256 214868e07f83e61d21087c9867be82c69039947d2f6e29d5d0facf23e7690a4d WHIRLPOOL 34de8852dfdb73e442aba0c8b52cb6bc7877ca7d9b922245d25861935d69882cebeb9a3220dadd2b0f8548f6b16d10bb2c95017eda5d5f7b96cc6af7eadb484d
diff --git a/www-client/arcanist/arcanist-9999.ebuild b/www-client/arcanist/arcanist-9999.ebuild
index d3875ae8..83eaabfb 100644
--- a/www-client/arcanist/arcanist-9999.ebuild
+++ b/www-client/arcanist/arcanist-9999.ebuild
@@ -3,7 +3,11 @@
# $Header: $
EAPI=5
-inherit bash-completion-r1 git-2
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="ncurses"
+
+inherit bash-completion-r1 python-single-r1 git-2
DESCRIPTION="Command-line tool for Phabricator"
HOMEPAGE="http://www.phabricator.org"
@@ -16,6 +20,7 @@ IUSE="css git javascript mercurial php python subversion ssl"
RDEPEND=">=dev-lang/php-5.2.3[cli,curl,json,ssl?]
=dev-php/libphutil-${PV}:0[ssl?]
+ dev-python/configparser:0[${PYTHON_USEDEP}]
git? ( dev-vcs/git:0 )
mercurial? ( dev-vcs/mercurial:0 )
subversion? ( dev-vcs/subversion:0 )
@@ -27,7 +32,6 @@ RDEPEND=">=dev-lang/php-5.2.3[cli,curl,json,ssl?]
src_install() {
newbashcomp resources/shell/bash-completion "${PN}"
- rm -r resources/shell
if ! use mercurial ; then
rm -r scripts/hgdaemon src/hgdaemon
fi
@@ -38,6 +42,12 @@ src_install() {
insinto "/usr/share/php/${PN}"
doins -r bin externals scripts src
+ python_scriptinto "/usr/share/php/${PN}/externals/pep8"
+ python_doscript externals/pep8/pep8.py
+
+ python_scriptinto "/usr/share/php/${PN}/scripts"
+ python_doscript scripts/breakout.py
+
# Make executable all shebanged files
find "${ED}" -type f \
| xargs -n 1 --no-run-if-empty -- \
@@ -46,13 +56,6 @@ src_install() {
| xargs --no-run-if-empty -- \
fperms 755
- # Fix python shebang
- # Move to python-r1
- find "${ED}" -type f -name '*.py' \
- | xargs --no-run-if-empty -- \
- sed -i \
- -e '/^#!/ s/python$/python2/'
-
dosym "/usr/share/php/${PN}/bin/arc" /usr/bin/arc
dodoc NOTICE README