summaryrefslogtreecommitdiff
path: root/www-client
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2016-09-03 21:54:19 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2016-09-04 00:07:40 +0100
commit2774fadcf04dac5a707a51a7c732b124d2a1aeaa (patch)
tree18d42db3124e3fe53b95fedc453879efebbaf1f6 /www-client
parentwww-apps/phabricator-extensions-Sprint: Move to EAPI 6 (diff)
downloadportage-2774fadcf04dac5a707a51a7c732b124d2a1aeaa.tar.xz
www-client/arcanist: Move to EAPI 6
Package-Manager: portage-2.2.28
Diffstat (limited to 'www-client')
-rw-r--r--www-client/arcanist/Manifest4
-rw-r--r--www-client/arcanist/arcanist-20160701.ebuild14
-rw-r--r--www-client/arcanist/arcanist-9999.ebuild14
3 files changed, 18 insertions, 14 deletions
diff --git a/www-client/arcanist/Manifest b/www-client/arcanist/Manifest
index e1cf5e19..55f00fdc 100644
--- a/www-client/arcanist/Manifest
+++ b/www-client/arcanist/Manifest
@@ -1,3 +1,3 @@
-EBUILD arcanist-20160701.ebuild 3799 SHA256 e7e34716e79b1f642dc0f3b99e649745bb855d845dc36e632676a8e8262b9f6a WHIRLPOOL 5f053b092c8be45bb7cf126c128d9c7c16c65d2994b82d379905bc6aa3b01f7127ae88b0314a5e7aae68a2af86f7f794ad2a1af3435c58e470facae30ed51082
-EBUILD arcanist-9999.ebuild 3711 SHA256 7ca702d300f758224f85f6e3139d174b0d595963773c1d8539472eb6913576cb WHIRLPOOL 63ed10477e05fbbe1322c4da07725ee42161ecd15c209a6833e598d0d0e45b9efe4d0cf6c447b490b09f59893952830a7d2d6be499e00aafcd25b63af31f913b
+EBUILD arcanist-20160701.ebuild 3812 SHA256 824ac6987685ab3ad40176075a9fae5cf1e81bf1e269450b7598451bb26faa64 WHIRLPOOL e8a15d6c76e329dfc76c40979496324cabb9d92404246c66d895baa4fdd14777aff9062bb5abce83dcc9eb04da020298f0fddc6b06d64f6a3dafed459824dc46
+EBUILD arcanist-9999.ebuild 3724 SHA256 6c66d053b89496b860c0614d7d93bb04b7c98377d84266603c525a4420ad19a5 WHIRLPOOL 7943d84cd410304eefbbfedb027b81ff7f9e637116c7d2e330bcc8175b4e25dc6283c4b5fa2771dfebb45805a8affcd10efcc8d242f61c28c75c285aa9cd2754
MISC metadata.xml 452 SHA256 2e925bb81450c955ffb47c6af0cfccff61d103c2622101ee5fc225eac0407d59 WHIRLPOOL 757211efd5b90e2c231b585b3b06e5399fa5407bddcf80cd457796a09239c88a48313a5d75ea98ad538ed3aa73bfa080676570f42ea92817c2a4183526006045
diff --git a/www-client/arcanist/arcanist-20160701.ebuild b/www-client/arcanist/arcanist-20160701.ebuild
index 6b11db8d..7a53502f 100644
--- a/www-client/arcanist/arcanist-20160701.ebuild
+++ b/www-client/arcanist/arcanist-20160701.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="ncurses"
@@ -23,12 +23,12 @@ REQUIRED_USE="test? ( lint )"
DEPEND="virtual/awk:0
test? (
- >=dev-lang/php-5.2.3[xmlwriter]
- <dev-lang/php-7
+ >=dev-lang/php-5.2.3:*[xmlwriter]
+ <dev-lang/php-7:*
=dev-php/libphutil-20160709:0[test]
)"
-RDEPEND=">=dev-lang/php-5.2.3[cli,curl,json,ssl?]
- <dev-lang/php-7
+RDEPEND=">=dev-lang/php-5.2.3:*[cli,curl,json,ssl?]
+ <dev-lang/php-7:*
=dev-php/libphutil-20160709:0[ssl?]
git? ( dev-vcs/git:0 )
mercurial? ( dev-vcs/mercurial:0 )
@@ -36,7 +36,7 @@ RDEPEND=">=dev-lang/php-5.2.3[cli,curl,json,ssl?]
lint? (
app-admin/puppet-lint:0
dev-haskell/hlint:0
- dev-php/PEAR-PHP_CodeSniffer:0
+ dev-php/PHP_CodeSniffer:0
dev-python/pylint:0[${PYTHON_USEDEP}]
dev-python/flake8:0[${PYTHON_USEDEP}]
dev-util/cppcheck:0
@@ -76,6 +76,8 @@ src_test() {
}
src_prepare() {
+ default
+
git log --format='%H %ct' -n 1 > "${S}/GIT_COMMIT_INFO"
find "${S}" -type f -name .gitignore -print0 \
diff --git a/www-client/arcanist/arcanist-9999.ebuild b/www-client/arcanist/arcanist-9999.ebuild
index d9e22ee1..97e9303a 100644
--- a/www-client/arcanist/arcanist-9999.ebuild
+++ b/www-client/arcanist/arcanist-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="ncurses"
@@ -21,12 +21,12 @@ REQUIRED_USE="test? ( lint )"
DEPEND="virtual/awk:0
test? (
- >=dev-lang/php-5.2.3[xmlwriter]
- <dev-lang/php-7
+ >=dev-lang/php-5.2.3:*[xmlwriter]
+ <dev-lang/php-7:*
=dev-php/libphutil-${PV}:0[test]
)"
-RDEPEND=">=dev-lang/php-5.2.3[cli,curl,json,ssl?]
- <dev-lang/php-7
+RDEPEND=">=dev-lang/php-5.2.3:*[cli,curl,json,ssl?]
+ <dev-lang/php-7:*
=dev-php/libphutil-${PV}:0[ssl?]
git? ( dev-vcs/git:0 )
mercurial? ( dev-vcs/mercurial:0 )
@@ -34,7 +34,7 @@ RDEPEND=">=dev-lang/php-5.2.3[cli,curl,json,ssl?]
lint? (
app-admin/puppet-lint:0
dev-haskell/hlint:0
- dev-php/PEAR-PHP_CodeSniffer:0
+ dev-php/PHP_CodeSniffer:0
dev-python/pylint:0[${PYTHON_USEDEP}]
dev-python/flake8:0[${PYTHON_USEDEP}]
dev-util/cppcheck:0
@@ -74,6 +74,8 @@ src_test() {
}
src_prepare() {
+ default
+
git log --format='%H %ct' -n 1 > "${S}/GIT_COMMIT_INFO"
find "${S}" -type f -name .gitignore -print0 \