summaryrefslogtreecommitdiff
path: root/www-client
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2013-09-11 11:49:50 +0200
committerBertrand Jacquin <beber@meleeweb.net>2013-09-11 11:54:01 +0200
commit0f0d29f7bb7b20edeac01e841a565cb3f1bfafe2 (patch)
tree695b0f93a65e612dd806969b2b26f06a9efd4f37 /www-client
parentdev-php/libphutil: Replace 'env' shebang to files it point to, move source de... (diff)
downloadportage-0f0d29f7bb7b20edeac01e841a565cb3f1bfafe2.tar.xz
www-client/arcanist: Replace 'env' shebang to files it point to, move source deletion to src_prepare
Package-Manager: portage-2.2.2
Diffstat (limited to 'www-client')
-rw-r--r--www-client/arcanist/ChangeLog4
-rw-r--r--www-client/arcanist/Manifest4
-rw-r--r--www-client/arcanist/arcanist-9999.ebuild33
3 files changed, 37 insertions, 4 deletions
diff --git a/www-client/arcanist/ChangeLog b/www-client/arcanist/ChangeLog
index 6cd21f11..e27a7388 100644
--- a/www-client/arcanist/ChangeLog
+++ b/www-client/arcanist/ChangeLog
@@ -1,3 +1,7 @@
+ 11 Sep 2013; Bertrand Jacquin <beber@meleeweb.net> arcanist-9999.ebuild:
+ www-client/arcanist: Replace 'env' shebang to files it point to, move source
+ deletion to src_prepare
+
02 Sep 2013; Bertrand Jacquin <beber@meleeweb.net> arcanist-9999.ebuild:
www-client/arcanist: Implement FEATURES=test
diff --git a/www-client/arcanist/Manifest b/www-client/arcanist/Manifest
index 2a2f4913..19b68271 100644
--- a/www-client/arcanist/Manifest
+++ b/www-client/arcanist/Manifest
@@ -1,3 +1,3 @@
-EBUILD arcanist-9999.ebuild 2270 SHA256 f979ed329e999c7ce711da8f13aef077a50b9368be10f66c0c46328af07e3c6c WHIRLPOOL d94b9354549f81ffc2dc3d20427df25e48d12b1b3758ff91030999cc40087aceabbe57b72f94ef2392deb9d7f4f5af2bb8399ead9d0f187f1f35fb8d15a12500
-MISC ChangeLog 1320 SHA256 575a62d57e91f4dd04eb2d49eb09f262b2c0c5d4f912ca6140611f192bc50b14 WHIRLPOOL 9d8f7cbf9aa3b43780f76793ada6f942c695723dde49d3a3fe10d2a40299040a4de0903dc579c7f46fd02cf41832890cfa75f428b6aaf8245b515299832d9401
+EBUILD arcanist-9999.ebuild 2947 SHA256 eb45698eb3603d6a5b162aae243744cfee8e02822e145d0bbff8d09b50975f47 WHIRLPOOL 98b6d11d8982f10042a95ec8e215aa136d3745c035c119637495113cd519419210bd6cae6fb45d69f82f92efaf37aae369337bb218231ef65f1fc03de1047688
+MISC ChangeLog 1501 SHA256 261bc5343a84f1d16bda711cff90eab1b5e050631592e550d71012e970ac2ac7 WHIRLPOOL 06a082cc6ce85981807ac4aad24dfa43be8e0222dd498fb59f14bc6e1d3a30a9637a8e16ec0a84d0a0d834c70c38c835c2100a7067eabc7cf99df02fb64ae089
MISC metadata.xml 376 SHA256 214868e07f83e61d21087c9867be82c69039947d2f6e29d5d0facf23e7690a4d WHIRLPOOL 34de8852dfdb73e442aba0c8b52cb6bc7877ca7d9b922245d25861935d69882cebeb9a3220dadd2b0f8548f6b16d10bb2c95017eda5d5f7b96cc6af7eadb484d
diff --git a/www-client/arcanist/arcanist-9999.ebuild b/www-client/arcanist/arcanist-9999.ebuild
index c08c6147..2f0cbc5a 100644
--- a/www-client/arcanist/arcanist-9999.ebuild
+++ b/www-client/arcanist/arcanist-9999.ebuild
@@ -44,13 +44,42 @@ src_test() {
bin/arc unit --everything --no-coverage || ewarn "arc unit failed"
}
-src_install() {
+src_prepare() {
+ find "${S}" -type f -name .gitignore -print0 \
+ | xargs -0 --no-run-if-empty -- \
+ rm
+
# Provided by dev-python/pep8
rm -r externals/pep8
rm bin/*.bat
rm scripts/*.txt
+ # Replace 'env' shebang to files it point to
+ find "${S}" -type f \
+ | sort \
+ | xargs -n 1 --no-run-if-empty -- \
+ awk 'NR == 1 && /^#!\/usr\/bin\/env/ {print FILENAME}' \
+ | while read ; do
+ set -- $(sed -ne '1 s:^#!\([^ ]*\) ::p;q' ${REPLY})
+ cmd="$1" ; shift ; args="$@"
+
+ case "${cmd}" in
+ bash|php) ;;
+ *) continue ;;
+ esac
+
+ path="$(type -p ${cmd})" || continue
+ [[ -z "${path}" ]] && continue
+
+ einfo "Changing ${REPLY/#${S}\/} shebang to #!${path} ${args}"
+ sed -i \
+ -e "1 s:^#!.*:#!${path} ${args}:" \
+ "${REPLY}"
+ done
+}
+
+src_install() {
newbashcomp resources/shell/bash-completion "${PN}"
insinto "/usr/share/php/${PN}"
@@ -72,7 +101,7 @@ src_install() {
dodoc NOTICE README
}
-pkg_postinst () {
+pkg_postinst() {
elog
elog "Linter for different languages are available thrue USE flags"
elog " css javascript php python ruby"