summaryrefslogtreecommitdiff
path: root/www-apps
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2008-03-31 03:47:01 +0200
committerBertrand Jacquin <beber@meleeweb.net>2008-03-31 03:47:01 +0200
commita4ef87a3358ae6b9d30bf4d32f8606ca8b5ffc2a (patch)
tree2ff3d7e82fb96aa70925b78f98ce067bf9ebac5d /www-apps
parentroundcube from webapp-experimental (diff)
downloadportage-a4ef87a3358ae6b9d30bf4d32f8606ca8b5ffc2a.tar.xz
ebuild for zenphoto
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/zenphoto/Manifest4
-rw-r--r--www-apps/zenphoto/files/postinstall-en.txt4
-rw-r--r--www-apps/zenphoto/files/postupgrade-en.txt7
-rw-r--r--www-apps/zenphoto/zenphoto-1.1.5.ebuild52
4 files changed, 67 insertions, 0 deletions
diff --git a/www-apps/zenphoto/Manifest b/www-apps/zenphoto/Manifest
new file mode 100644
index 00000000..acbb3ed5
--- /dev/null
+++ b/www-apps/zenphoto/Manifest
@@ -0,0 +1,4 @@
+AUX postinstall-en.txt 177 RMD160 6cb9bf7adca2a41c39e11a321a14c1bf2fb76532 SHA1 54333d1ba93d670765f48470e70401a21e3080fa SHA256 867e1fad7e8f2275f1e2e887f4c5c0599d1fb770a0dedef97fcfe849c7e7b94a
+AUX postupgrade-en.txt 498 RMD160 f5bc793fe7fe5e2394f6a6150e0eb6191f8dcdd4 SHA1 5fd63c2bf2f0603230a76b579fc49b95367fd1b2 SHA256 dfe4da27be637222a1005bc1276d73325905f5d98591f918ca4b38cf351ded67
+DIST zenphoto-1.1.5.tar.gz 770444 RMD160 be97af59e4204b36a7bca55223efa5d8a7e8b7a4 SHA1 e9fdf5d65e2f1a7afb4c14b16bc92ad53b768b20 SHA256 4848ede68bff4ad05103fd446b9d5240dc23185ea732f07993a42e5f27018954
+EBUILD zenphoto-1.1.5.ebuild 1192 RMD160 defc1e64d06c9b7a17c19a94ea8b434d500afe4b SHA1 8d87edb182bee5bf8b9c6e06c4db935a0a97dd8e SHA256 e60c6d17657232583e16b7a5d5e09d1eea11e905949b4eaf98b86e6052197810
diff --git a/www-apps/zenphoto/files/postinstall-en.txt b/www-apps/zenphoto/files/postinstall-en.txt
new file mode 100644
index 00000000..e9370a3e
--- /dev/null
+++ b/www-apps/zenphoto/files/postinstall-en.txt
@@ -0,0 +1,4 @@
+# Navigate to your gallery. EXAMPLE: www.yoursite.org/gallery/. Setup will run
+# the first time you visit the gallery. Make sure everything checks out then
+# click GO!
+# ENJOY!
diff --git a/www-apps/zenphoto/files/postupgrade-en.txt b/www-apps/zenphoto/files/postupgrade-en.txt
new file mode 100644
index 00000000..1bfc8d2a
--- /dev/null
+++ b/www-apps/zenphoto/files/postupgrade-en.txt
@@ -0,0 +1,7 @@
+With anything after ZenPhoto 1.1.3, upgrading is super easy!
+
+ 1. Backup your MySQL database.
+ 2. Remove the “zen” or “zp-core” folder and the files in the home dir within your installation taking note of the database credentials in your zp-config file, you will need it in step 4
+ 3. Download the latest version and upload it to your server.
+ 4. Once the files are uploaded, go to www.yoursite.org/gallery/. Setup.php will run. Follow the instructions.
+ 5. You’re done! Enjoy.
diff --git a/www-apps/zenphoto/zenphoto-1.1.5.ebuild b/www-apps/zenphoto/zenphoto-1.1.5.ebuild
new file mode 100644
index 00000000..54bdd1e6
--- /dev/null
+++ b/www-apps/zenphoto/zenphoto-1.1.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils webapp depend.php depend.apache
+
+DESCRIPTION="A simpler web photo gallery"
+HOMEPAGE="http://www.zenphoto.org/"
+SRC_URI="http://www.zenphoto.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="exif"
+
+RDEPEND=">=virtual/mysql-3.23
+ || ( www-servers/lighttpd
+ www-servers/apache )
+ >=dev-lang/php-4.1.0
+ exif? ( media-libs/libexif )"
+need_httpd_cgi
+need_php_httpd
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ local require="mysql gd"
+ use exif && require="${require} exif"
+
+ require_php_with_use ${require}
+
+ webapp_pkg_setup
+}
+
+#src_unpack() {
+# unpack ${A}
+#}
+
+src_install () {
+ webapp_src_preinst
+ dodoc README.html lighttpd-rewrite.txt example_robots.txt
+
+ cp -R [[:lower:]]* ${D}/${MY_HTDOCSDIR}
+ cp ${D}/${MY_HTDOCSDIR}/zp-core/zp-config.php{.example,}
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/cache
+ webapp_serverowned "${MY_HTDOCSDIR}"/albums
+
+ webapp_configfile "${MY_HTDOCSDIR}"/zp-core/zp-config.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_postupgrade_txt en "${FILESDIR}"/postupgrade-en.txt
+ webapp_src_install
+}