summaryrefslogtreecommitdiff
path: root/www-apps
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2013-09-06 22:28:23 +0200
committerBertrand Jacquin <beber@meleeweb.net>2013-09-06 22:29:38 +0200
commit6134c13d71c4cef0456057801fbbc34ff834525c (patch)
treee19357cb629c4759298a5f871a6cce1dfe1a2a64 /www-apps
parentRefresh metadata/md5-cache reflecting changes in flag-o-matic, git-2, (diff)
downloadportage-6134c13d71c4cef0456057801fbbc34ff834525c.tar.xz
www-apps/phabricator: Fix installing outside from htdocs
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/phabricator/ChangeLog3
-rw-r--r--www-apps/phabricator/Manifest4
-rw-r--r--www-apps/phabricator/phabricator-9999.ebuild24
3 files changed, 21 insertions, 10 deletions
diff --git a/www-apps/phabricator/ChangeLog b/www-apps/phabricator/ChangeLog
index 461ae880..1e33668a 100644
--- a/www-apps/phabricator/ChangeLog
+++ b/www-apps/phabricator/ChangeLog
@@ -1,3 +1,6 @@
+ 06 Sep 2013; Bertrand Jacquin <beber@meleeweb.net> phabricator-9999.ebuild:
+ www-apps/phabricator: Fix installing outside from htdocs
+
02 Sep 2013; Bertrand Jacquin <beber@meleeweb.net> phabricator-9999.ebuild:
www-apps/phabricator: Implement FEATURES=test
diff --git a/www-apps/phabricator/Manifest b/www-apps/phabricator/Manifest
index 7c29a11e..adb89874 100644
--- a/www-apps/phabricator/Manifest
+++ b/www-apps/phabricator/Manifest
@@ -1,5 +1,5 @@
AUX phabricator.confd 223 SHA256 afa8ecbedde0eadad0474a5c03c0ab86db7e0b85fec720e560156958f437cb74 WHIRLPOOL c2ac7e29b6a551828cc175132c5f7f29345042d375e5d38de2d2a2989101e6303b677cde8e8184be1de2d5495165cd2d19fdfabd37db0503c34f2f9e1e5b86be
AUX phabricator.initd 850 SHA256 d0a9dabfa0a618f4a316eca263e8ecc39f2c1f0e9813c35a6d9777aa45dddb9f WHIRLPOOL af4b2ad1474b22aa1481e334f3b07ff616149d27ccb59131da5666168dfc64cae65ed2dbf9ed74e222ee7e22367af394c11bf18edd4e9b0790b8abd55d201617
-EBUILD phabricator-9999.ebuild 3372 SHA256 51e78f57d7cd7582c801bbb14c07f9b625ff20bf0a297f4fd88a781cdf991868 WHIRLPOOL e6d9ee5363258b150de6cff85279c45b60d85ea2c73c4bb96163e5af4f0b44a1751489c4fa90ee16127f884992841ff0488664a5b1b4e633b95a0f69a65e77f3
-MISC ChangeLog 1740 SHA256 0afe19ac2d3a4791cca9d5e747e590c5e57e1f5bbaa23a532c72220b54df69c4 WHIRLPOOL db0d500dfcafc7c053858506a3c4e76cf189a61fb95dd6722dcf0330958341f39899e154751e3738f2326cac5faf6d9ae343736e294f7e5b78304459e85d40e0
+EBUILD phabricator-9999.ebuild 3701 SHA256 9a535e5764c842f3081b8b81c3883fe00967da5822fe9b12398107ed291a9d90 WHIRLPOOL 5b0a8d004197c2ce2cf43a7873b4b810e7a24b266081c61387e2a0c5071d58e8d45d4b0a6553804effb674e0929b5649bf241ded2490d8f5345221e49df3542b
+MISC ChangeLog 1878 SHA256 77434f47251ef76b976291fd7e1e1f467dc5a7c535b002e35299cd2276432f97 WHIRLPOOL 2700653367a7e5dbc62cc690c437304058b5db4914127b69b9e167475233306b95b7f13e43b3710c2d0d63e88885390458bb18ffa92a528a378f5b64b12d5fef
MISC metadata.xml 653 SHA256 744c67bfd3b874f305b08a5b68c5e2213c3cdc1c47b381fe130ebfc2005a964b WHIRLPOOL 5efd225c032e0704862510f166c94327460caf27527b473fe8f35ea6117b2b16862e362aff0b7bdb47b38349dbcf8710fff4040f11d50e07865f983dacc93d99
diff --git a/www-apps/phabricator/phabricator-9999.ebuild b/www-apps/phabricator/phabricator-9999.ebuild
index edc3c1f6..f981d9bf 100644
--- a/www-apps/phabricator/phabricator-9999.ebuild
+++ b/www-apps/phabricator/phabricator-9999.ebuild
@@ -83,8 +83,20 @@ src_install() {
rm -r scripts/install
- insinto "${MY_APPDIR}"
- doins -r bin conf externals resources scripts src support webroot
+ # All directoies must be private (ie accessible in hostroot),
+ # expect webroot that will become htdocs
+ insinto "${MY_HOSTROOTDIR}"
+ doins -r bin conf externals resources scripts src support
+
+ # All files and directories present in webroot/ will be
+ # installed in htdocs
+ insinto "${MY_HTDOCSDIR}"
+ doins -r webroot/*
+
+ # In any case, hostroot access files in webroot/ directory
+ # so we need to make sure a webroot symlink is present in hostroot
+ # that point to actual htdocs
+ dosym "${MY_HTDOCSBASE}" "${MY_HOSTROOTDIR}/webroot"
# Make executable all shebanged files
find "${ED}" -type f \
@@ -94,11 +106,7 @@ src_install() {
| xargs --no-run-if-empty -- \
fperms 755
- # "${MY_HTDOCSDIR}" is created by webapp_src_preinst()
- rm -r "${ED}/${MY_HTDOCSDIR}"
- dosym webroot "${MY_HTDOCSDIR}"
-
- webapp_configfile "${MY_APPDIR}"/conf/{default,development,production}.conf.php
+ webapp_configfile "${MY_HOSTROOTDIR}"/conf/{default,development,production}.conf.php
webapp_src_install
newinitd "${FILESDIR}/${PN}.initd" "${PN}"
@@ -112,7 +120,7 @@ pkg_postinst() {
elog
elog "After an upgrade, you should run"
- elog " ${MY_APPDIR}bin/storage upgrade"
+ elog " ${MY_APPDIR}/bin/storage upgrade"
elog
elog "For more info about how to configure it, see"
elog " http://www.phabricator.com/docs/phabricator/article/Configuration_Guide.html"