summaryrefslogtreecommitdiff
path: root/www-apache
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2010-06-06 03:51:58 +0200
committerBertrand Jacquin <beber@meleeweb.net>2010-06-06 03:51:58 +0200
commitb494b67a69bb463e5325576a751d1a762bafa50b (patch)
treeddcc34a5e7028708855038e629f8b3dedeba52af /www-apache
parentMerge branch 'master' of git://git.meleeweb.net/var/git/distros/gentoo/portage (diff)
downloadportage-b494b67a69bb463e5325576a751d1a762bafa50b.tar.xz
ebuild for mod_virtualvalue
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_virtualvalue/Manifest1
-rw-r--r--www-apache/mod_virtualvalue/mod_virtualvalue-9999.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/www-apache/mod_virtualvalue/Manifest b/www-apache/mod_virtualvalue/Manifest
new file mode 100644
index 00000000..8adfab9d
--- /dev/null
+++ b/www-apache/mod_virtualvalue/Manifest
@@ -0,0 +1 @@
+EBUILD mod_virtualvalue-9999.ebuild 769 RMD160 8442f7a3f7c31c175e0e49ca7056b90f6e5ba0de SHA1 8b4b7853b37c93dbc89e8215d92e369cdcddb8ea SHA256 bfecc5752070c68acd291c93d410382dd6048c43775b79f9ca19697670c63035
diff --git a/www-apache/mod_virtualvalue/mod_virtualvalue-9999.ebuild b/www-apache/mod_virtualvalue/mod_virtualvalue-9999.ebuild
new file mode 100644
index 00000000..a8f73c01
--- /dev/null
+++ b/www-apache/mod_virtualvalue/mod_virtualvalue-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EGIT_REPO_URI="git://git.meleeweb.net/var/git/mod_virtualvalue.git"
+EGIT_PROJECT="mod_virtualvalue.git"
+
+inherit apache-module eutils toolchain-funcs confutils git
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Apache2 modules to Mass Virtual Hosting"
+HOMEPAGE="http://git.meleeweb.net/cgit.cgi/mod_virtualvalue.git/"
+LICENSE="GPL"
+SLOT="0"
+IUSE="php debug"
+
+DEPEND="php? ( dev-lang/php )"
+RDEPEND=""
+
+#APACHE2_MOD_CONF="10_${PN}"
+
+need_apache2_2
+
+pkg_setup() {
+ confutils_require_built_with_all www-servers/apache debug
+}
+
+src_compile() {
+ myconf=
+ use php && myconf="${myconf} HAVE_PHP=Yes"
+ use debug && myconf="${myconf} DEBUG=Yes"
+
+ make ${myconf}
+}