summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2022-09-17 17:32:31 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2022-09-17 17:32:31 +0100
commit358209cea87560595b29571abc2e6076f1580f98 (patch)
tree89dc12f3d9e81887fe706bb2ecadf5f3f8c48b9a /sys-fs
parentwww-client/inject: unused eclass: eutils (diff)
downloadportage-358209cea87560595b29571abc2e6076f1580f98.tar.xz
sys-fs/static-dev: unkeyword 0.1 for s390
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/static-dev/static-dev-0.1.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/sys-fs/static-dev/static-dev-0.1.ebuild b/sys-fs/static-dev/static-dev-0.1.ebuild
index b6f80427..dc503ee6 100644
--- a/sys-fs/static-dev/static-dev-0.1.ebuild
+++ b/sys-fs/static-dev/static-dev-0.1.ebuild
@@ -2,7 +2,6 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs
DESCRIPTION="A skeleton, statically managed /dev"
HOMEPAGE="https://bugs.gentoo.org/107875"
@@ -10,12 +9,12 @@ SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 arm hppa m68k ~mips ppc ppc64 s390 sparc x86"
+KEYWORDS="amd64 arm hppa m68k ~mips ppc ppc64 sparc x86"
IUSE=""
DEPEND="sys-apps/makedev"
-abort() {
+_abort() {
echo
eerror "We have detected that you currently use udev or devfs or devtmpfs"
eerror "and this ebuild cannot install to the same mount-point."
@@ -26,7 +25,7 @@ pkg_pretend() {
# We also want to not clobber newer devtmpfs setups.
if [[ ${ROOT} == "/" ]] && \
! awk '$2 == "/dev" && $3 == "devtmpfs" { exit 1 }' /proc/mounts ; then
- abort
+ _abort
fi
}