summaryrefslogtreecommitdiff
path: root/sys-firmware
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2018-08-26 02:42:38 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2018-10-05 00:10:36 +0100
commitb01f1db399c9d5581b2619a8ca15a9155292bc97 (patch)
tree664a9e6c9b5137fda7dc27f44ca6470c39fe4dea /sys-firmware
parentsys-kernel/stable-sources: Version bump (diff)
downloadportage-b01f1db399c9d5581b2619a8ca15a9155292bc97.tar.xz
sys-firmware/gnuk: Version bump
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sys-firmware')
-rw-r--r--sys-firmware/gnuk/files/1.2.10-Disable-PIE-by-default.patch24
-rw-r--r--sys-firmware/gnuk/files/1.2.10-MINOR-Always-get-version-from-the-VERSION-file.patch (renamed from sys-firmware/gnuk/files/1.2.8-MINOR-Always-get-version-from-the-VERSION-file.patch)0
-rw-r--r--sys-firmware/gnuk/gnuk-1.2.10.ebuild (renamed from sys-firmware/gnuk/gnuk-1.2.8.ebuild)7
3 files changed, 30 insertions, 1 deletions
diff --git a/sys-firmware/gnuk/files/1.2.10-Disable-PIE-by-default.patch b/sys-firmware/gnuk/files/1.2.10-Disable-PIE-by-default.patch
new file mode 100644
index 00000000..2469ecb5
--- /dev/null
+++ b/sys-firmware/gnuk/files/1.2.10-Disable-PIE-by-default.patch
@@ -0,0 +1,24 @@
+From a62a16d0f7561c91580bec39a2170fabf6f3c80a Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Tue, 28 Aug 2018 21:51:26 +0100
+Subject: [PATCH] Disable PIE by default
+
+If gcc is built using --enable-default-pie, generated binary will
+contain dynamic relocations which is irrelevant for firmware build
+---
+ chopstx/rules.mk | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/chopstx/rules.mk b/chopstx/rules.mk
+index 110079efdaaa..39ec326fb295 100644
+--- a/chopstx/rules.mk
++++ b/chopstx/rules.mk
+@@ -42,7 +42,7 @@ OUTFILES = $(BUILDDIR)/$(PROJECT)
+ endif
+
+
+-OPT += -ffunction-sections -fdata-sections -fno-common
++OPT += -ffunction-sections -fdata-sections -fno-common -fno-pie
+
+ OBJS = $(addprefix $(BUILDDIR)/, $(notdir $(CSRC:.c=.o)))
+
diff --git a/sys-firmware/gnuk/files/1.2.8-MINOR-Always-get-version-from-the-VERSION-file.patch b/sys-firmware/gnuk/files/1.2.10-MINOR-Always-get-version-from-the-VERSION-file.patch
index 6d704acb..6d704acb 100644
--- a/sys-firmware/gnuk/files/1.2.8-MINOR-Always-get-version-from-the-VERSION-file.patch
+++ b/sys-firmware/gnuk/files/1.2.10-MINOR-Always-get-version-from-the-VERSION-file.patch
diff --git a/sys-firmware/gnuk/gnuk-1.2.8.ebuild b/sys-firmware/gnuk/gnuk-1.2.10.ebuild
index 66199638..1cff6331 100644
--- a/sys-firmware/gnuk/gnuk-1.2.8.ebuild
+++ b/sys-firmware/gnuk/gnuk-1.2.10.ebuild
@@ -23,7 +23,10 @@ RDEPEND="virtual/udev
dev-python/colorama[${PYTHON_USEDEP}]
)"
-PATCHES=( "${FILESDIR}/${PV}-MINOR-Always-get-version-from-the-VERSION-file.patch" )
+PATCHES=(
+ "${FILESDIR}/${PV}-MINOR-Always-get-version-from-the-VERSION-file.patch"
+ "${FILESDIR}/${PV}-Disable-PIE-by-default.patch"
+)
pkg_pretend() {
if type -p arm-none-eabi-gcc > /dev/null 2>&1 ; then
@@ -56,6 +59,7 @@ src_configure() {
--vidpid=234b:0000 \
--enable-certdo \
--enable-factory-reset \
+ --enable-hid-card-change \
$(use_enable debug) \
|| die "configure failed"
}
@@ -95,6 +99,7 @@ src_install() {
if use tools ; then
python_foreach_impl python_domodule tool/gnuk_token.py
python_foreach_impl python_domodule tool/gpg_agent.py
+ python_foreach_impl python_domodule tool/kdf_calc.py
python_foreach_impl python_domodule tool/rsa.py
python_foreach_impl python_doscript "tool/${PN}-get_raw_public_key.py"