summaryrefslogtreecommitdiff
path: root/sys-firmware
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2022-09-17 18:02:41 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2022-09-17 18:09:46 +0100
commita617a3fabc80c70d99ab16ee9f0c22ca8a9e16e4 (patch)
treed616d608174586d3a681fbf1d92551b3217a0f86 /sys-firmware
parentsys-fs/static-dev: unkeyword 0.1 for s390 (diff)
downloadportage-a617a3fabc80c70d99ab16ee9f0c22ca8a9e16e4.tar.xz
sys-firmware/gnuk: unused eclass: eutils
Diffstat (limited to 'sys-firmware')
-rw-r--r--sys-firmware/gnuk/gnuk-1.2.19.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/sys-firmware/gnuk/gnuk-1.2.19.ebuild b/sys-firmware/gnuk/gnuk-1.2.19.ebuild
index ba3fcf0e..5d780a75 100644
--- a/sys-firmware/gnuk/gnuk-1.2.19.ebuild
+++ b/sys-firmware/gnuk/gnuk-1.2.19.ebuild
@@ -3,7 +3,7 @@
EAPI=7
PYTHON_COMPAT=( python{3_8,3_9,3_10} )
-inherit git-r3 eutils python-r1 udev
+inherit git-r3 python-r1 udev
DESCRIPTION="An Implementation of USB Cryptographic Token for GnuPG"
HOMEPAGE="https://www.fsij.org/category/gnuk.html"
@@ -22,6 +22,7 @@ RDEPEND="virtual/udev
dev-python/pyusb[${PYTHON_USEDEP}]
dev-python/colorama[${PYTHON_USEDEP}]
)"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
PATCHES=(
"${FILESDIR}/${PV}-MINOR-Always-get-version-from-the-VERSION-file.patch"
@@ -96,7 +97,8 @@ src_install() {
fi
install_example() {
- insinto "$(python_get_scriptdir)"
+ local d="$(python_get_scriptdir)"
+ insinto "${d#${EPREFIX}}"
doins "${1}"
}