summaryrefslogtreecommitdiff
path: root/sys-apps
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2013-05-27 14:08:41 +0200
committerBertrand Jacquin <beber@meleeweb.net>2013-05-27 14:08:41 +0200
commitb1b3a0c9964c5058670ca5a653e0d7dca4641c80 (patch)
tree63cb955802ffb9017d332a7fb96d53e8d911da28 /sys-apps
parentrefresh missing-links, need to vanish this (diff)
downloadportage-b1b3a0c9964c5058670ca5a653e0d7dca4641c80.tar.xz
sys-apps/dfc: update to eclass git-2 and fix warnings
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/dfc/Manifest5
-rw-r--r--sys-apps/dfc/dfc-9999.ebuild18
-rw-r--r--sys-apps/dfc/files/9999-warning-cast.diff61
3 files changed, 77 insertions, 7 deletions
diff --git a/sys-apps/dfc/Manifest b/sys-apps/dfc/Manifest
index 7771cc3d..6a69c68c 100644
--- a/sys-apps/dfc/Manifest
+++ b/sys-apps/dfc/Manifest
@@ -1,2 +1,3 @@
-AUX remount-sstrip.diff 370 RMD160 33a7ca7b82aebd93c535ecff417e1a11fa2689b7 SHA1 85114a3448ef46bb0eb1eca99587ed03e64dfa3d SHA256 200399addf766d1871da02a52fa1f3fb9c246ecb6327d2af33b1c36bab21ba0e
-EBUILD dfc-9999.ebuild 577 RMD160 61e84d808a459dbc79a18d35f6f07f02e81e5296 SHA1 2eaf9a21de4ac0d8df474b38e9e495f20bc7be70 SHA256 f214a57bc8966cba50e87cb473f7c0ca3886e885f6337fe7878d4e23e20859f8
+AUX 9999-warning-cast.diff 2198 SHA256 91c5fe95e6dbd81c1a098a2e417ad50e9ebc1a6590daa7fde8c10afa6b0ec69b SHA512 6a96109bc3fae0e052b343bc5b7adc013ed3bb0fb85a8e9fb7a079b6a5a8c4082a45f7e4c435806fd0bdd3005a153027c1c12f9452aa6624fe25b11bb1ce7882 WHIRLPOOL ff101f6c68f7971dbeb98cd45aff92596b19926caa01a33ec33d1b0afbd03977d8cf2943aab0808829dbf6a566f1340a909cef5349949fa4b93a74e0920e2493
+AUX remount-sstrip.diff 370 SHA256 200399addf766d1871da02a52fa1f3fb9c246ecb6327d2af33b1c36bab21ba0e SHA512 1d3a3cb02cfea24c0bf4f6b61aed07ea41102d00f92620a8d6ad530211d81ed821537a167af164da58ce72a09454b3218d848d1a3a8fe540255956535d743954 WHIRLPOOL 9556880a94e0fcbdf77d8b3f7b4968247cbcff7fa6dfe3d67946c9b4c5cb1ca3b9c1a67d7063449cdccfaee26652ccc2634305da29910c89736465aea5b9065c
+EBUILD dfc-9999.ebuild 601 SHA256 af8dae0ee5172f1c646deb39a19acfef675395c9dbcffe26286f36fba242188b SHA512 cd63646240592e04b1ec173102619c5eb793fa9ffbd883b28795e8cda36e063e6a3645f872d54d986f787a86dea807f09c7bb6bf74ce3fd2f1efdb7c0220be0a WHIRLPOOL d32c51329a7f8db566a8480a87fed8e2bb5725e585517816596ea8f9c178bbe39edb87700761e09264ef3927290c3bfdaa3d3ccbf23e0ed17036e08fcbd7deda
diff --git a/sys-apps/dfc/dfc-9999.ebuild b/sys-apps/dfc/dfc-9999.ebuild
index 06797e96..93d45f0d 100644
--- a/sys-apps/dfc/dfc-9999.ebuild
+++ b/sys-apps/dfc/dfc-9999.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit git
+EAPI=4
+inherit git-2 toolchain-funcs eutils
DESCRIPTION="Formilux Tools"
HOMEPAGE="http://master.formilux.org/git/people/ben/dfc.git"
@@ -15,13 +16,20 @@ KEYWORDS="~amd64 ~x86"
DEPEND=""
RDEPEND=""
+src_prepare ()
+{
+ epatch "${FILESDIR}"/${PV}-warning-cast.diff
+
+ sed -i \
+ -e "/^LDFLAGS=/ s/-static//" \
+ Makefile
+}
+
src_compile ()
{
-# export DIET="/usr/bin/diet"
-# export OBJDUMP="$(tc-getPROG OBJDUMP objdump ${CHOST})"
-# export STRIP="$(tc-getSTRIP)"
+ tc-export CC
- emake || die "emake flx failed"
+ emake
}
src_install ()
diff --git a/sys-apps/dfc/files/9999-warning-cast.diff b/sys-apps/dfc/files/9999-warning-cast.diff
new file mode 100644
index 00000000..e26af997
--- /dev/null
+++ b/sys-apps/dfc/files/9999-warning-cast.diff
@@ -0,0 +1,61 @@
+diff --git a/dfc.c b/dfc.c
+index 91eb5df..9a0ed57 100644
+--- a/dfc.c
++++ b/dfc.c
+@@ -12,7 +12,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+-#define _XOPEN_SOURCE /* glibc2 needs this */
++#define __USE_XOPEN /* glibc2 needs this */
+ #include <time.h>
+ #include <limits.h>
+ #include <unistd.h>
+@@ -307,7 +307,7 @@ time_t strptime_mktime(const char *s, const char *format, struct tm *tm) {
+ }
+ tm->tm_isdst = 0;
+
+- p = (char*)strptime(s, format, tm);
++ p = strptime((char *)s, format, tm);
+ if (!p || *p)
+ return ((time_t)-1);
+
+@@ -394,7 +394,7 @@ int main(int argc, char **argv) {
+ char *p;
+
+ if ((p = strchr(global_first_line_full_date, '='))) {
+- if (strptime(global_first_line_full_date, p+1, &ref_tm) == -1) {
++ if (strptime(global_first_line_full_date, p+1, &ref_tm) == (char *)-1) {
+ ERROR("bad reference time or format");
+ exit(2);
+ }
+@@ -479,7 +479,7 @@ int main(int argc, char **argv) {
+ if (date_field >= 0) {
+ // check date on group number 'date_field',
+ // global_date_filter_field need to set to enable this condition
+- if (!(ptmp = (void*)strptime(tmp + REG_PTR(m, date_field),
++ if (!(ptmp = strptime(tmp + REG_PTR(m, date_field),
+ global_input_date_format, &tm))) {
+ fprintf(stderr, "UNPARSABLE: %s", tmp + REG_PTR(m, date_field));
+ continue;
+@@ -487,7 +487,7 @@ int main(int argc, char **argv) {
+ }
+ else {
+ // single call to localtime at begin of line
+- if (!(ptmp = (void*)strptime(tmp, global_input_date_format, &tm))) {
++ if (!(ptmp = strptime(tmp, global_input_date_format, &tm))) {
+ fprintf(stderr, "UNPARSABLE: %s", tmp);
+ continue;
+ }
+@@ -607,9 +607,9 @@ int main(int argc, char **argv) {
+ }
+
+ if (global_track_past_return) {
+- fprintf(stderr, "NEGATIVE-PAST-RETURN (%d)\nL1: %sL2: %s",
++ fprintf(stderr, "NEGATIVE-PAST-RETURN (%ld)\nL1: %sL2: %s",
+ negative_tm_diff, negative_old_line, negative_cur_line);
+- fprintf(stderr, "POSITIVE-PAST-RETURN (%d)\nL1: %sL2: %s",
++ fprintf(stderr, "POSITIVE-PAST-RETURN (%ld)\nL1: %sL2: %s",
+ positive_tm_diff, positive_old_line, positive_cur_line);
+
+ }