summaryrefslogtreecommitdiff
path: root/sys-apps
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2020-10-02 22:03:21 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2020-10-18 16:02:52 +0100
commit7177b17d970a09f4163ef46b98ce72bbee8d1ba8 (patch)
tree70991f2e5c688a78570d30588498034d92b0405a /sys-apps
parentwww-apps/phabricator: drop old (diff)
downloadportage-7177b17d970a09f4163ef46b98ce72bbee8d1ba8.tar.xz
sys-apps/IPMIView: drop old
Package-Manager: Portage-3.0.4, Repoman-3.0.1
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/IPMIView/IPMIView-2.16.0.ebuild48
-rw-r--r--sys-apps/IPMIView/Manifest1
-rw-r--r--sys-apps/IPMIView/files/IPMIView-wrapper62
-rw-r--r--sys-apps/IPMIView/metadata.xml8
4 files changed, 0 insertions, 119 deletions
diff --git a/sys-apps/IPMIView/IPMIView-2.16.0.ebuild b/sys-apps/IPMIView/IPMIView-2.16.0.ebuild
deleted file mode 100644
index b763dc3b..00000000
--- a/sys-apps/IPMIView/IPMIView-2.16.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit java-utils-2
-
-myPR="190528"
-
-DESCRIPTION="SuperMicro IPMI management tool"
-HOMEPAGE="ftp://ftp.supermicro.com/utility/IPMIView"
-SRC_URI="amd64? ( ftp://ftp.supermicro.com/utility/${PN}/Linux/${PN}_${PV}_build.${myPR}_bundleJRE_Linux_x64.tar.gz )"
-
-LICENSE="Oracle-BCLA-JavaSE"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND="virtual/jre:*"
-RDEPEND="${DEPEND}"
-
-RESTRICT="mirror bindist"
-
-QA_PREBUILT="usr/lib*/*.so"
-
-src_unpack() {
- use x86 && S="${WORKDIR}/${PN}_${PV}_build.${myPR}_bundleJRE_Linux"
- use amd64 && S="${WORKDIR}/${PN}_${PV}_build.${myPR}_bundleJRE_Linux_x64"
-
- default
-}
-
-src_install() {
- exeinto /usr/libexec
- doexe "${FILESDIR}/${PN}-wrapper"
-
- dosym "../libexec/${PN}-wrapper" /usr/bin/IPMIView20
- dosym "../libexec/${PN}-wrapper" /usr/bin/TrapReceiver
-
- java-pkg_dojar iKVM.jar iKVMMicroBlade.jar IPMIView20.jar JViewerX9.jar TrapView.jar
-
- # Use LIBOPTIONS="-m0755" for bug #225729
- use x86 && LIBOPTIONS="-m0755" java-pkg_doso libiKVM32.so libSharedLibrary32.so
- use amd64 && LIBOPTIONS="-m0755" java-pkg_doso libiKVM64.so libSharedLibrary64.so
-
- dodoc IPMIView20_User_Guide.pdf
- dodoc IPMIView_MicroBlade_20141222.pdf IPMIView_SuperBlade_User_Guide.pdf
- dodoc ReleaseNote.txt
-}
diff --git a/sys-apps/IPMIView/Manifest b/sys-apps/IPMIView/Manifest
deleted file mode 100644
index 8174982f..00000000
--- a/sys-apps/IPMIView/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST IPMIView_2.16.0_build.190528_bundleJRE_Linux_x64.tar.gz 93728959 BLAKE2B 28f30ad2adc27ce5795867a323cca905a2177b750a3b4a3ba86a54915e9ec09374a86c5aa889b440540cbb01164a2ebaf7b3c68bce963726cc2d441e4701153a SHA512 6cc56f69c0baf68dd00447517f9d35bb81c47ae5bb654c29884b84aafe26078755ae6c192b68fcbd28619d39f5a472e84c26dfb6f3fbe6baaa8bd1a554238c7e
diff --git a/sys-apps/IPMIView/files/IPMIView-wrapper b/sys-apps/IPMIView/files/IPMIView-wrapper
deleted file mode 100644
index 33b681c6..00000000
--- a/sys-apps/IPMIView/files/IPMIView-wrapper
+++ /dev/null
@@ -1,62 +0,0 @@
-#!/bin/bash
-#
-# (c) 2013-2014 - Bertrand Jacquin <bertrand@jacquin.bzh>
-#
-
-function die () {
- echo "FATAL: $@"
- exit 1
-}
-
-BIN="${0##*/}"
-
-PN="IPMIView"
-PVR="$(java-config --query PVR --package ${PN})"
-
-JAVA_HOME="$(java-config --jre-home)"
-CLASSPATH="$(java-config --classpath ${PN})"
-LIBRARY_PATH="$(java-config --library ${PN})"
-
-if [[ ! -e "/usr/share/${PN}/lib/${BIN}.jar" ]] ; then
- die "/usr/share/${PN}/lib/${BIN}.jar is missing"
-elif [[ ! ${CLASSPATH} ]] ; then
- die "java-config --classpath ${PN} return nothing"
-elif [[ ! ${LIBRARY_PATH} ]] ; then
- die "java-config --library ${PN} return nothing"
-fi
-
-# IPMIView has hardcoded java exec like:
-# java -Djava.library.path=. -jar iKVM.jar ...
-#
-# If you change current directory to /usr/share/IPMIView/lib
-# Then IPMIView20 try to create .properties files but but get denied
-# due to directory permissions
-# --- error to write log[timeout.properties]! ---
-# java.io.FileNotFoundException: ./account.properties (Permission denied)
-# ...
-#
-# So lets fake where the jar remains and create a dumb symlink to real
-# jar so the java exec can use -Djava.library.path=. and create theses
-# properties files
-#
-# The same apply for .so files
-[[ ! -d "${HOME}/.${PN}" ]] && mkdir -p "${HOME}/.${PN}"
-cd "${HOME}/.${PN}" || die "Failed to change directory to ${HOME}/.${PN}"
-
-# Flush that fake IPMIView root directory when IPMIView get upgraded
-if [[ "/usr/share/${PN}/package.env" -nt PVR ]] ; then
- rm -f *.jar *.so
- echo "${PVR}" > PVR
-fi
-
-while read -d : ; do
- [[ ! -L "${REPLY##*/}" ]] && ln -snf "${REPLY}" "${REPLY##*/}"
-done <<< "${CLASSPATH}:"
-
-while read ; do
- [[ ! -L "${REPLY##*/}" ]] && ln -snf "${REPLY}" "${REPLY##*/}"
-done < <(find "${LIBRARY_PATH}" -type f -name '*.so')
-
-exec "${JAVA_HOME}/bin/java" \
- -classpath "${CLASSPATH}" \
- -jar "/usr/share/${PN}/lib/${BIN}.jar"
diff --git a/sys-apps/IPMIView/metadata.xml b/sys-apps/IPMIView/metadata.xml
deleted file mode 100644
index 82f7232e..00000000
--- a/sys-apps/IPMIView/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>bertrand@jacquin.bzh</email>
- <name>Bertrand Jacquin</name>
- </maintainer>
-</pkgmetadata>