summaryrefslogtreecommitdiff
path: root/sys-apps
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2022-03-22 09:03:11 +0000
committerBertrand Jacquin <bertrand@jacquin.bzh>2022-03-26 20:24:20 +0000
commit2e25ed361ae661c71a920a2346f48eeae35c5fba (patch)
treee1ab48d5310f1eb43da57ac2c978710bab9a9047 /sys-apps
parenteclass/linux-build: bump to EAPI 7 (diff)
downloadportage-2e25ed361ae661c71a920a2346f48eeae35c5fba.tar.xz
sys-apps/mklibs: version bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/mklibs/Manifest2
-rw-r--r--sys-apps/mklibs/files/0001-mklibs-fix-usage.patch39
-rw-r--r--sys-apps/mklibs/mklibs-0.1.45.ebuild (renamed from sys-apps/mklibs/mklibs-0.1.44.ebuild)17
3 files changed, 52 insertions, 6 deletions
diff --git a/sys-apps/mklibs/Manifest b/sys-apps/mklibs/Manifest
index d9085db5..5f56ad48 100644
--- a/sys-apps/mklibs/Manifest
+++ b/sys-apps/mklibs/Manifest
@@ -1 +1 @@
-DIST mklibs_0.1.44.tar.xz 22508 BLAKE2B b4d34bd19eacd469f7135727019cc3b1ce6e1b332ced51d06e51da1bb6c6359c49859a60016c8bad735642f19fa2d212342a63264427f7f865f4a6f6cdb7f74c SHA512 c3eaead7df838352f028bebb0b5dbf230d4025cfe5139b68e4563bfacfaaf58b4eaab30394feb19085d97912a1beed0dfe281cdfd749f3b7b4313a20ad792800
+DIST mklibs-debian-0.1.45.tar.gz 26094 BLAKE2B a23e7aa7b32d0607eb8ecd785206bd30d534c21c6a55e05e75f145d2933528c2207b57db6bf7a678f355c6e24f37b24d5c24009639637051679d82374ef4ffac SHA512 e7e15c00ea3cc0a1e35d94c3f43ed9d82e53474e8eda7dffb08ba1312bb7de1d551c68b5e9961c51d60e0de519d8af569f8450f47bda95a8b0485352e4028280
diff --git a/sys-apps/mklibs/files/0001-mklibs-fix-usage.patch b/sys-apps/mklibs/files/0001-mklibs-fix-usage.patch
new file mode 100644
index 00000000..859c297d
--- /dev/null
+++ b/sys-apps/mklibs/files/0001-mklibs-fix-usage.patch
@@ -0,0 +1,39 @@
+From 68dc92f142f77647379f8bb559802398612614dd Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Tue, 22 Mar 2022 09:09:57 +0000
+Subject: [PATCH] mklibs: fix usage
+
+Traceback (most recent call last):
+ File "/usr/lib/python-exec/python3.9/mklibs", line 400, in <module>
+ usage(0)
+ File "/usr/lib/python-exec/python3.9/mklibs", line 301, in usage
+ print(" -D, --no-default-lib omit default libpath (", ':'.join(default_lib_path, file=outfd), ", file=outfd)", file=outfd)
+TypeError: str.join() takes no keyword arguments
+---
+ src/mklibs | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/mklibs b/src/mklibs
+index 081ff844e695..a8c45627b08a 100755
+--- a/src/mklibs
++++ b/src/mklibs
+@@ -298,8 +298,8 @@ def usage(was_err):
+ print("Make a set of minimal libraries for FILE(s, file=outfd) in DEST.", file=outfd)
+ print("" , file=outfd)
+ print(" -d, --dest-dir DIRECTORY create libraries in DIRECTORY", file=outfd)
+- print(" -D, --no-default-lib omit default libpath (", ':'.join(default_lib_path, file=outfd), ", file=outfd)", file=outfd)
+- print(" -L DIRECTORY[:DIRECTORY]... add DIRECTORY(s, file=outfd) to the library search path", file=outfd)
++ print(" -D, --no-default-lib omit default libpath (", ':'.join(default_lib_path), file=outfd)
++ print(" -L DIRECTORY[:DIRECTORY]... add DIRECTORY(s) to the library search path", file=outfd)
+ print(" -l LIBRARY add LIBRARY always", file=outfd)
+ print(" --ldlib LDLIB use LDLIB for the dynamic linker", file=outfd)
+ print(" --libc-extras-dir DIRECTORY look for libc extra files in DIRECTORY", file=outfd)
+@@ -307,7 +307,7 @@ def usage(was_err):
+ print(" --root ROOT search in ROOT for library rpaths", file=outfd)
+ print(" --sysroot ROOT prepend ROOT to all paths for libraries", file=outfd)
+ print(" --gcc-options OPTIONS pass OPTIONS to gcc", file=outfd)
+- print(" --libdir DIR use DIR (e.g. lib64, file=outfd) in place of lib in default paths", file=outfd)
++ print(" --libdir DIR use DIR (e.g. lib64) in place of lib in default paths", file=outfd)
+ print(" -v, --verbose explain what is being done", file=outfd)
+ print(" -h, --help display this help and exit", file=outfd)
+ sys.exit(was_err)
diff --git a/sys-apps/mklibs/mklibs-0.1.44.ebuild b/sys-apps/mklibs/mklibs-0.1.45.ebuild
index fd9bc934..bb718a7d 100644
--- a/sys-apps/mklibs/mklibs-0.1.44.ebuild
+++ b/sys-apps/mklibs/mklibs-0.1.45.ebuild
@@ -1,21 +1,28 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python{3_8,3_9} )
inherit autotools python-single-r1
DESCRIPTION="Shared library reduction script"
HOMEPAGE="https://salsa.debian.org/installer-team/mklibs"
-SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}.tar.xz"
+SRC_URI="https://salsa.debian.org/installer-team/${PN}/-/archive/debian/${PV}/${PN}-debian-${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""
-DEPEND="app-arch/dpkg"
-RDEPEND="${DEPEND}"
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-arch/dpkg"
+
+S="${WORKDIR}/${PN}-debian-${PV}"
+
+PATCHES=(
+ "${FILESDIR}/0001-mklibs-fix-usage.patch"
+)
src_prepare() {
default