summaryrefslogtreecommitdiff
path: root/sys-apps/dfc
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2011-07-23 00:43:14 +0200
committerBertrand Jacquin <beber@meleeweb.net>2011-07-23 00:43:14 +0200
commit738a8ef09adf61de700d9711bee0d5451bbccdc0 (patch)
tree4870eebe699a2e24a3067665d4101ee3b06f2fb8 /sys-apps/dfc
parentmissing-links (diff)
downloadportage-738a8ef09adf61de700d9711bee0d5451bbccdc0.tar.xz
busybox dfc
Diffstat (limited to 'sys-apps/dfc')
-rw-r--r--sys-apps/dfc/dfc-9999.ebuild31
-rw-r--r--sys-apps/dfc/files/remount-sstrip.diff8
2 files changed, 39 insertions, 0 deletions
diff --git a/sys-apps/dfc/dfc-9999.ebuild b/sys-apps/dfc/dfc-9999.ebuild
new file mode 100644
index 00000000..06797e96
--- /dev/null
+++ b/sys-apps/dfc/dfc-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit git
+
+DESCRIPTION="Formilux Tools"
+HOMEPAGE="http://master.formilux.org/git/people/ben/dfc.git"
+EGIT_REPO_URI="http://master.formilux.org/git/people/ben/dfc.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND=""
+
+src_compile ()
+{
+# export DIET="/usr/bin/diet"
+# export OBJDUMP="$(tc-getPROG OBJDUMP objdump ${CHOST})"
+# export STRIP="$(tc-getSTRIP)"
+
+ emake || die "emake flx failed"
+}
+
+src_install ()
+{
+ into /usr
+ dobin dfc
+}
diff --git a/sys-apps/dfc/files/remount-sstrip.diff b/sys-apps/dfc/files/remount-sstrip.diff
new file mode 100644
index 00000000..a9ca6ef5
--- /dev/null
+++ b/sys-apps/dfc/files/remount-sstrip.diff
@@ -0,0 +1,8 @@
+--- remount/Makefile.ori 2009-04-24 13:54:14.000000000 +0200
++++ remount/Makefile 2009-04-24 13:54:59.000000000 +0200
+@@ -9,4 +9,4 @@
+ $(CC) $(LDFLAGS) $(CFLAGS) -o $@ $<
+ $(STRIP) -x --strip-unneeded -R .comment -R .note $@
+ $(OBJDUMP) -h $@ | grep -q '\.data[ ]*00000000' && $(STRIP) -R .data $@ || true
+- sstrip $@
++ -if [ -n "$(SSTRIP)" ]; then $(SSTRIP) $@ ; fi