summaryrefslogtreecommitdiff
path: root/perso/app-misc
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2005-03-05 00:48:01 +0000
committerBertrand Jacquin <beber@meleeweb.net>2005-03-05 00:48:01 +0000
commitadceee9580aab8459cfac42367bbba4b4d993a8a (patch)
tree52a6c32292f1d2da9273924000c229570d5dbb5e /perso/app-misc
parentModif sur sheebang (diff)
downloadportage-adceee9580aab8459cfac42367bbba4b4d993a8a.tar.xz
Move first cycling ebuild to others
Diffstat (limited to 'perso/app-misc')
-rw-r--r--perso/app-misc/cycling/ChangeLog4
-rw-r--r--perso/app-misc/cycling/Manifest9
-rw-r--r--perso/app-misc/cycling/cycling-0.3.3.ebuild34
-rw-r--r--perso/app-misc/cycling/cycling-0.3.4.ebuild3
-rw-r--r--perso/app-misc/cycling/files/cycling-0.3.3-gcc34.patch392
-rw-r--r--perso/app-misc/cycling/files/digest-cycling-0.3.31
6 files changed, 4 insertions, 439 deletions
diff --git a/perso/app-misc/cycling/ChangeLog b/perso/app-misc/cycling/ChangeLog
index 8175e5e0..bd405fca 100644
--- a/perso/app-misc/cycling/ChangeLog
+++ b/perso/app-misc/cycling/ChangeLog
@@ -5,8 +5,4 @@
16 Feb 2005; Bertrand Jacquin <beber.gentoo@gmail.com>
cycling-0.3.4.ebuild:
- Version Bump.
-
- 16 Feb 2005; Bertrand Jacquin <beber.gentoo@gmail.com>
- cycling-0.3.3.ebuild, cycling-0.3.3-gcc34.patch:
New Ebuild.
diff --git a/perso/app-misc/cycling/Manifest b/perso/app-misc/cycling/Manifest
index 58180a24..490dd953 100644
--- a/perso/app-misc/cycling/Manifest
+++ b/perso/app-misc/cycling/Manifest
@@ -1,7 +1,4 @@
-MD5 4e450577bac434f4d7d6c2e06844dad8 cycling-0.3.4.ebuild 674
-MD5 304728586e1fb8fa8a1a19fce577c81f cycling-0.3.3.ebuild 691
-MD5 84294ef4960759a402b3dafbf3d5f3ee ChangeLog 356
-MD5 06093ebe48949a45baafbdd2ac5235a1 metadata.xml 272
-MD5 eee04b2ae56ee1464180bcfca19b5395 files/cycling-0.3.3-gcc34.patch 14198
-MD5 26a3cffaf0b83d8b9215ee61ea32a280 files/digest-cycling-0.3.3 65
+MD5 6c0f8c52b09206c852d62df2515a6ddc cycling-0.3.4.ebuild 636
+MD5 0b367f182fba4891333ac471f6f98c02 ChangeLog 229
+MD5 a26b2af52a90ba476496df1f2b945e02 metadata.xml 252
MD5 75d9f6ca9adf50db96a5f31182ed878b files/digest-cycling-0.3.4 65
diff --git a/perso/app-misc/cycling/cycling-0.3.3.ebuild b/perso/app-misc/cycling/cycling-0.3.3.ebuild
deleted file mode 100644
index 99d47ac1..00000000
--- a/perso/app-misc/cycling/cycling-0.3.3.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit eutils
-
-DESCRIPTION="Cycling is a training management programme"
-HOMEPAGE="http://cycling.homelinux.org/en/index.xhtml"
-SRC_URI="http://cycling.homelinux.org/downloads/${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-DEPEND=">=x11-libs/gtk+-2.2.4-r1
- >=dev-libs/glib-2.2.3
- >=sys-devel/gettext-0.12.1
- >=dev-libs/libxml2-2.6.4
- >=media-libs/gdk-pixbuf-0.22.0-r2"
-S=${WORKDIR}/${P}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-gcc34.patch
-}
-
-src_compile() {
- econf || die
- emake || die
-}
-
-src_install() {
- einstall || die
-}
diff --git a/perso/app-misc/cycling/cycling-0.3.4.ebuild b/perso/app-misc/cycling/cycling-0.3.4.ebuild
index d1f3123e..daff86a8 100644
--- a/perso/app-misc/cycling/cycling-0.3.4.ebuild
+++ b/perso/app-misc/cycling/cycling-0.3.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Copyright 1999-2005 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -20,7 +20,6 @@ DEPEND=">=x11-libs/gtk+-2.2.4-r1
src_unpack() {
unpack ${A}
cd ${S}
- #epatch ${FILESDIR}/${P}-gcc34.patch
}
src_compile() {
diff --git a/perso/app-misc/cycling/files/cycling-0.3.3-gcc34.patch b/perso/app-misc/cycling/files/cycling-0.3.3-gcc34.patch
deleted file mode 100644
index c4f291a9..00000000
--- a/perso/app-misc/cycling/files/cycling-0.3.3-gcc34.patch
+++ /dev/null
@@ -1,392 +0,0 @@
---- src/circuits_gui.c.old 2004-04-24 00:52:46.925187384 +0100
-+++ src/circuits_gui.c 2004-04-24 01:00:21.812034072 +0100
-@@ -56,6 +56,186 @@
-
- /************************************************* callbacks *******************************************/
-
-+static CircuitEditEntries *
-+circuit_edit_entries_new (void)
-+{
-+ CircuitEditEntries *entries = g_new (CircuitEditEntries, 1);
-+
-+ GList *circuit_difficulty_list = NULL;
-+
-+ {
-+ entries->circuit_name_entry = gtk_entry_new ();
-+ gtk_entry_set_width_chars ( GTK_ENTRY (entries->circuit_name_entry), 20 );
-+ gtk_entry_set_max_length ( GTK_ENTRY (entries->circuit_name_entry), 50);
-+ entries->circuit_length_entry = gtk_spin_button_new_with_range (0.0, 999.99, 0.01);
-+
-+ /* initializing combo */
-+ entries->circuit_difficulty_combo = gtk_combo_new ();
-+ /* difficulty list */
-+ circuit_difficulty_list =
-+ g_list_append (circuit_difficulty_list, _("Very Easy"));
-+ circuit_difficulty_list =
-+ g_list_append (circuit_difficulty_list, _("Easy"));
-+ circuit_difficulty_list =
-+ g_list_append (circuit_difficulty_list, _("Average"));
-+ circuit_difficulty_list =
-+ g_list_append (circuit_difficulty_list, _("Hard"));
-+ circuit_difficulty_list =
-+ g_list_append (circuit_difficulty_list, _("Very hard"));
-+ gtk_combo_set_popdown_strings (GTK_COMBO (entries->circuit_difficulty_combo),
-+ circuit_difficulty_list);
-+
-+ entries->comment_add_button = gtk_button_new_with_label (_("Add"));
-+ }
-+
-+ return entries;
-+}
-+
-+static gulong
-+set_text_in_entries (CircuitEditEntries *entries)
-+{
-+ GtkTreeModel *model;
-+ GtkTreeIter iter;
-+ GtkTreeSelection *selection;
-+ gulong circuit_number = 0;
-+
-+ selection = gtk_tree_view_get_selection (GTK_TREE_VIEW (tree));
-+
-+ if (gtk_tree_selection_get_selected (selection, &model, &iter) ) {
-+ CyclingCircuit *circuit;
-+ CircuitsTreeData *circuit_data;
-+
-+ gtk_tree_model_get (model, &iter,
-+ 0, &circuit_data,
-+ -1);
-+
-+ circuit = read_circuit_infos_from_file (circuit_data->number);
-+ circuit_number = circuit_data->number;
-+
-+ gtk_entry_set_text (GTK_ENTRY (entries->circuit_name_entry),
-+ g_strdup (circuit->name));
-+ gtk_entry_set_text (GTK_ENTRY (GTK_COMBO (entries->circuit_difficulty_combo)->entry),
-+ g_strdup (circuit->difficulty));
-+ gtk_spin_button_set_value (GTK_SPIN_BUTTON (entries->circuit_length_entry),
-+ circuit->length);
-+
-+ if (circuit->comment != NULL) {
-+ set_comment_value (g_strdup (circuit->comment));
-+ gtk_button_set_label (GTK_BUTTON (entries->comment_add_button), _("Edit"));
-+ }
-+
-+ cycling_circuit_free (circuit);
-+ circuits_tree_data_free (circuit_data);
-+ }
-+
-+ return circuit_number;
-+}
-+
-+void
-+create_add_circuit_window (gboolean edit)
-+{
-+ GtkWidget *dialog_window;
-+ GtkWidget *table;
-+ GtkWidget *frame;
-+ GtkWidget *circuit_name_label;
-+ GtkWidget *circuit_length_label;
-+ GtkWidget *circuit_difficulty_label;
-+ GtkWidget *circuit_comment_label;
-+ CircuitEditEntries *entries=NULL;
-+ gint response, status = -1;
-+ gulong circuit_number = 0;
-+
-+
-+ dialog_window =
-+ gtk_dialog_new_with_buttons (_("Circuit addition"),
-+ GTK_WINDOW (cycling->cycling_window),
-+ GTK_DIALOG_MODAL,
-+ GTK_STOCK_CANCEL,
-+ GTK_RESPONSE_CANCEL,
-+ GTK_STOCK_SAVE,
-+ GTK_RESPONSE_OK,
-+ NULL );
-+ gtk_window_set_position ( GTK_WINDOW(dialog_window), GTK_WIN_POS_CENTER_ON_PARENT );
-+
-+ table = gtk_table_new (5, 4, FALSE);
-+ gtk_table_set_row_spacings ( GTK_TABLE(table), 5);
-+ frame = gtk_frame_new (_("Circuit addition"));
-+
-+ /* labels */
-+ circuit_length_label = gtk_label_new (_("Distance :"));
-+ circuit_name_label = gtk_label_new (_("Name :"));
-+ circuit_difficulty_label = gtk_label_new (_("Difficulty :"));
-+ circuit_comment_label = gtk_label_new (_("Comment :"));
-+
-+ /* create entry widgets */
-+ entries = circuit_edit_entries_new ();
-+ /* make sure the comment is not set */
-+ comment_free ();
-+
-+ /* and then set the values if edit = TRUE */
-+ if (edit == TRUE) {
-+ circuit_number = set_text_in_entries (entries);
-+ gtk_window_set_title (GTK_WINDOW (dialog_window), _("Circuit edition"));
-+ gtk_frame_set_label (GTK_FRAME (frame), _("Circuit edition"));
-+ }
-+
-+ gtk_container_add ( GTK_CONTAINER (GTK_DIALOG(dialog_window)->vbox), frame );
-+ gtk_widget_show ( frame );
-+ gtk_container_add ( GTK_CONTAINER (frame), table );
-+
-+ /* creating the table */
-+ {
-+ gtk_table_attach (GTK_TABLE (table), circuit_name_label, 0, 1, 0, 1,
-+ GTK_FILL, GTK_FILL, 0, 0);
-+ gtk_table_attach (GTK_TABLE (table), entries->circuit_name_entry, 1, 5, 0, 1,
-+ GTK_FILL, GTK_FILL, 0, 0);
-+ gtk_table_attach (GTK_TABLE (table), circuit_length_label, 0, 1 , 1, 2,
-+ GTK_FILL, GTK_FILL, 0, 0);
-+ gtk_table_attach (GTK_TABLE (table), entries->circuit_length_entry, 1, 2 , 1, 2,
-+ GTK_SHRINK, GTK_FILL, 0, 0);
-+
-+ gtk_table_attach (GTK_TABLE (table), circuit_difficulty_label, 0, 1, 2, 3,
-+ GTK_SHRINK, GTK_SHRINK, 0, 0);
-+ gtk_table_attach (GTK_TABLE (table), entries->circuit_difficulty_combo, 1, 5, 2, 3,
-+ GTK_SHRINK, GTK_SHRINK, 0, 0);
-+
-+ gtk_table_attach (GTK_TABLE (table), circuit_comment_label, 0, 1, 3, 4,
-+ GTK_SHRINK, GTK_SHRINK, 0, 0);
-+ gtk_table_attach (GTK_TABLE (table), entries->comment_add_button, 1, 2, 3, 4,
-+ GTK_SHRINK, GTK_SHRINK, 0, 0);
-+ }
-+
-+ g_signal_connect (G_OBJECT (entries->comment_add_button),
-+ "clicked",
-+ G_CALLBACK (create_edit_comment_window),
-+ NULL);
-+
-+
-+ gtk_widget_show_all ( table );
-+ gtk_widget_show ( dialog_window );
-+
-+ do {
-+ response = gtk_dialog_run ( GTK_DIALOG (dialog_window) );
-+
-+ switch ( response ) {
-+ case GTK_RESPONSE_OK :
-+ if (edit != TRUE) {
-+ status = add_circuit_to_list (entries);
-+ } else {
-+ status = edit_circuit_in_file_old (entries, circuit_number);
-+ }
-+ break;
-+ case GTK_RESPONSE_CANCEL :
-+ status = 1;
-+ break;
-+ default :
-+ break;
-+ }
-+ }while (status < 0);
-+
-+ gtk_widget_destroy ( dialog_window );
-+}
-+
- static void
- row_activated_in_circuits_list (GtkTreeView *treeview,
- GtkTreePath *path,
-@@ -64,7 +244,7 @@
- {
- /* when the user doubleclick on an item of the list we open
- the edition window */
-- create_add_circuit_window (TRUE);
-+ create_add_circuit_window (TRUE);
- }
-
- /*******************************************************************************************************/
-@@ -136,81 +316,6 @@
- return circuit_data;
- }
-
--static CircuitEditEntries *
--circuit_edit_entries_new (void)
--{
-- CircuitEditEntries *entries = g_new (CircuitEditEntries, 1);
--
-- GList *circuit_difficulty_list = NULL;
--
-- {
-- entries->circuit_name_entry = gtk_entry_new ();
-- gtk_entry_set_width_chars ( GTK_ENTRY (entries->circuit_name_entry), 20 );
-- gtk_entry_set_max_length ( GTK_ENTRY (entries->circuit_name_entry), 50);
-- entries->circuit_length_entry = gtk_spin_button_new_with_range (0.0, 999.99, 0.01);
--
-- /* initializing combo */
-- entries->circuit_difficulty_combo = gtk_combo_new ();
-- /* difficulty list */
-- circuit_difficulty_list =
-- g_list_append (circuit_difficulty_list, _("Very Easy"));
-- circuit_difficulty_list =
-- g_list_append (circuit_difficulty_list, _("Easy"));
-- circuit_difficulty_list =
-- g_list_append (circuit_difficulty_list, _("Average"));
-- circuit_difficulty_list =
-- g_list_append (circuit_difficulty_list, _("Hard"));
-- circuit_difficulty_list =
-- g_list_append (circuit_difficulty_list, _("Very hard"));
-- gtk_combo_set_popdown_strings (GTK_COMBO (entries->circuit_difficulty_combo),
-- circuit_difficulty_list);
--
-- entries->comment_add_button = gtk_button_new_with_label (_("Add"));
-- }
--
-- return entries;
--}
--
--static gulong
--set_text_in_entries (CircuitEditEntries *entries)
--{
-- GtkTreeModel *model;
-- GtkTreeIter iter;
-- GtkTreeSelection *selection;
-- gulong circuit_number = 0;
--
-- selection = gtk_tree_view_get_selection (GTK_TREE_VIEW (tree));
--
-- if (gtk_tree_selection_get_selected (selection, &model, &iter) ) {
-- CyclingCircuit *circuit;
-- CircuitsTreeData *circuit_data;
--
-- gtk_tree_model_get (model, &iter,
-- 0, &circuit_data,
-- -1);
--
-- circuit = read_circuit_infos_from_file (circuit_data->number);
-- circuit_number = circuit_data->number;
--
-- gtk_entry_set_text (GTK_ENTRY (entries->circuit_name_entry),
-- g_strdup (circuit->name));
-- gtk_entry_set_text (GTK_ENTRY (GTK_COMBO (entries->circuit_difficulty_combo)->entry),
-- g_strdup (circuit->difficulty));
-- gtk_spin_button_set_value (GTK_SPIN_BUTTON (entries->circuit_length_entry),
-- circuit->length);
--
-- if (circuit->comment != NULL) {
-- set_comment_value (g_strdup (circuit->comment));
-- gtk_button_set_label (GTK_BUTTON (entries->comment_add_button), _("Edit"));
-- }
--
-- cycling_circuit_free (circuit);
-- circuits_tree_data_free (circuit_data);
-- }
--
-- return circuit_number;
--}
--
- static void
- number_set_func (GtkTreeViewColumn *tree_column,
- GtkCellRenderer *cell,
-@@ -840,111 +945,6 @@
- }
-
- void
--create_add_circuit_window (gboolean edit)
--{
-- GtkWidget *dialog_window;
-- GtkWidget *table;
-- GtkWidget *frame;
-- GtkWidget *circuit_name_label;
-- GtkWidget *circuit_length_label;
-- GtkWidget *circuit_difficulty_label;
-- GtkWidget *circuit_comment_label;
-- CircuitEditEntries *entries=NULL;
-- gint response, status = -1;
-- gulong circuit_number = 0;
--
--
-- dialog_window =
-- gtk_dialog_new_with_buttons (_("Circuit addition"),
-- GTK_WINDOW (cycling->cycling_window),
-- GTK_DIALOG_MODAL,
-- GTK_STOCK_CANCEL,
-- GTK_RESPONSE_CANCEL,
-- GTK_STOCK_SAVE,
-- GTK_RESPONSE_OK,
-- NULL );
-- gtk_window_set_position ( GTK_WINDOW(dialog_window), GTK_WIN_POS_CENTER_ON_PARENT );
--
-- table = gtk_table_new (5, 4, FALSE);
-- gtk_table_set_row_spacings ( GTK_TABLE(table), 5);
-- frame = gtk_frame_new (_("Circuit addition"));
--
-- /* labels */
-- circuit_length_label = gtk_label_new (_("Distance :"));
-- circuit_name_label = gtk_label_new (_("Name :"));
-- circuit_difficulty_label = gtk_label_new (_("Difficulty :"));
-- circuit_comment_label = gtk_label_new (_("Comment :"));
--
-- /* create entry widgets */
-- entries = circuit_edit_entries_new ();
-- /* make sure the comment is not set */
-- comment_free ();
--
-- /* and then set the values if edit = TRUE */
-- if (edit == TRUE) {
-- circuit_number = set_text_in_entries (entries);
-- gtk_window_set_title (GTK_WINDOW (dialog_window), _("Circuit edition"));
-- gtk_frame_set_label (GTK_FRAME (frame), _("Circuit edition"));
-- }
--
-- gtk_container_add ( GTK_CONTAINER (GTK_DIALOG(dialog_window)->vbox), frame );
-- gtk_widget_show ( frame );
-- gtk_container_add ( GTK_CONTAINER (frame), table );
--
-- /* creating the table */
-- {
-- gtk_table_attach (GTK_TABLE (table), circuit_name_label, 0, 1, 0, 1,
-- GTK_FILL, GTK_FILL, 0, 0);
-- gtk_table_attach (GTK_TABLE (table), entries->circuit_name_entry, 1, 5, 0, 1,
-- GTK_FILL, GTK_FILL, 0, 0);
-- gtk_table_attach (GTK_TABLE (table), circuit_length_label, 0, 1 , 1, 2,
-- GTK_FILL, GTK_FILL, 0, 0);
-- gtk_table_attach (GTK_TABLE (table), entries->circuit_length_entry, 1, 2 , 1, 2,
-- GTK_SHRINK, GTK_FILL, 0, 0);
--
-- gtk_table_attach (GTK_TABLE (table), circuit_difficulty_label, 0, 1, 2, 3,
-- GTK_SHRINK, GTK_SHRINK, 0, 0);
-- gtk_table_attach (GTK_TABLE (table), entries->circuit_difficulty_combo, 1, 5, 2, 3,
-- GTK_SHRINK, GTK_SHRINK, 0, 0);
--
-- gtk_table_attach (GTK_TABLE (table), circuit_comment_label, 0, 1, 3, 4,
-- GTK_SHRINK, GTK_SHRINK, 0, 0);
-- gtk_table_attach (GTK_TABLE (table), entries->comment_add_button, 1, 2, 3, 4,
-- GTK_SHRINK, GTK_SHRINK, 0, 0);
-- }
--
-- g_signal_connect (G_OBJECT (entries->comment_add_button),
-- "clicked",
-- G_CALLBACK (create_edit_comment_window),
-- NULL);
--
--
-- gtk_widget_show_all ( table );
-- gtk_widget_show ( dialog_window );
--
-- do {
-- response = gtk_dialog_run ( GTK_DIALOG (dialog_window) );
--
-- switch ( response ) {
-- case GTK_RESPONSE_OK :
-- if (edit != TRUE) {
-- status = add_circuit_to_list (entries);
-- } else {
-- status = edit_circuit_in_file_old (entries, circuit_number);
-- }
-- break;
-- case GTK_RESPONSE_CANCEL :
-- status = 1;
-- break;
-- default :
-- break;
-- }
-- }while (status < 0);
--
-- gtk_widget_destroy ( dialog_window );
--}
--
--void
- display_circuit (gulong circuit_number)
- {
- create_circuit_infos_window (circuit_number);
diff --git a/perso/app-misc/cycling/files/digest-cycling-0.3.3 b/perso/app-misc/cycling/files/digest-cycling-0.3.3
deleted file mode 100644
index 2e246893..00000000
--- a/perso/app-misc/cycling/files/digest-cycling-0.3.3
+++ /dev/null
@@ -1 +0,0 @@
-MD5 f61f34a3d97221b20014a9e896c1e904 cycling-0.3.3.tar.gz 437117