summaryrefslogtreecommitdiff
path: root/net-proxy
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2010-07-06 00:31:24 +0200
committerBertrand Jacquin <beber@meleeweb.net>2010-07-06 00:31:24 +0200
commit293a31b958c8292a854d389a9fe9668fb8e73145 (patch)
tree0d27ab97b90af1372dc3ffd90f40c7a70ee0f942 /net-proxy
parentmailx for cross compile (diff)
downloadportage-293a31b958c8292a854d389a9fe9668fb8e73145.tar.xz
haproxy dev release
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/haproxy/haproxy-1.3.15.5.ebuild49
-rw-r--r--net-proxy/haproxy/haproxy-1.4_rc1.ebuild59
2 files changed, 108 insertions, 0 deletions
diff --git a/net-proxy/haproxy/haproxy-1.3.15.5.ebuild b/net-proxy/haproxy/haproxy-1.3.15.5.ebuild
new file mode 100644
index 00000000..db6c71d3
--- /dev/null
+++ b/net-proxy/haproxy/haproxy-1.3.15.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.3.15.5.ebuild,v 1.2 2009/01/10 15:06:57 maekke Exp $
+
+inherit eutils versionator
+
+DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
+HOMEPAGE="http://haproxy.1wt.eu"
+SRC_URI="http://haproxy.1wt.eu/download/$(get_version_component_range 1-2)/src/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="pcre"
+
+DEPEND="pcre? ( dev-libs/libpcre )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ local ARGS="TARGET=linux26"
+ use pcre && ARGS="${ARGS} REGEX=pcre"
+
+ emake ADDINC="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC="$(tc-getCC ${CTARGET})" ${ARGS} \
+ || die "emake failed"
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe haproxy
+ newinitd "${FILESDIR}/haproxy.initd" haproxy
+
+ # Don't install useless files
+ rm examples/build.cfg doc/*gpl.txt
+
+ dodoc CHANGELOG ROADMAP TODO doc/*.txt
+ docinto examples
+ dodoc examples/*.cfg
+}
+
+pkg_postinst() {
+ if [[ ! -f "${ROOT}/etc/haproxy.cfg" ]] ; then
+ einfo "You need to create /etc/haproxy.cfg before you start haproxy service."
+ if [[ -d "${ROOT}/usr/share/doc/${P}" ]]; then
+ einfo "Please consult the installed documentation for learning the configuration file's syntax."
+ einfo "The documentation and sample configuration files are installed here:"
+ einfo " ${ROOT}usr/share/doc/${P}"
+ fi
+ fi
+}
diff --git a/net-proxy/haproxy/haproxy-1.4_rc1.ebuild b/net-proxy/haproxy/haproxy-1.4_rc1.ebuild
new file mode 100644
index 00000000..b11b2c63
--- /dev/null
+++ b/net-proxy/haproxy/haproxy-1.4_rc1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.3.22-r1.ebuild,v 1.1 2009/12/05 09:04:28 mrness Exp $
+
+inherit versionator eutils
+
+DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
+HOMEPAGE="http://haproxy.1wt.eu"
+SRC_URI="http://haproxy.1wt.eu/download/$(get_version_component_range 1-2)/src/${P/_/-}.tar.gz"
+
+S=${WORKDIR}/${P/_/-}
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="pcre"
+
+DEPEND="pcre? ( dev-libs/libpcre )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup haproxy
+ enewuser haproxy -1 -1 -1 haproxy
+}
+
+src_compile() {
+ local ARGS="TARGET=linux26"
+ use pcre && ARGS="${ARGS} USE_PCRE=1"
+ use kernel_linux && ARGS="${ARGS} USE_LINUX_SPLICE=1"
+ use kernel_linux && ARGS="${ARGS} USE_LINUX_TPROXY=1"
+ emake ADDINC="${CFLAGS}" LDFLAGS="${LDFLAGS}" ${ARGS}
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe haproxy
+ newinitd "${FILESDIR}/haproxy.initd" haproxy
+
+ # Don't install useless files
+ rm examples/build.cfg doc/*gpl.txt
+
+ dodoc CHANGELOG ROADMAP TODO doc/*.txt
+ docinto examples
+ dodoc examples/*.cfg
+}
+
+pkg_postinst() {
+ if [[ ! -f "${ROOT}/etc/haproxy.cfg" ]] ; then
+ ewarn "You need to create /etc/haproxy.cfg before you start the haproxy service."
+ ewarn "It's best practice to not run haproxy as root, user and group haproxy was therefore created."
+ ewarn "Make use of them with the \"user\" and \"group\" directives."
+
+ if [[ -d "${ROOT}/usr/share/doc/${PF}" ]]; then
+ einfo "Please consult the installed documentation for learning the configuration file's syntax."
+ einfo "The documentation and sample configuration files are installed here:"
+ einfo " ${ROOT}usr/share/doc/${PF}"
+ fi
+ fi
+}